From: "Hogander, Jouni" <jouni.hogander@intel.com>
To: "Manna, Animesh" <animesh.manna@intel.com>,
"intel-gfx@lists.freedesktop.org"
<intel-gfx@lists.freedesktop.org>
Cc: "dri-devel@lists.freedesktop.org"
<dri-devel@lists.freedesktop.org>,
"Murthy, Arun R" <arun.r.murthy@intel.com>,
"Nikula, Jani" <jani.nikula@intel.com>
Subject: Re: [PATCH v3 4/6] drm/i915/alpm: Add compute config for lobf
Date: Fri, 3 May 2024 09:40:41 +0000 [thread overview]
Message-ID: <035b13047e35db6a46ce53b8be88b087c444124f.camel@intel.com> (raw)
In-Reply-To: <PH7PR11MB59811611ADCC1B3DCBEA3830F91F2@PH7PR11MB5981.namprd11.prod.outlook.com>
On Fri, 2024-05-03 at 08:42 +0000, Manna, Animesh wrote:
>
>
> > -----Original Message-----
> > From: Hogander, Jouni <jouni.hogander@intel.com>
> > Sent: Friday, May 3, 2024 12:49 PM
> > To: Manna, Animesh <animesh.manna@intel.com>; intel-
> > gfx@lists.freedesktop.org
> > Cc: dri-devel@lists.freedesktop.org; Murthy, Arun R
> > <arun.r.murthy@intel.com>; Nikula, Jani <jani.nikula@intel.com>
> > Subject: Re: [PATCH v3 4/6] drm/i915/alpm: Add compute config for
> > lobf
> >
> > On Thu, 2024-04-25 at 00:08 +0530, Animesh Manna wrote:
> > > Link Off Between Active Frames, is a new feature for eDP
> > > that allows the panel to go to lower power state after
> > > transmission of data. This is a feature on top of ALPM, AS SDP.
> > > Add compute config during atomic-check phase.
> > >
> > > v1: RFC version.
> > > v2: Add separate flag for auxless-alpm. [Jani]
> > > v3:
> > > - intel_dp->lobf_supported replaced with crtc_state->has_lobf.
> > > [Jouni]
> > > - Add DISPLAY_VER() check. [Jouni]
> > > - Modify function name of get_aux_less_status. [Jani]
> > >
> > > Signed-off-by: Animesh Manna <animesh.manna@intel.com>
> > > ---
> > > drivers/gpu/drm/i915/display/intel_alpm.c | 48
> > > +++++++++++++++++++
> > > drivers/gpu/drm/i915/display/intel_alpm.h | 5 ++
> > > .../drm/i915/display/intel_display_types.h | 4 ++
> > > drivers/gpu/drm/i915/display/intel_dp.c | 4 ++
> > > 4 files changed, 61 insertions(+)
> > >
> > > diff --git a/drivers/gpu/drm/i915/display/intel_alpm.c
> > > b/drivers/gpu/drm/i915/display/intel_alpm.c
> > > index 13bac3e8c8fa..3bb69ed16aab 100644
> > > --- a/drivers/gpu/drm/i915/display/intel_alpm.c
> > > +++ b/drivers/gpu/drm/i915/display/intel_alpm.c
> > > @@ -11,6 +11,16 @@
> > > #include "intel_dp_aux.h"
> > > #include "intel_psr_regs.h"
> > >
> > > +bool intel_alpm_get_aux_less_status(struct intel_dp *intel_dp)
> > > +{
> > > + u8 alpm_caps = 0;
> > > +
> > > + if (drm_dp_dpcd_readb(&intel_dp->aux,
> > > DP_RECEIVER_ALPM_CAP,
> > > + &alpm_caps) != 1)
> > > + return false;
> > > + return alpm_caps & DP_ALPM_AUX_LESS_CAP;
> > > +}
> > > +
> > > /*
> > > * See Bspec: 71632 for the table
> > > *
> > > @@ -242,6 +252,44 @@ bool intel_alpm_compute_params(struct
> > > intel_dp
> > > *intel_dp,
> > > return true;
> > > }
> > >
> > > +void intel_alpm_compute_lobf_config(struct intel_dp *intel_dp,
> > > + struct intel_crtc_state
> > > *crtc_state,
> > > + struct drm_connector_state
> > > *conn_state)
> > > +{
> > > + struct drm_i915_private *i915 = dp_to_i915(intel_dp);
> > > + struct drm_display_mode *adjusted_mode = &crtc_state-
> > > > hw.adjusted_mode;
> > > + int waketime_in_lines, first_sdp_position;
> > > + int context_latency, guardband;
> > > +
> > > + crtc_state->has_lobf = false;
> >
> > Drop this line. I think crtc_state is reset before doing this
> > compute_config
>
> Sure.
>
> >
> > > +
> > > + if (!intel_dp_is_edp(intel_dp))
> > > + return;
> > > +
> > > + if (DISPLAY_VER(i915) < 20)
> > > + return;
> > > +
> > > + if (!intel_dp_as_sdp_supported(intel_dp))
> > > + return;
> > > +
> > > + if (crtc_state->has_psr)
> > > + return;
> > > +
> > > + if (intel_alpm_compute_params(intel_dp, crtc_state)) {
> >
> > I think it is easier to read and helps avoiding big if blocks if
> > you:
> >
> > if (!intel_alpm_compute_params(intel_dp, crtc_state())
> > return;
>
> Ok.
>
> >
> > This actually brings up another thing: do we want to spread
> > intel_psr.c
> > pollution by continue using these boolean return values? I would
> > prefer
> > changing intel_alpm_compute_params return value to "normal" int
> > approach and return 0 on success. This would mean one more patch
> > changing it.
>
> Ok.
>
> >
> > > + context_latency = adjusted_mode-
> > > >crtc_vblank_start -
> > > adjusted_mode->crtc_vdisplay;
> > > + guardband = adjusted_mode->crtc_vtotal -
> > > + adjusted_mode->crtc_vdisplay -
> > > context_latency;
> > > + first_sdp_position = adjusted_mode->crtc_vtotal -
> > > adjusted_mode->crtc_vsync_start;
> > > + if (intel_dp-
> > > >alpm_parameters.auxless_alpm_supported)
> > > + waketime_in_lines = intel_dp-
> > > > alpm_parameters.io_wake_lines;
> > > + else
> > > + waketime_in_lines = intel_dp-
> > > > alpm_parameters.fast_wake_lines;
> > > +
> > > + if ((context_latency + guardband) >
> > > (first_sdp_position + waketime_in_lines))
> > > + crtc_state->has_lobf = true;
> >
> > crtc_state->has_lobf = (context_latency + guardband) >
> > (first_sdp_position + waketime_in_lines);
>
> Ok.
>
> >
> > > + }
> > > +}
> > > +
> > > static void lnl_alpm_configure(struct intel_dp *intel_dp)
> > > {
> > > struct drm_i915_private *dev_priv = dp_to_i915(intel_dp);
> > > diff --git a/drivers/gpu/drm/i915/display/intel_alpm.h
> > > b/drivers/gpu/drm/i915/display/intel_alpm.h
> > > index c45d078e5a6b..b9602b71d28f 100644
> > > --- a/drivers/gpu/drm/i915/display/intel_alpm.h
> > > +++ b/drivers/gpu/drm/i915/display/intel_alpm.h
> > > @@ -10,9 +10,14 @@
> > >
> > > struct intel_dp;
> > > struct intel_crtc_state;
> > > +struct drm_connector_state;
> > >
> > > +bool intel_alpm_get_aux_less_status(struct intel_dp *intel_dp);
> > > bool intel_alpm_compute_params(struct intel_dp *intel_dp,
> > > struct intel_crtc_state
> > > *crtc_state);
> > > +void intel_alpm_compute_lobf_config(struct intel_dp *intel_dp,
> > > + struct intel_crtc_state
> > > *crtc_state,
> > > + struct drm_connector_state
> > > *conn_state);
> > > void intel_alpm_configure(struct intel_dp *intel_dp);
> > >
> > > #endif
> > > diff --git a/drivers/gpu/drm/i915/display/intel_display_types.h
> > > b/drivers/gpu/drm/i915/display/intel_display_types.h
> > > index d94f50c6dc6c..5a0ffd5aa48b 100644
> > > --- a/drivers/gpu/drm/i915/display/intel_display_types.h
> > > +++ b/drivers/gpu/drm/i915/display/intel_display_types.h
> > > @@ -1405,6 +1405,9 @@ struct intel_crtc_state {
> > >
> > > /* for loading single buffered registers during vblank */
> > > struct drm_vblank_work vblank_work;
> > > +
> > > + /* LOBF flag */
> > > + bool has_lobf;
> > > };
> > >
> > > enum intel_pipe_crc_source {
> > > @@ -1835,6 +1838,7 @@ struct intel_dp {
> > > u8 fast_wake_lines;
> > >
> > > /* LNL and beyond */
> > > + bool auxless_alpm_supported;
> > > u8 check_entry_lines;
> > > u8 silence_period_sym_clocks;
> > > u8 lfps_half_cycle_num_of_syms;
> > > diff --git a/drivers/gpu/drm/i915/display/intel_dp.c
> > > b/drivers/gpu/drm/i915/display/intel_dp.c
> > > index e05e25cd4a94..563739c6014c 100644
> > > --- a/drivers/gpu/drm/i915/display/intel_dp.c
> > > +++ b/drivers/gpu/drm/i915/display/intel_dp.c
> > > @@ -48,6 +48,7 @@
> > > #include "i915_drv.h"
> > > #include "i915_irq.h"
> > > #include "i915_reg.h"
> > > +#include "intel_alpm.h"
> > > #include "intel_atomic.h"
> > > #include "intel_audio.h"
> > > #include "intel_backlight.h"
> > > @@ -2997,6 +2998,7 @@ intel_dp_compute_config(struct
> > > intel_encoder
> > > *encoder,
> > > intel_vrr_compute_config(pipe_config, conn_state);
> > > intel_dp_compute_as_sdp(intel_dp, pipe_config);
> > > intel_psr_compute_config(intel_dp, pipe_config,
> > > conn_state);
> > > + intel_alpm_compute_lobf_config(intel_dp, pipe_config,
> > > conn_state);
> > > intel_dp_drrs_compute_config(connector, pipe_config,
> > > link_bpp_x16);
> > > intel_dp_compute_vsc_sdp(intel_dp, pipe_config,
> > > conn_state);
> > > intel_dp_compute_hdr_metadata_infoframe_sdp(intel_dp,
> > > pipe_config, conn_state);
> > > @@ -6612,6 +6614,8 @@ static bool intel_edp_init_connector(struct
> > > intel_dp *intel_dp,
> > >
> > > intel_pps_init_late(intel_dp);
> > >
> > > + intel_dp->alpm_parameters.auxless_alpm_supported =
> > > intel_alpm_get_aux_less_status(intel_dp);
> >
> > How about aux_wake ?
>
> I felt auxless_alpm_supported will give both aux-less and aux-wake
> info, if it is true then aux-less otherwise aux-wake. Do you see any
> issue here?
If panel supports only AUX Wake?
BR,
Jouni Högander
>
> Regards,
> Animesh
> >
> > > +
> > > return true;
> > >
> > > out_vdd_off:
>
next prev parent reply other threads:[~2024-05-03 9:41 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-04-24 18:38 [PATCH v3 0/6] Link off between frames for edp Animesh Manna
2024-04-24 18:38 ` [PATCH v3 1/6] drm/i915/alpm: Move alpm parameters from intel_psr Animesh Manna
2024-04-24 18:38 ` [PATCH v3 2/6] drm/i915/alpm: Move alpm related code to a new file Animesh Manna
2024-04-26 7:55 ` kernel test robot
2024-04-24 18:38 ` [PATCH v3 3/6] drm/display: Add missing aux less alpm wake related bits Animesh Manna
2024-04-24 18:38 ` [PATCH v3 4/6] drm/i915/alpm: Add compute config for lobf Animesh Manna
2024-04-26 17:42 ` kernel test robot
2024-05-03 7:19 ` Hogander, Jouni
2024-05-03 8:42 ` Manna, Animesh
2024-05-03 9:40 ` Hogander, Jouni [this message]
2024-04-24 18:38 ` [PATCH v3 5/6] drm/i915/alpm: Enable lobf from source in ALPM_CTL Animesh Manna
2024-05-03 7:48 ` Hogander, Jouni
2024-05-03 8:19 ` Manna, Animesh
2024-05-03 9:33 ` Hogander, Jouni
2024-04-24 18:38 ` [PATCH v3 6/6] drm/i915/alpm: Add debugfs for LOBF Animesh Manna
2024-05-03 7:31 ` Hogander, Jouni
2024-05-03 8:30 ` Manna, Animesh
2024-05-03 9:37 ` Hogander, Jouni
2024-04-24 19:24 ` ✗ Fi.CI.CHECKPATCH: warning for Link off between frames for edp (rev3) Patchwork
2024-04-24 19:24 ` ✗ Fi.CI.SPARSE: " Patchwork
2024-04-24 19:30 ` ✓ Fi.CI.BAT: success " Patchwork
2024-04-25 13:55 ` ✗ Fi.CI.IGT: failure " Patchwork
2024-05-03 9:52 ` [PATCH v3 0/6] Link off between frames for edp Hogander, Jouni
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=035b13047e35db6a46ce53b8be88b087c444124f.camel@intel.com \
--to=jouni.hogander@intel.com \
--cc=animesh.manna@intel.com \
--cc=arun.r.murthy@intel.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jani.nikula@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.