From: Florian Fainelli <f.fainelli@gmail.com>
To: Vivien Didelot <vivien.didelot@savoirfairelinux.com>,
netdev@vger.kernel.org
Cc: linux-kernel@vger.kernel.org, kernel@savoirfairelinux.com,
"David S. Miller" <davem@davemloft.net>,
Andrew Lunn <andrew@lunn.ch>
Subject: Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port
Date: Fri, 29 Sep 2017 12:26:07 -0700 [thread overview]
Message-ID: <03cef84e-546d-d8c2-85fb-afc697ced2cb@gmail.com> (raw)
In-Reply-To: <20170929183635.8122-1-vivien.didelot@savoirfairelinux.com>
On 09/29/2017 11:36 AM, Vivien Didelot wrote:
> With DSA, a master net_device is physically wired to a dedicated CPU
> switch port. For interaction with the DSA layer, the struct net_device
> contains a dsa_ptr, which currently points to a dsa_switch_tree object.
>
> This is only valid for a switch fabric with a single CPU port. In order
> to support switch fabrics with multiple CPU ports, we first need to
> change the type of dsa_ptr to what it really is: a dsa_port object.
>
> This is what this patchset does. The first 4 patches cleans up portions
> of DSA core to make the next patches more readable. These next patches
> prepare the xmit and receive hot paths and finally change dsa_ptr.
This looks nice and clean, as mentioned in patch 5, there may be room
for organizing the structure a bit more efficiently such that everything
still fits within the first cacheline .
>
> Vivien Didelot (8):
> net: dsa: directly fetch switch in mtk_tag_rcv
> net: dsa: directly fetch switch in lan9303_rcv
> net: dsa: use cpu_dp in master code
> net: dsa: use temporary dsa_device_ops variable
> net: dsa: add tagging ops to port
> net: dsa: prepare master receive hot path
> net: dsa: change dsa_ptr for a dsa_port
> net: dsa: remove tag ops from the switch tree
>
> include/linux/netdevice.h | 4 ++--
> include/net/dsa.h | 19 ++++++++-----------
> net/dsa/dsa.c | 6 +++---
> net/dsa/dsa2.c | 15 ++++++++++-----
> net/dsa/dsa_priv.h | 7 +------
> net/dsa/legacy.c | 15 ++++++++++-----
> net/dsa/master.c | 47 ++++++++++++++++++++++-------------------------
> net/dsa/slave.c | 3 +--
> net/dsa/tag_brcm.c | 3 +--
> net/dsa/tag_dsa.c | 3 ++-
> net/dsa/tag_edsa.c | 3 ++-
> net/dsa/tag_ksz.c | 3 +--
> net/dsa/tag_lan9303.c | 6 ++----
> net/dsa/tag_mtk.c | 12 ++----------
> net/dsa/tag_qca.c | 3 +--
> net/dsa/tag_trailer.c | 3 +--
> 16 files changed, 69 insertions(+), 83 deletions(-)
>
--
Florian
next prev parent reply other threads:[~2017-09-29 19:26 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-09-29 18:36 [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot
2017-09-29 18:36 ` [PATCH net-next 1/8] net: dsa: directly fetch switch in mtk_tag_rcv Vivien Didelot
2017-09-29 19:21 ` Florian Fainelli
2017-09-29 18:36 ` [PATCH net-next 2/8] net: dsa: directly fetch switch in lan9303_rcv Vivien Didelot
2017-09-29 19:02 ` Florian Fainelli
2017-09-29 19:04 ` Vivien Didelot
2017-09-29 18:36 ` [PATCH net-next 3/8] net: dsa: use cpu_dp in master code Vivien Didelot
2017-09-29 19:10 ` Florian Fainelli
2017-09-29 18:36 ` [PATCH net-next 4/8] net: dsa: use temporary dsa_device_ops variable Vivien Didelot
2017-09-29 19:11 ` Florian Fainelli
2017-09-29 18:36 ` [PATCH net-next 5/8] net: dsa: add tagging ops to port Vivien Didelot
2017-09-29 19:12 ` Florian Fainelli
2017-09-29 19:24 ` Florian Fainelli
2017-09-29 18:36 ` [PATCH net-next 6/8] net: dsa: prepare master receive hot path Vivien Didelot
2017-09-29 19:14 ` Florian Fainelli
2017-09-29 18:36 ` [PATCH net-next 7/8] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot
2017-09-29 19:20 ` Florian Fainelli
2017-09-29 18:36 ` [PATCH net-next 8/8] net: dsa: remove tag ops from the switch tree Vivien Didelot
2017-09-29 19:20 ` Florian Fainelli
2017-09-29 19:26 ` Florian Fainelli [this message]
2017-09-29 19:34 ` [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port Vivien Didelot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=03cef84e-546d-d8c2-85fb-afc697ced2cb@gmail.com \
--to=f.fainelli@gmail.com \
--cc=andrew@lunn.ch \
--cc=davem@davemloft.net \
--cc=kernel@savoirfairelinux.com \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=vivien.didelot@savoirfairelinux.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.