From: Pradeep Jagadeesh <pradeep.jagadeesh@huawei.com>
To: Eric Blake <eblake@redhat.com>,
Pradeep Jagadeesh <pradeepkiruvale@gmail.com>,
greg kurz <groug@kaod.org>
Cc: alberto garcia <berto@igalia.com>,
jani kokkonen <jani.kokkonen@huawei.com>,
qemu-devel@nongnu.org
Subject: Re: [Qemu-devel] [PATCH v3 2/4] fsdev: QMP interface for throttling
Date: Thu, 4 May 2017 17:12:01 +0200 [thread overview]
Message-ID: <04bf2bd9-54af-161f-6fc6-e0fcd5c05406@huawei.com> (raw)
In-Reply-To: <c8b789ab-97d9-6bf6-e7bd-49b9260827ee@redhat.com>
On 5/3/2017 6:32 PM, Eric Blake wrote:
> On 05/03/2017 10:40 AM, Pradeep Jagadeesh wrote:
>> On 5/3/2017 12:13 AM, Eric Blake wrote:
>>> On 05/02/2017 09:29 AM, Pradeep Jagadeesh wrote:
>>>> This patchset enables qmp interfaces for the fsdev
>>>> devices. This provides two interfaces one
>>>> for querying info of all the fsdev devices. The second one
>>>> to set the IO limits for the required fsdev device.
>>>>
>>>> Signed-off-by: Pradeep Jagadeesh <pradeep.jagadeesh@huawei.com>
>>>> ---
>>>
>
>>>> +void fsdev_set_io_throttle(IOThrottle *arg, FsThrottle *fst, Error
>>>> **errp)
>>>> +{
>>>> + ThrottleConfig cfg;
>>>> +
>>>> + throttle_config_init(&cfg);
>>>> + cfg.buckets[THROTTLE_BPS_TOTAL].avg = arg->bps;
>>>> + cfg.buckets[THROTTLE_BPS_READ].avg = arg->bps_rd;
>>>> + cfg.buckets[THROTTLE_BPS_WRITE].avg = arg->bps_wr;
>>>> +
>>>> + cfg.buckets[THROTTLE_OPS_TOTAL].avg = arg->iops;
>>>> + cfg.buckets[THROTTLE_OPS_READ].avg = arg->iops_rd;
>>>> + cfg.buckets[THROTTLE_OPS_WRITE].avg = arg->iops_wr;
>>>> +
>>>> + if (arg->has_bps_max) {
>>>> + cfg.buckets[THROTTLE_BPS_TOTAL].max = arg->bps_max;
>>>> + }
>>>
>>> Should the bulk of this be replaced by a call to a common IOThrottle
>>> helper function, rather than open-coded duplication?
>> If we can reduce the duplicate code with a helper function its a good
>> idea. But I can not think of any ways of doing it. Any suggestions?
>
> In fact, you did exactly that in patch 3/4, which I argue should be
> rebased to occur in front of this patch to minimize the churn (in other
> words, when you add fsdev_set_io_throttle(), it should directly call the
> qmp_set_io_throttle() helper).
>
OK, done.
>
>>>> +void hmp_fsdev_set_io_throttle(Monitor *mon, const QDict *qdict)
>>>> +{
>>>> + Error *err = NULL;
>>>> + IOThrottle throttle = {
>>>> + .has_id = true,
>>>> + .id = (char *) qdict_get_str(qdict, "id"),
>>>> + .bps = qdict_get_int(qdict, "bps"),
>>>> + .bps_rd = qdict_get_int(qdict, "bps_rd"),
>>>> + .bps_wr = qdict_get_int(qdict, "bps_wr"),
>>>> + .iops = qdict_get_int(qdict, "iops"),
>>>> + .iops_rd = qdict_get_int(qdict, "iops_rd"),
>>>> + .iops_wr = qdict_get_int(qdict, "iops_wr"),
>>>
>>> Again, don't you need to be setting .has_bps=true and so on?
>> Same as above. I have not set any max burst values here, because I
>> wanted to keep it in line with the block device.
>> May be there is a room to enable these max values in both in future.
>
> I don't think you were getting the point of my question. Since 'bps' is
> an optional member of struct IOThrottle, you have to set 'has_bps' at
> the same time to make it obvious that 'bps' should affect things.
>
I need some more clarifications here.
I did not understand what do you mean by an optional parameter?
You mean I need to set "has_*" for all the parameters?
> I understand that you aren't setting 'bps_max', nor it's counterpart
> 'has_bps_max', and that's not what I was asking about.
>
>
>>>> +++ b/qapi/iothrottle.json
>>>> @@ -3,6 +3,7 @@
>>>> ##
>>>> # == QAPI IOThrottle definitions
>>>> ##
>>>> +##
>>>> # @IOThrottle:
>>>
>>> This looks like a spurious change
>> You mean the below sentence is not required?
>
> No, the above addition of a second ## is not required.
If I remove that I will get the compilation error.
I think the parser needs that.
-Pradeep
>
next prev parent reply other threads:[~2017-05-04 15:12 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-05-02 14:29 [Qemu-devel] [PATCH v3 0/4] fsdev: qmp interface for io throttling Pradeep Jagadeesh
2017-05-02 14:29 ` [Qemu-devel] [PATCH v3 1/4] Throttle: Create IOThrottle structure Pradeep Jagadeesh
2017-05-02 21:56 ` Eric Blake
2017-05-03 6:22 ` Greg Kurz
2017-05-03 14:19 ` Pradeep Jagadeesh
2017-05-03 17:10 ` Greg Kurz
2017-05-02 14:29 ` [Qemu-devel] [PATCH v3 2/4] fsdev: QMP interface for throttling Pradeep Jagadeesh
2017-05-02 22:13 ` Eric Blake
2017-05-03 15:40 ` Pradeep Jagadeesh
2017-05-03 16:32 ` Eric Blake
2017-05-04 15:12 ` Pradeep Jagadeesh [this message]
2017-05-04 15:19 ` Eric Blake
2017-05-05 11:09 ` Pradeep Jagadeesh
2017-05-02 14:29 ` [Qemu-devel] [PATCH v3 3/4] qmp: refactor duplicate code Pradeep Jagadeesh
2017-05-02 22:15 ` Eric Blake
2017-05-03 17:21 ` Greg Kurz
2017-05-04 9:44 ` Pradeep Jagadeesh
2017-05-02 14:29 ` [Qemu-devel] [PATCH v3 4/4] throttle: factor out " Pradeep Jagadeesh
2017-05-02 15:03 ` [Qemu-devel] [PATCH v3 0/4] fsdev: qmp interface for io throttling no-reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=04bf2bd9-54af-161f-6fc6-e0fcd5c05406@huawei.com \
--to=pradeep.jagadeesh@huawei.com \
--cc=berto@igalia.com \
--cc=eblake@redhat.com \
--cc=groug@kaod.org \
--cc=jani.kokkonen@huawei.com \
--cc=pradeepkiruvale@gmail.com \
--cc=qemu-devel@nongnu.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.