From: Ping-Ke Shih <pkshih@realtek.com>
To: Bitterblue Smith <rtl8821cerfe2@gmail.com>,
"linux-wireless@vger.kernel.org" <linux-wireless@vger.kernel.org>
Subject: RE: [PATCH rtw-next v1 02/13] wifi: rtw89: Get dle_mem via rtw89_hci_dle_mem()
Date: Mon, 26 May 2025 02:52:28 +0000 [thread overview]
Message-ID: <102d0c86fee74eba9bcc761df10b935e@realtek.com> (raw)
In-Reply-To: <83a7ade0-2c9a-4148-b998-db52e05587b8@gmail.com>
Bitterblue Smith <rtl8821cerfe2@gmail.com> wrote:
> On 14/05/2025 03:56, Ping-Ke Shih wrote:
> > Bitterblue Smith <rtl8821cerfe2@gmail.com> wrote:
> >> Don't access dle_mem in get_dle_mem_cfg() directly. USB 2, USB 3, and
> >> SDIO will need different sets of values.
> >>
> >> Rename dle_mem in struct rtw89_chip_info to dle_mem_pcie and get it
> >> via rtw89_hci_dle_mem() and rtw89_pci_ops_dle_mem().
> >>
> >> Signed-off-by: Bitterblue Smith <rtl8821cerfe2@gmail.com>
> >> ---
> >> drivers/net/wireless/realtek/rtw89/core.h | 10 +++++++++-
> >> drivers/net/wireless/realtek/rtw89/mac.c | 2 +-
> >> drivers/net/wireless/realtek/rtw89/pci.c | 8 ++++++++
> >> drivers/net/wireless/realtek/rtw89/rtw8851b.c | 2 +-
> >> drivers/net/wireless/realtek/rtw89/rtw8852a.c | 2 +-
> >> drivers/net/wireless/realtek/rtw89/rtw8852b.c | 2 +-
> >> drivers/net/wireless/realtek/rtw89/rtw8852bt.c | 2 +-
> >> drivers/net/wireless/realtek/rtw89/rtw8852c.c | 2 +-
> >> drivers/net/wireless/realtek/rtw89/rtw8922a.c | 2 +-
> >> 9 files changed, 24 insertions(+), 8 deletions(-)
> >>
> >> diff --git a/drivers/net/wireless/realtek/rtw89/core.h b/drivers/net/wireless/realtek/rtw89/core.h
> >> index be1259cfa712..afcf0353a625 100644
> >> --- a/drivers/net/wireless/realtek/rtw89/core.h
> >> +++ b/drivers/net/wireless/realtek/rtw89/core.h
> >> @@ -3579,6 +3579,8 @@ struct rtw89_hci_ops {
> >> void (*disable_intr)(struct rtw89_dev *rtwdev);
> >> void (*enable_intr)(struct rtw89_dev *rtwdev);
> >> int (*rst_bdram)(struct rtw89_dev *rtwdev);
> >
> > an empty line
> >
> >> + const struct rtw89_dle_mem *(*dle_mem)(struct rtw89_dev *rtwdev,
> >> + u8 qta_mode);
> >> };
> >>
> >> struct rtw89_hci_info {
> >> @@ -4271,7 +4273,7 @@ struct rtw89_chip_info {
> >> bool dis_2g_40m_ul_ofdma;
> >> u32 rsvd_ple_ofst;
> >> const struct rtw89_hfc_param_ini *hfc_param_ini;
> >> - const struct rtw89_dle_mem *dle_mem;
> >> + const struct rtw89_dle_mem *dle_mem_pcie;
> >
> > I reconsider if this can be an array with a new enum = {PCIE, USB2, USB3, SDIO}
> > stored in hal->hci_dle_mem_type. Then, consumers can just access it via
> > chip->dle_mem[hal->hci_dle_mem_type][quota]. But, I'm not sure if USB
> > subsystem can notify driver when USB speed is changed.
> >
> > This is a thought to simply the struct definition.
> >
>
> The hard part is naming the new enum. It's basically rtw89_hci_type
> but more detailed.
If it only used by DLE, maybe rtw89_hci_dle_type is fine?
>
> I don't expect the USB speed to change during the lifetime of struct
> rtw89_dev. When the device switches from USB 2 to USB 3 it disconnects
> and reappears as a new device:
So seemingly it is workable to store the USB speed in a variable at USB probe.
Please try if it looks good.
>
> Apr 21 22:02:22 ideapad2 kernel: usb 1-4: new high-speed USB device number 17 using xhci_hcd
> Apr 21 22:02:22 ideapad2 kernel: usb 1-4: New USB device found, idVendor=0bda, idProduct=c832, bcdDevice=
> 0.00
> Apr 21 22:02:22 ideapad2 kernel: usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
> Apr 21 22:02:22 ideapad2 kernel: usb 1-4: Product: 802.11ax WLAN Adapter
> Apr 21 22:02:22 ideapad2 kernel: usb 1-4: Manufacturer: Realtek
> Apr 21 22:02:22 ideapad2 kernel: usb 1-4: SerialNumber: 00e04c000001
> Apr 21 22:02:24 ideapad2 kernel: eric-tx CALL alloc_txring !!!!
> Apr 21 22:02:24 ideapad2 kernel: usb 1-4: USB disconnect, device number 17
> Apr 21 22:02:24 ideapad2 kernel: rtl8852cu 1-4:1.0: Runtime PM usage count underflow!
>
> Apr 21 22:02:27 ideapad2 kernel: usb 2-4: new SuperSpeed USB device number 2 using xhci_hcd
> Apr 21 22:02:27 ideapad2 kernel: usb 2-4: New USB device found, idVendor=0bda, idProduct=c832, bcdDevice=
> 0.00
> Apr 21 22:02:28 ideapad2 kernel: usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
> Apr 21 22:02:28 ideapad2 kernel: usb 2-4: Product: 802.11ax WLAN Adapter
> Apr 21 22:02:28 ideapad2 kernel: usb 2-4: Manufacturer: Realtek
> Apr 21 22:02:28 ideapad2 kernel: usb 2-4: SerialNumber: 00e04c000001
> Apr 21 22:02:28 ideapad2 kernel: eric-tx CALL alloc_txring !!!!
> Apr 21 22:02:28 ideapad2 kernel: rtl8852cu 2-4:1.0 wlp3s0f3u4: renamed from wlan0
>
next prev parent reply other threads:[~2025-05-26 2:52 UTC|newest]
Thread overview: 47+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-04 20:47 [PATCH rtw-next v1 00/13] wifi: rtw89: Add support for USB devices Bitterblue Smith
2025-05-04 20:49 ` [PATCH rtw-next v1 01/13] wifi: rtw89: 8851b: Accept USB devices and load their MAC address Bitterblue Smith
2025-05-13 2:46 ` Ping-Ke Shih
2025-05-04 20:49 ` [PATCH rtw-next v1 02/13] wifi: rtw89: Get dle_mem via rtw89_hci_dle_mem() Bitterblue Smith
2025-05-13 2:51 ` Ping-Ke Shih
2025-05-14 0:56 ` Ping-Ke Shih
2025-05-25 22:04 ` Bitterblue Smith
2025-05-26 2:52 ` Ping-Ke Shih [this message]
2025-05-04 20:49 ` [PATCH rtw-next v1 03/13] wifi: rtw89: Rename hfc_param_ini to hfc_param_ini_pcie Bitterblue Smith
2025-05-13 3:04 ` Ping-Ke Shih
2025-05-04 20:50 ` [PATCH rtw-next v1 04/13] wifi: rtw89: Add dle_mem_usb2 and dle_mem_usb3 Bitterblue Smith
2025-05-13 3:06 ` Ping-Ke Shih
2025-05-04 20:51 ` [PATCH rtw-next v1 05/13] wifi: rtw89: Add hfc_param_ini_usb Bitterblue Smith
2025-05-13 3:12 ` Ping-Ke Shih
2025-05-25 21:55 ` Bitterblue Smith
2025-05-26 1:51 ` Ping-Ke Shih
2025-05-26 6:29 ` Ping-Ke Shih
2025-05-31 20:57 ` Bitterblue Smith
2025-05-31 20:54 ` Bitterblue Smith
2025-05-04 20:51 ` [PATCH rtw-next v1 06/13] wifi: rtw89: Disable some power saving for USB Bitterblue Smith
2025-05-13 3:27 ` Ping-Ke Shih
2025-05-25 21:57 ` Bitterblue Smith
2025-05-26 2:36 ` Ping-Ke Shih
2025-05-04 20:51 ` [PATCH rtw-next v1 07/13] wifi: rtw89: Add extra TX headroom " Bitterblue Smith
2025-05-13 3:28 ` Ping-Ke Shih
2025-05-04 20:52 ` [PATCH rtw-next v1 08/13] wifi: rtw89: Hide some errors when the device is unplugged Bitterblue Smith
2025-05-13 3:43 ` Ping-Ke Shih
2025-05-25 21:58 ` Bitterblue Smith
2025-05-04 20:52 ` [PATCH rtw-next v1 09/13] wifi: rtw89: Fix rtw89_mac_power_switch() for USB Bitterblue Smith
2025-05-13 3:50 ` Ping-Ke Shih
2025-05-25 21:58 ` Bitterblue Smith
2025-05-26 2:45 ` Ping-Ke Shih
2025-05-04 20:53 ` [PATCH rtw-next v1 10/13] wifi: rtw89: Add some definitions " Bitterblue Smith
2025-05-13 3:52 ` Ping-Ke Shih
2025-05-04 20:54 ` [PATCH rtw-next v1 11/13] wifi: rtw89: Add usb.{c,h} Bitterblue Smith
2025-05-13 6:12 ` Ping-Ke Shih
2025-05-25 22:03 ` Bitterblue Smith
2025-05-26 3:18 ` Ping-Ke Shih
2025-05-31 21:03 ` Bitterblue Smith
2025-05-04 20:54 ` [PATCH rtw-next v1 12/13] wifi: rtw89: Add rtw8851bu.c Bitterblue Smith
2025-05-13 6:14 ` Ping-Ke Shih
2025-05-04 20:55 ` [PATCH rtw-next v1 13/13] wifi: rtw89: Enable the new USB modules Bitterblue Smith
2025-05-13 6:14 ` Ping-Ke Shih
2025-05-13 6:22 ` [PATCH rtw-next v1 00/13] wifi: rtw89: Add support for USB devices Ping-Ke Shih
2025-05-13 7:07 ` Ping-Ke Shih
2025-05-25 22:03 ` Bitterblue Smith
2025-05-26 1:35 ` Ping-Ke Shih
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=102d0c86fee74eba9bcc761df10b935e@realtek.com \
--to=pkshih@realtek.com \
--cc=linux-wireless@vger.kernel.org \
--cc=rtl8821cerfe2@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.