All of lore.kernel.org
 help / color / mirror / Atom feed
From: Harvey Harrison <harvey.harrison@gmail.com>
To: David Miller <davem@davemloft.net>
Cc: akpm@linux-foundation.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/2] byteorder: eliminate pointer bytorder api
Date: Tue, 20 May 2008 15:30:19 -0700	[thread overview]
Message-ID: <1211322619.5915.218.camel@brick> (raw)
In-Reply-To: <20080520.151951.239145609.davem@davemloft.net>

On Tue, 2008-05-20 at 15:19 -0700, David Miller wrote:
> From: Harvey Harrison <harvey.harrison@gmail.com>
> Date: Tue, 20 May 2008 15:15:25 -0700
> 
> > Obviously I missed that part, my apologies.  Would it be acceptable if,
> > taking the possibly arch-specific parts, moved the [endian]_to_cpup
> > name over to get_[endian]
> 
> Why are we fiddling with interface names that have been fine for about
> 10 years?

Saw a lot of (or similar in a private helper):

*(__be32 *)ptr = cpu_to_be32(val);

So I came up with

void put_be32(val, ptr);

This looked a lot like the put_unaligned_be32 helpers and only left a
gap that was get_be32(ptr).

But this was exactly the same as the existing be32_to_cpup, so I wasn't
sure if I should add it or not.  In the end I just went ahead and did
it and wanted to see what the patch would be like moving over existing
users to the new api looked like.

On top of that I did the cpu_to_be32p removal, which probably was not
the brightest thing ever.

So, that leaves (repeat for various endian values, be32 is an example):

1) should put_be32(val, ptr) be added (it seems useful and lots of code
is already rolling their own if they aren't opencoding it)

2) should get_be32 be added purely to have a symmetric api, even through
it is equivalent to be32_to_cpup? (nice that it looks just like
get_unaligned_be32...makes alignment explicit)

3) if 2) should existiing be32_to_cpup users be moved over to the new
api

4) if 3) should cpu_to_be32p be moved/changed at all (unlikely)

I hope that explains where I was coming from with this set of patches.

Harvey




  reply	other threads:[~2008-05-20 22:30 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-05-20 19:24 [PATCH 2/2] byteorder: eliminate pointer bytorder api Harvey Harrison
2008-05-20 21:17 ` David Miller
2008-05-20 22:15   ` Harvey Harrison
2008-05-20 22:19     ` David Miller
2008-05-20 22:30       ` Harvey Harrison [this message]
2008-05-26 12:17         ` Jan Engelhardt
2008-05-27 22:40           ` Harvey Harrison

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1211322619.5915.218.camel@brick \
    --to=harvey.harrison@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=davem@davemloft.net \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.