All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Linux PM <linux-pm@vger.kernel.org>
Cc: LKML <linux-kernel@vger.kernel.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Lukasz Luba <lukasz.luba@arm.com>,
	Daniel Lezcano <daniel.lezcano@linaro.org>,
	Srinivas Pandruvada <srinivas.pandruvada@linux.intel.com>,
	Zhang Rui <rui.zhang@intel.com>
Subject: [PATCH v2 0/5] thermal: core: Assorted improvements for v6.11
Date: Tue, 28 May 2024 18:47:33 +0200	[thread overview]
Message-ID: <12458899.O9o76ZdvQC@kreacher> (raw)

Hi Everyone,

This is an update of

https://lore.kernel.org/linux-pm/13518388.uLZWGnKmhe@kreacher/

which mostly is a rebase on top of the recent fixes:

https://lore.kernel.org/linux-pm/12438941.O9o76ZdvQC@kreacher/

and the first patch from v1 is gone it turned out to be controversial (I will
be sending a new version of it separately).

The patches in the series address some shortcomings in the thermal
core code (including the Bang-Bang governor) and clean it up somewhat.

Please refer to the individual patch changelogs for details.

This series is independent of the thermal debugfs one posted earlier today:

https://lore.kernel.org/linux-pm/5794974.DvuYhMxLoT@kreacher/

At one point I'm going to put this series on a git branch for easier
access/testing.

Thanks!




             reply	other threads:[~2024-05-28 16:54 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-05-28 16:47 Rafael J. Wysocki [this message]
2024-05-28 16:50 ` [PATCH v2 1/5] thermal: trip: Rename __thermal_zone_set_trips() to thermal_zone_set_trips() Rafael J. Wysocki
2024-06-10 13:54   ` Daniel Lezcano
2024-05-28 16:51 ` [PATCH v2 2/5] thermal: trip: Make thermal_zone_set_trips() use trip thresholds Rafael J. Wysocki
2024-06-10 18:01   ` Daniel Lezcano
2024-06-11 18:43     ` Rafael J. Wysocki
2024-05-28 16:52 ` [PATCH v2 3/5] thermal: trip: Use READ_ONCE() for lockless access to trip properties Rafael J. Wysocki
2024-05-28 16:54 ` [PATCH v2 4/5] thermal: gov_bang_bang: Drop unnecessary cooling device target state checks Rafael J. Wysocki
2024-05-28 16:54 ` [PATCH v2 5/5] thermal: core: Avoid calling .trip_crossed() for critical and hot trips Rafael J. Wysocki

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=12458899.O9o76ZdvQC@kreacher \
    --to=rjw@rjwysocki.net \
    --cc=daniel.lezcano@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=lukasz.luba@arm.com \
    --cc=rafael@kernel.org \
    --cc=rui.zhang@intel.com \
    --cc=srinivas.pandruvada@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.