All of lore.kernel.org
 help / color / mirror / Atom feed
From: Arnd Bergmann <arnd@arndb.de>
To: Thomas Gleixner <tglx@linutronix.de>
Cc: Heena Sirwani <heenasirwani@gmail.com>,
	linux-kernel@vger.kernel.org, john.stultz@linaro.org
Subject: Re: [PATCH v5] timekeeping: Added a function to return tv_sec portion of ktime_get_ts64()
Date: Sat, 25 Oct 2014 17:39:38 +0200	[thread overview]
Message-ID: <12462229.Mz3a4d4AP9@wuerfel> (raw)
In-Reply-To: <alpine.DEB.2.11.1410251714460.5308@nanos>

On Saturday 25 October 2014 17:22:23 Thomas Gleixner wrote:
> On Sat, 25 Oct 2014, Thomas Gleixner wrote:
> > On Sat, 25 Oct 2014, Heena Sirwani wrote:
> > > +time64_t ktime_get_seconds(void)
> > > +{
> > > +   time64_t ts;
> > > +   struct timekeeper *tk = &tk_core.timekeeper;
> > > +   struct timespec64 tomono;
> > > +   s32 nsec;
> > > +   unsigned int seq;
> > > +
> > > +   WARN_ON(timekeeping_suspended);
> > > +
> > > +   do {
> > > +           seq = read_seqcount_begin(&tk_core.seq);
> > > +           ts = tk->xtime_sec;
> > > +           nsec = (long)(tk->tkr.xtime_nsec >> tk->tkr.shift);
> > > +           tomono = tk->wall_to_monotonic;
> > > +
> > > +   } while (read_seqcount_retry(&tk_core.seq, seq));
> > > +
> > > +   ts += tomono.tv_sec;
> > > +   if (nsec + tomono.tv_nsec >= NSEC_PER_SEC)
> > > +           ts += 1;
> > > +   return ts;
> > 
> > I'd rather have an extra field in the timekeeper
> > 
> >     u64 xtime_sec;
> > +   u64 ktime_sec;
> > 
> > and update this in tk_update_ktime_data() so the readout function
> > boils down to
> > 
> > time64_t ktime_get_seconds(void)
> > {
> > #if BITS_PER_LONG < 64
> >       u64 sec;
> >       int seq;
> > 
> >       do {
> >               seq = read_seqcount_begin(&tk_core.seq);
> >               sec = tk->ktime_sec;
> >       } while (read_seqcount_retry(&tk_core.seq, seq));
> > 
> >       return sec;
> > #else
> >       return tk->ktime_sec;
> > #endif
> > }
> > 
> > So 64bit can do w/o the seqcount and 32bit avoids all extra math, right?
> 
> Hmm. Thinking more about it. That's actually overkill. For ktime_sec a
> 32bit value is plenty enough unless we care about systems with more
> than 136 years uptime. So if we calculate the seconds value of ktime,
> i.e. CLOCK_MONOTONIC, in the update function, we can read it on both
> 32 and 64bit w/o the seqcount loop.

Ah, very good point. That opens the question which type that function
should return. I really want to remove all uses of time_t from the
kernel, mostly so we know when we're done with this. However as you
say we know that we only need a 32-bit value here. Some possible
ideas:

- use time64_t here anyway and accept the slight inefficiency in return
  for clarity
- introduce a monotonic_time_t (we probably also want a struct
  monotonic_timespec if we do that) which is basically the old time_t
  but is known to be y2038 safe because we only ever use it to store
  monotonic times.
- return u32 and use the same type in the callers instead of
  time_t/time64_t/monotonic_time_t.

> Where we really need the above readout mechanism is get_seconds() as
> that will break in 2038 on 32bit. So there you need to change the
> return value from unsigned long to time64_t and change the
> implementation as above just xtime_sec instead of ktime_sec.

Heena already posted a first draft of that patch to the opw internal
mailing list, I found a small issue that needs to be resolved and
then she can post the new version to you for review.

	Arnd

  reply	other threads:[~2014-10-25 18:24 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-10-25 12:34 [PATCH v5] timekeeping: Added a function to return tv_sec portion of ktime_get_ts64() Heena Sirwani
2014-10-25 15:12 ` Thomas Gleixner
2014-10-25 15:22   ` Thomas Gleixner
2014-10-25 15:39     ` Arnd Bergmann [this message]
2014-10-25 17:32       ` Thomas Gleixner
2014-10-26 20:34         ` Arnd Bergmann
2014-10-28 11:26           ` Thomas Gleixner
2014-10-28 13:21             ` Arnd Bergmann
2014-10-26 21:01   ` Arnd Bergmann
2014-10-27 21:21     ` Thomas Gleixner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=12462229.Mz3a4d4AP9@wuerfel \
    --to=arnd@arndb.de \
    --cc=heenasirwani@gmail.com \
    --cc=john.stultz@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.