From: "Sebastian Herbszt" <herbszt@gmx.de>
To: Stuart Brady <sdb@zubnet.me.uk>, qemu-devel@nongnu.org
Subject: [Qemu-devel] Re: Re: [RFC] [PATCH] add ahci support into qemu
Date: Thu, 6 May 2010 21:10:18 +0200 [thread overview]
Message-ID: <1296B50E61914D0290D02B8FBDDC5494@FSCPC> (raw)
In-Reply-To: <20100505193716.GA5982@zubnet.me.uk>
Stuart Brady wrote:
> On Tue, May 04, 2010 at 10:51:37PM +0200, Sebastian Herbszt wrote:
>> >diff --git a/hw/pci_ids.h b/hw/pci_ids.h
>> >index fe7a121..4d4de93 100644
>> >--- a/hw/pci_ids.h
>> >+++ b/hw/pci_ids.h
>> >@@ -97,3 +97,4 @@
>> >#define PCI_DEVICE_ID_INTEL_82371AB 0x7111
>> >#define PCI_DEVICE_ID_INTEL_82371AB_2 0x7112
>> >#define PCI_DEVICE_ID_INTEL_82371AB_3 0x7113
>> >+#define PCI_DEVICE_ID_INTEL_ICH6R_AHCI 0x2652
>>
>> The list is sorted by vendor and device id. This entry should go
>> after "PCI_DEVICE_ID_INTEL_ESB_9". The naming scheme seems
>> to be VENDOR_DEVICE_FUNCTION, so i suggest something like
>> PCI_DEVICE_ID_INTEL_ICH6R_2 or PCI_DEVICE_ID_INTEL_82801FR_2.
>
> Linux seems to have called this PCI_DEVICE_ID_INTEL_ICH6_4 at one point.
>
> So this should be function 4, no?
Well, i am not sure if the last part is the function number. pci_ids.h from the linux
kernel got this:
#define PCI_DEVICE_ID_INTEL_ICH6_0 0x2640
#define PCI_DEVICE_ID_INTEL_ICH6_1 0x2641
#define PCI_DEVICE_ID_INTEL_ICH6_2 0x2642
#define PCI_DEVICE_ID_INTEL_ICH6_16 0x266a
#define PCI_DEVICE_ID_INTEL_ICH6_17 0x266d
#define PCI_DEVICE_ID_INTEL_ICH6_18 0x266e
#define PCI_DEVICE_ID_INTEL_ICH6_19 0x266f
According to the Intel spec the SATA controller is D31:F2. So we got device 31
and function 2. The IDE controller is D31:F1, but above it's ICH6_19.
Sebastian
> Cheers,
> --
> Stuart Brady
>
>
>
next prev parent reply other threads:[~2010-05-06 19:11 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-04-30 12:48 [Qemu-devel] add ahci support into qemu 乔崇
2010-05-02 8:05 ` Alexander Graf
2010-05-02 12:52 ` [Qemu-devel] [RFC] [PATCH] " 乔崇
2010-05-02 15:36 ` [Qemu-devel] " Sebastian Herbszt
2010-05-02 15:49 ` Avi Kivity
2010-05-02 15:56 ` Elek Roland
2010-05-03 21:08 ` Elek Roland
2010-05-04 20:56 ` Sebastian Herbszt
2010-05-02 22:13 ` Sebastian Herbszt
2010-05-04 1:07 ` 乔崇
2010-05-04 20:51 ` Sebastian Herbszt
2010-05-05 19:37 ` Stuart Brady
2010-05-06 19:10 ` Sebastian Herbszt [this message]
2010-05-04 0:01 ` Alexander Graf
2010-05-04 0:28 ` 乔崇
2010-05-09 19:16 ` Alexander Graf
2010-05-10 11:24 ` 乔崇
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1296B50E61914D0290D02B8FBDDC5494@FSCPC \
--to=herbszt@gmx.de \
--cc=qemu-devel@nongnu.org \
--cc=sdb@zubnet.me.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.