From: Tomi Valkeinen <tomi.valkeinen@ti.com>
To: Mythri P K <mythripk@ti.com>
Cc: linux-omap@vger.kernel.org
Subject: Re: [PATCH 3/8] OMAP4: DSS: HDMI: Use specific HDMI timings structure
Date: Thu, 23 Jun 2011 11:30:43 +0300 [thread overview]
Message-ID: <1308817843.1834.40.camel@deskari> (raw)
In-Reply-To: <1308298637-29753-4-git-send-email-mythripk@ti.com>
On Fri, 2011-06-17 at 13:47 +0530, Mythri P K wrote:
> Define new HDMI timings structure to replace the OMAP DSS timing strucutre in hdmi.c
> to have the HDMI include defintion out of DSS.
>
> Signed-off-by: Mythri P K <mythripk@ti.com>
> ---
> drivers/video/omap2/dss/hdmi.c | 23 ++++++++++++++++++++---
> drivers/video/omap2/dss/hdmi.h | 15 ++++++++++++++-
> 2 files changed, 34 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/video/omap2/dss/hdmi.c b/drivers/video/omap2/dss/hdmi.c
> index 4ee879a..c24d573 100644
> --- a/drivers/video/omap2/dss/hdmi.c
> +++ b/drivers/video/omap2/dss/hdmi.c
> @@ -593,6 +593,20 @@ static int read_edid(struct hdmi_ip_data *ip_data, u8 *pedid, u16 max_length)
> return 0;
> }
>
> +static void copy_hdmi_to_dss_timings(struct hdmi_video_timings hdmi_timings,
> + struct omap_video_timings *timings)
There's no reason to pass hdmi_timings as a value, so it should be a
pointer.
> +{
> + timings->x_res = hdmi_timings.x_res;
> + timings->y_res = hdmi_timings.y_res;
> + timings->pixel_clock = hdmi_timings.pixel_clock;
> + timings->hbp = hdmi_timings.hbp;
> + timings->hfp = hdmi_timings.hfp;
> + timings->hsw = hdmi_timings.hsw;
> + timings->vbp = hdmi_timings.vbp;
> + timings->vfp = hdmi_timings.vfp;
> + timings->vsw = hdmi_timings.vsw;
> +}
> +
> static int get_timings_index(void)
> {
> int code;
> @@ -617,7 +631,7 @@ static struct hdmi_cm hdmi_get_code(struct omap_video_timings *timing)
> {
> int i = 0, code = -1, temp_vsync = 0, temp_hsync = 0;
> int timing_vsync = 0, timing_hsync = 0;
> - struct omap_video_timings temp;
> + struct hdmi_video_timings temp;
> struct hdmi_cm cm = {-1};
> DSSDBG("hdmi_get_code\n");
>
> @@ -775,7 +789,8 @@ static void hdmi_read_edid(struct omap_video_timings *dp)
"dp" feels a rather odd name for video timings variable. What does it
stand for?
Tomi
next prev parent reply other threads:[~2011-06-23 8:30 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-06-17 8:17 [PATCH 0/8] HDMI: Split hdmi.c to seperate HDMI IP dependant code from DSS Mythri P K
2011-06-17 8:17 ` [PATCH 1/8] OMAP4: DSS: HDMI: HDMI clean up to pass base_address Mythri P K
2011-06-17 8:17 ` [PATCH 2/8] OMAP4 : DSS : HDMI : Move the EDID portion from HDMI IP Mythri P K
2011-06-17 8:17 ` [PATCH 3/8] OMAP4: DSS: HDMI: Use specific HDMI timings structure Mythri P K
2011-06-17 8:17 ` [PATCH 4/8] OMAP4: DSS: HDMI: Move the common header file definition Mythri P K
2011-06-17 8:17 ` [PATCH 5/8] OMAP4: DSS2: HDMI: Split the HDMI driver to DSS and IP Mythri P K
2011-06-17 8:17 ` [PATCH 6/8] OMAP4: DSS: HDMI: Rename the functions in HDMI IP Mythri P K
2011-06-17 8:17 ` [PATCH 7/8] HDMI: Move HDMI IP Library from OMAP DSS to common Mythri P K
2011-06-17 8:17 ` [PATCH 8/8] OMAP4: DSS: Rename hdmi_omap4_panel.c to hdmi_panel.c Mythri P K
2011-06-20 13:48 ` [PATCH 5/8] OMAP4: DSS2: HDMI: Split the HDMI driver to DSS and IP Premi, Sanjeev
2011-06-23 5:55 ` K, Mythri P
2011-06-20 12:46 ` [PATCH 3/8] OMAP4: DSS: HDMI: Use specific HDMI timings structure Premi, Sanjeev
2011-06-23 5:45 ` K, Mythri P
2011-06-23 8:30 ` Tomi Valkeinen [this message]
2011-06-23 8:46 ` K, Mythri P
2011-06-20 13:33 ` [PATCH 1/8] OMAP4: DSS: HDMI: HDMI clean up to pass base_address Premi, Sanjeev
2011-06-23 5:51 ` K, Mythri P
2011-06-23 10:30 ` Premi, Sanjeev
2011-06-23 11:00 ` K, Mythri P
2011-06-23 11:03 ` Premi, Sanjeev
2011-06-23 11:09 ` K, Mythri P
2011-06-23 9:58 ` [PATCH 0/8] HDMI: Split hdmi.c to seperate HDMI IP dependant code from DSS Tomi Valkeinen
2011-06-23 12:05 ` K, Mythri P
2011-06-23 12:31 ` Tomi Valkeinen
2011-06-27 5:51 ` K, Mythri P
2011-06-27 12:58 ` Tomi Valkeinen
2011-06-29 13:38 ` K, Mythri P
2011-06-29 16:21 ` Tomi Valkeinen
2011-06-30 17:46 ` K, Mythri P
2011-07-01 8:51 ` Tomi Valkeinen
2011-07-01 9:22 ` K, Mythri P
2011-07-01 11:44 ` Tomi Valkeinen
2011-07-01 12:43 ` K, Mythri P
-- strict thread matches above, loose matches on Subject: below --
2011-06-22 11:55 [PATCH 3/8] OMAP4: DSS: HDMI: Use specific HDMI timings structure Mythri P K
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1308817843.1834.40.camel@deskari \
--to=tomi.valkeinen@ti.com \
--cc=linux-omap@vger.kernel.org \
--cc=mythripk@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.