From mboxrd@z Thu Jan 1 00:00:00 1970 From: Paulo Zanoni Subject: [PATCH 00/11] More HDMI fixes Date: Thu, 24 May 2012 17:49:42 -0300 Message-ID: <1337892594-31908-1-git-send-email-przanoni@gmail.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-vc0-f177.google.com (mail-vc0-f177.google.com [209.85.220.177]) by gabe.freedesktop.org (Postfix) with ESMTP id 375A1A09A4 for ; Thu, 24 May 2012 13:49:50 -0700 (PDT) Received: by vcbf13 with SMTP id f13so153503vcb.36 for ; Thu, 24 May 2012 13:49:49 -0700 (PDT) List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org Errors-To: intel-gfx-bounces+gcfxdi-intel-gfx=m.gmane.org@lists.freedesktop.org To: intel-gfx@lists.freedesktop.org Cc: Paulo Zanoni List-Id: intel-gfx@lists.freedesktop.org From: Paulo Zanoni Hi This is my final patch series dealing with HDMI InfoFrames. It's on top of the drm-intel-next-queued tree. For now, everything seems to follow the specification from Gen 4 to HSW and I'm happy with the code. The only thing missing is support for even more DIPs, but these should not change the current functions: just add a few others. One of the main additions of this series is the 'set_infoframes' function that now completely resets the state of the DIP registers at every mode set. This allowed us to implement the remaining fixes of the series in a proper way. Patches that only change coding style and/or restructure code: - 1, 3, 4, 10, 11 The most important patches, IMHO, are: - 2, 5, 7, 8 I tested these patches on Gen4, ILK, SNB and IVB. Some were desktops, some were laptops. Thanks, Paulo Paulo Zanoni (11): drm/i915: add set_infoframes to struct intel_hdmi drm/i915: properly alternate between DVI and HDMI drm/i915: only set the HDMI port on the DIP once drm/i915: enable DIP before enabling each InfoFrame drm/i915: don't wait for vblank while writing InfoFrames drm/i915: explicitly disable the DIPs we're not using drm/i915: disable DIP while changing the port drm/i915: don't write 0 to DIP control at HDMI init drm/i915: don't set SDVO_BORDER_ENABLE when we're HDMI drm/i915: rename sdvox_reg to hdmi_reg on HDMI context drm/i915: remove comment about HSW HDMI DIPs drivers/gpu/drm/i915/i915_reg.h | 6 + drivers/gpu/drm/i915/intel_ddi.c | 3 +- drivers/gpu/drm/i915/intel_drv.h | 6 +- drivers/gpu/drm/i915/intel_hdmi.c | 322 ++++++++++++++++++++++++++----------- 4 files changed, 241 insertions(+), 96 deletions(-) -- 1.7.10