From mboxrd@z Thu Jan 1 00:00:00 1970 From: Scott Wood Date: Thu, 27 Feb 2014 13:21:47 -0600 Subject: [U-Boot] [U-Boot PATCH v2 05/12] NAND: DaVinci: allow forced disable of subpage writes In-Reply-To: <3E54258959B69E4282D79E01AB1F32B7046C27D5@DFLE11.ent.ti.com> References: <1392918914-15564-1-git-send-email-m-karicheri2@ti.com> <1392918914-15564-6-git-send-email-m-karicheri2@ti.com> <1393387271.6733.1001.camel@snotra.buserror.net> <3E54258959B69E4282D79E01AB1F32B7046C27D5@DFLE11.ent.ti.com> Message-ID: <1393528907.2697.13.camel@snotra.buserror.net> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de On Thu, 2014-02-27 at 16:14 +0000, Karicheri, Muralidharan wrote: > >-----Original Message----- > >From: Scott Wood [mailto:scottwood at freescale.com] > >Sent: Tuesday, February 25, 2014 11:01 PM > >To: Karicheri, Muralidharan > >Cc: u-boot at lists.denx.de; Rini, Tom > >Subject: Re: [U-Boot] [U-Boot PATCH v2 05/12] NAND: DaVinci: allow forced disable of > >subpage writes > > > >On Thu, 2014-02-20 at 12:55 -0500, Murali Karicheri wrote: > >> This patch introduces a configurable mechanism to disable subpage > >> writes in the DaVinci NAND driver. > >> > >> Signed-off-by: Vitaly Andrianov > >> Signed-off-by: Murali Karicheri > >> --- > >> - Added README > >> README | 5 +++++ > >> drivers/mtd/nand/davinci_nand.c | 3 +++ > >> 2 files changed, 8 insertions(+) > >> > >> diff --git a/README b/README > >> index aea82be..caf60a2 100644 > >> --- a/README > >> +++ b/README > >> @@ -4427,6 +4427,11 @@ Low Level (hardware related) configuration options: > >> - CONFIG_SPL_AM33XX_ENABLE_RTC32K_OSC: > >> Enables the RTC32K OSC on AM33xx based plattforms > >> > >> +- CONFIG_SYS_NAND_NO_SUBPAGE_WRITE > >> + Option to disable subpage write in NAND driver > >> + Example driver that use this: > >> + drivers/mtd/nand/davinci_nand.c > > > >I'd rather this be a full list of drivers that use it, not an example. > > There are 3 drivers out there that disable sub page write using NAND_NO_SUBPAGE_WRITE > by default. > > nand/docg4.c > nand/fsl_ifc_nand.c > nand/mxs_nand.c > > nand/davinci_nand.c is used across many of ti's existing davinci platforms and some of them > do enable sub page write. And only one of them uses CONFIG_SYS_NAND_NO_SUBPAGE_WRITE, which is a potentially confusing thing given the generic naming, and thus warrants clear documentation. > In Keystone platform, we want to disable this option. So to answer > your question, davinci_nand.c is the only user driver using this configuration option, > but that doesn't prevent anyone from using the option. So I want to keep this configuration > option as a generic option. That's fine. My point is just to s/Example driver/Drivers/ so that if someone adds this to a new driver, they (hopefully) add it to the list in README, rather than just thinking one example is enough. -Scott