From: Mike Galbraith <umgwanakikbuti@gmail.com>
To: Peter Zijlstra <peterz@infradead.org>
Cc: Vincent Guittot <vincent.guittot@linaro.org>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: 143e1e28 sched: Rework sched_domain topology definition
Date: Sun, 20 Jul 2014 09:05:50 +0200 [thread overview]
Message-ID: <1405839950.6512.49.camel@marge.simpson.net> (raw)
In-Reply-To: <20140720065207.GU9918@twins.programming.kicks-ass.net>
On Sun, 2014-07-20 at 08:52 +0200, Peter Zijlstra wrote:
> On Sun, Jul 20, 2014 at 08:43:36AM +0200, Mike Galbraith wrote:
> > Hi,
> >
> > +/*
> > + * Topology list, bottom-up.
> > + */
> > +static struct sched_domain_topology_level default_topology[] = {
> > +#ifdef CONFIG_SCHED_SMT
> > + { cpu_smt_mask, cpu_smt_flags, SD_INIT_NAME(SMT) },
> > +#endif
> > +#ifdef CONFIG_SCHED_MC
> > + { cpu_coregroup_mask, cpu_core_flags, SD_INIT_NAME(MC) },
> > +#endif
> > +#ifdef CONFIG_SCHED_BOOK
> > + { cpu_book_mask, SD_INIT_NAME(BOOK) },
> > +#endif
> > + { cpu_cpu_mask, SD_INIT_NAME(DIE) },
> > + { NULL, },
> > +};
> >
> > Why did this commit rename the CPU domain to DIE?
>
> Because they're both wrong, but we found that DIE was less wrong than
> CPU.
Ok, doesn't matter anyway, just looks peculiar.
> Seeing how CPU typically means 1 logical, well, CPU, in the scheduler,
> and not the package you stick on your board.
>
> We chose DIE over PACKAGE due to 1) its shorter name and 2) things like
> interlagos which have multiple DIEs in one PACKAGE etc..
It's actually a good name for some NUMA topologies. You don't ever want
to see a CPU domain, that sucks cycles, so calling it DIE is fine :)
> Also, the only person who would ever care is the one who (with
> SCHED_DEBUG) enabled looks at the topology setup, which is maybe all of
> us 5.
Maybe a few more, but yeah, not many would care what you called it.
-Mike
next prev parent reply other threads:[~2014-07-20 7:05 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-07-20 6:43 143e1e28 sched: Rework sched_domain topology definition Mike Galbraith
2014-07-20 6:52 ` Peter Zijlstra
2014-07-20 7:05 ` Mike Galbraith [this message]
2014-07-20 7:19 ` Mike Galbraith
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1405839950.6512.49.camel@marge.simpson.net \
--to=umgwanakikbuti@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=peterz@infradead.org \
--cc=vincent.guittot@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.