From mboxrd@z Thu Jan 1 00:00:00 1970 From: James Liao Subject: Re: [PATCH v4 7/7] arm64: dts: mt8173: Add subsystem clock controller device nodes Date: Mon, 27 Jul 2015 10:56:22 +0800 Message-ID: <1437965782.5614.4.camel@mtksdaap41> References: <1437706925-3222-1-git-send-email-jamesjj.liao@mediatek.com> <1437706925-3222-8-git-send-email-jamesjj.liao@mediatek.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: Sender: linux-kernel-owner@vger.kernel.org To: Daniel Kurtz Cc: Matthias Brugger , Mike Turquette , Stephen Boyd , Heiko Stubner , srv_heupstream , Ricky Liang , Rob Herring , Sascha Hauer , "open list:OPEN FIRMWARE AND..." , "linux-arm-kernel@lists.infradead.org" , "linux-kernel@vger.kernel.org" , linux-mediatek@lists.infradead.org List-Id: linux-mediatek@lists.infradead.org Hi Daniel, On Fri, 2015-07-24 at 19:32 +0800, Daniel Kurtz wrote: > > @@ -88,6 +88,13 @@ > > #clock-cells = <0>; > > }; > > > > + cpum_ck: dummy_clk { > > I'm not a big fan of this "dummy_clk". > The 'name' part of the devicetree node is supposed to be generic. > So, perhaps just oscillator@2, and move it down below clk32k: oscillator@1. > Otherwise: cpum_ck is a test clock which only available in IC test. It's empty on MT8173 evaluation or production boards. Should we name this kind of empty clock as an oscillator? Or is there a better name for it? Best regards, James From mboxrd@z Thu Jan 1 00:00:00 1970 From: jamesjj.liao@mediatek.com (James Liao) Date: Mon, 27 Jul 2015 10:56:22 +0800 Subject: [PATCH v4 7/7] arm64: dts: mt8173: Add subsystem clock controller device nodes In-Reply-To: References: <1437706925-3222-1-git-send-email-jamesjj.liao@mediatek.com> <1437706925-3222-8-git-send-email-jamesjj.liao@mediatek.com> Message-ID: <1437965782.5614.4.camel@mtksdaap41> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org Hi Daniel, On Fri, 2015-07-24 at 19:32 +0800, Daniel Kurtz wrote: > > @@ -88,6 +88,13 @@ > > #clock-cells = <0>; > > }; > > > > + cpum_ck: dummy_clk { > > I'm not a big fan of this "dummy_clk". > The 'name' part of the devicetree node is supposed to be generic. > So, perhaps just oscillator at 2, and move it down below clk32k: oscillator at 1. > Otherwise: cpum_ck is a test clock which only available in IC test. It's empty on MT8173 evaluation or production boards. Should we name this kind of empty clock as an oscillator? Or is there a better name for it? Best regards, James From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755455AbbG0C4d (ORCPT ); Sun, 26 Jul 2015 22:56:33 -0400 Received: from mailgw01.mediatek.com ([210.61.82.183]:33567 "EHLO mailgw01.mediatek.com" rhost-flags-OK-FAIL-OK-FAIL) by vger.kernel.org with ESMTP id S1755059AbbG0C43 (ORCPT ); Sun, 26 Jul 2015 22:56:29 -0400 X-Listener-Flag: 11101 Message-ID: <1437965782.5614.4.camel@mtksdaap41> Subject: Re: [PATCH v4 7/7] arm64: dts: mt8173: Add subsystem clock controller device nodes From: James Liao To: Daniel Kurtz CC: Matthias Brugger , Mike Turquette , Stephen Boyd , "Heiko Stubner" , srv_heupstream , Ricky Liang , Rob Herring , Sascha Hauer , "open list:OPEN FIRMWARE AND..." , "linux-arm-kernel@lists.infradead.org" , "linux-kernel@vger.kernel.org" , Date: Mon, 27 Jul 2015 10:56:22 +0800 In-Reply-To: References: <1437706925-3222-1-git-send-email-jamesjj.liao@mediatek.com> <1437706925-3222-8-git-send-email-jamesjj.liao@mediatek.com> Content-Type: text/plain; charset="us-ascii" X-Mailer: Evolution 3.2.3-0ubuntu6 Content-Transfer-Encoding: 7bit MIME-Version: 1.0 X-MTK: N Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Daniel, On Fri, 2015-07-24 at 19:32 +0800, Daniel Kurtz wrote: > > @@ -88,6 +88,13 @@ > > #clock-cells = <0>; > > }; > > > > + cpum_ck: dummy_clk { > > I'm not a big fan of this "dummy_clk". > The 'name' part of the devicetree node is supposed to be generic. > So, perhaps just oscillator@2, and move it down below clk32k: oscillator@1. > Otherwise: cpum_ck is a test clock which only available in IC test. It's empty on MT8173 evaluation or production boards. Should we name this kind of empty clock as an oscillator? Or is there a better name for it? Best regards, James