All of lore.kernel.org
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Borislav Petkov <bp@alien8.de>, "Moore, Robert" <robert.moore@intel.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
	"Zheng, Lv" <lv.zheng@intel.com>,
	"Wysocki, Rafael J" <rafael.j.wysocki@intel.com>,
	Len Brown <lenb@kernel.org>,
	"linux-acpi@vger.kernel.org" <linux-acpi@vger.kernel.org>,
	"devel@acpica.org" <devel@acpica.org>
Subject: Re: [PATCH] ACPICA / Interpreter: Remove redundant newline
Date: Fri, 09 Sep 2016 11:55:44 -0700	[thread overview]
Message-ID: <1473447344.10509.3.camel@perches.com> (raw)
In-Reply-To: <20160909184042.srv6jrio6s5umear@pd.tnic>

On Fri, 2016-09-09 at 20:40 +0200, Borislav Petkov wrote:
> On Fri, Sep 09, 2016 at 06:26:17PM +0000, Moore, Robert wrote:
> > Is this a big deal?
> > We do this on purpose for AcpiExec, to make the screen output more readable.
[]
> What do you mean "big deal"? All other ACPI_INFO calls don't have a "\n"
> at the end except this one. How does one "\n" make some output more
> readable?

Blank lines in logging/dmesg generally don't add value.

I would prefer if the unnecessary double parentheses also
were removed in these macro uses and ##__VA_ARGS__ was
used instead.

/*
 * Error reporting. Callers module and line number are inserted by AE_INFO,
 * the plist contains a set of parens to allow variable-length lists.
 * These macros are used for both the debug and non-debug versions of the code.
 */
#define ACPI_INFO(plist)                acpi_info plist
#define ACPI_WARNING(plist)             acpi_warning plist
#define ACPI_EXCEPTION(plist)           acpi_exception plist
#define ACPI_ERROR(plist)               acpi_error plist
#define ACPI_BIOS_WARNING(plist)        acpi_bios_warning plist
#define ACPI_BIOS_ERROR(plist)          acpi_bios_error plist

It would also be good if format/argument verification
was done here and in the non-debug macro variants.

#define ACPI_INFO(plist)
#define ACPI_WARNING(plist)
#define ACPI_EXCEPTION(plist)
#define ACPI_ERROR(plist)
#define ACPI_BIOS_WARNING(plist)
#define ACPI_BIOS_ERROR(plist)


  parent reply	other threads:[~2016-09-09 18:55 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-09-09 16:12 [PATCH] ACPICA / Interpreter: Remove redundant newline Borislav Petkov
2016-09-09 18:26 ` [Devel] " Moore, Robert
2016-09-09 18:26   ` Moore, Robert
2016-09-09 18:40   ` Borislav Petkov
2016-09-09 18:46     ` [Devel] " Moore, Robert
2016-09-09 18:46       ` Moore, Robert
2016-09-09 18:50       ` Borislav Petkov
2016-09-09 18:55     ` Joe Perches [this message]
2016-09-09 18:45   ` [Devel] " Moore, Robert
2016-09-09 18:45     ` Moore, Robert
2016-09-09 19:06     ` Borislav Petkov
2016-09-09 19:15       ` Joe Perches
2016-09-09 19:25         ` Borislav Petkov
2016-09-14  3:09 ` [Devel] " Zheng, Lv
2016-09-14  3:09   ` Zheng, Lv
2016-09-14 11:30   ` Borislav Petkov
2016-09-19  9:30     ` [Devel] " Zheng, Lv
2016-09-19  9:30       ` Zheng, Lv
2016-09-19 10:12       ` Borislav Petkov
2016-09-23  6:46         ` [PATCH] acpiexec: Move an acpiexec specific purposed new line to acpiexec specific file Lv Zheng
2016-09-23  6:46           ` [Devel] " Lv Zheng
2016-09-23  6:46           ` Lv Zheng
2016-09-23  6:49         ` Lv Zheng
2016-09-23  6:49           ` [Devel] " Lv Zheng
2016-09-23  6:49           ` Lv Zheng
  -- strict thread matches above, loose matches on Subject: below --
2016-09-14  3:11 [Devel] [PATCH] ACPICA / Interpreter: Remove redundant newline Zheng, Lv
2016-09-14  3:11 ` Zheng, Lv
2016-09-14  3:11 ` Zheng, Lv
2016-09-14  3:14 [Devel] " Zheng, Lv
2016-09-14  3:14 ` Zheng, Lv
2016-09-14 14:03 [Devel] " Moore, Robert
2016-09-14 14:03 ` Moore, Robert

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1473447344.10509.3.camel@perches.com \
    --to=joe@perches.com \
    --cc=bp@alien8.de \
    --cc=devel@acpica.org \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lv.zheng@intel.com \
    --cc=rafael.j.wysocki@intel.com \
    --cc=robert.moore@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.