From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>,
"Rafael J. Wysocki" <rjw@rjwysocki.net>,
Erik Schmauss <erik.schmauss@intel.com>,
linux-acpi@vger.kernel.org, Liam Girdwood <lgirdwood@gmail.com>,
Mark Brown <broonie@kernel.org>,
alsa-devel@alsa-project.org,
Linus Walleij <linus.walleij@linaro.org>,
linux-gpio@vger.kernel.org,
Mika Westerberg <mika.westerberg@linux.intel.com>
Subject: Re: [alsa-devel] [PATCH v2 1/3] ACPI / utils: Introduce acpi_dev_get_dev_name()
Date: Thu, 04 Jan 2018 19:40:27 +0200 [thread overview]
Message-ID: <1515087627.7000.701.camel@linux.intel.com> (raw)
In-Reply-To: <aed928f3-452c-c0b8-bd93-b9921d72df67@linux.intel.com>
On Thu, 2018-01-04 at 11:31 -0600, Pierre-Louis Bossart wrote:
> On 1/4/18 10:47 AM, Andy Shevchenko wrote:
> > Sometimes the user want to have device name of the match rather than
> > just checking if device present or not. To make life easier for such
> > users introduce acpi_dev_get_dev_name() helper based on code for
> > acpi_dev_present().
> >
> > To be more consistent with the purpose rename
> >
> > struct acpi_dev_present_info -> struct acpi_dev_match_info
> > acpi_dev_present_cb() -> acpi_dev_match_cb()
> >
> > in the utils.c file.
>
> I would have done this differently. You have two routines
> (acpi_dev_present and acpi_dev_get_dev_name) which do the same thing
> except for what they return (bool and const char *) respectively.
I have thought about it :-)
I decide that for two current users there is a little benefit over
effort and readability.
See also below.
> This could be factored with
>
> static struct device *dev _acpi_dev_present(const char *hid, const
> char
> *uid, s64 hrv) {
>
> struct acpi_dev_present_info match = {};
> struct device *dev;
>
> strlcpy(match.hid[0].id, hid, sizeof(match.hid[0].id));
> match.uid = uid;
> match.hrv = hrv;
>
> dev = bus_find_device(&acpi_bus_type, NULL, &match,
> acpi_dev_present_cb);
>
> return dev;
> }
>
> bool acpi_dev_present(const char *hid, const char *uid, s64 hrv)
> {
> return !!_acpi_dev_present(const char *hid, const char *uid, s64
> hrv);
> }
>
> const char *acpi_dev_get_dev_name(const char *hid, const char *uid,
> s64 hrv)
> {
> struct device *dev;
>
> dev = _acpi_dev_present(const char *hid, const char *uid, s64
> hrv);
>
> return dev ? match.dev_name : NULL;
And where is the match declaration?
Yes, needs to be duplicated. That's why I stopped going this direction.
It still might make sense when 3+ variant will appear.
> }
>
> That said you are a much better programmer than me so the other code
> is
> fine with me...
Thanks.
Would be nice to get your Tested-by at some point.
--
Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Intel Finland Oy
next prev parent reply other threads:[~2018-01-04 17:40 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-01-04 16:47 [PATCH v2 0/3] ACPI, ASoC, gpio: Introduce and use acpi_dev_get_dev_name() Andy Shevchenko
2018-01-04 16:47 ` [PATCH v2 1/3] ACPI / utils: Introduce acpi_dev_get_dev_name() Andy Shevchenko
2018-01-04 17:31 ` Pierre-Louis Bossart
2018-01-04 17:40 ` Andy Shevchenko [this message]
2018-01-05 0:47 ` Pierre-Louis Bossart
2018-01-05 12:05 ` Mark Brown
2018-01-05 12:43 ` Andy Shevchenko
2018-01-05 15:46 ` Pierre-Louis Bossart
2018-01-05 12:06 ` Rafael J. Wysocki
2018-01-05 12:22 ` Andy Shevchenko
2018-01-05 12:34 ` Rafael J. Wysocki
2018-01-05 12:39 ` Andy Shevchenko
2018-01-05 15:55 ` Pierre-Louis Bossart
2018-01-04 16:47 ` [PATCH v2 2/3] ASoC: Intel - Convert users to use acpi_dev_get_dev_name() Andy Shevchenko
2018-01-04 16:47 ` [PATCH v2 3/3] gpio: merrifield: Add support of ACPI enabled platforms Andy Shevchenko
2018-01-04 17:33 ` [PATCH v2 0/3] ACPI, ASoC, gpio: Introduce and use acpi_dev_get_dev_name() Pierre-Louis Bossart
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1515087627.7000.701.camel@linux.intel.com \
--to=andriy.shevchenko@linux.intel.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=erik.schmauss@intel.com \
--cc=lgirdwood@gmail.com \
--cc=linus.walleij@linaro.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-gpio@vger.kernel.org \
--cc=mika.westerberg@linux.intel.com \
--cc=pierre-louis.bossart@linux.intel.com \
--cc=rjw@rjwysocki.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.