All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jean Tourrilhes <jt@bougret.hpl.hp.com>
To: kernel-janitors@vger.kernel.org
Subject: [Kernel-janitors] Re: [PATCH] irda/irtty-sir: replace
Date: Tue, 27 Jul 2004 17:50:04 +0000	[thread overview]
Message-ID: <20040727175004.GA18782@bougret.hpl.hp.com> (raw)

[-- Attachment #1: Type: text/plain, Size: 2166 bytes --]

On Tue, Jul 27, 2004 at 10:11:20AM -0700, Nishanth Aravamudan wrote:
> I would appreciate any comments from the janitors list. 
> 
> Applys-to: 2.6.7
> 
> Description: Replace schedule_timeout() with msleep() to guarantee the
> task delays for the desired time.

	I'm forwarding that the Martin, which is the maintainer of
that piece of code.
	I personally find the name of the msleep() function dangerous
and confusing, and I would prefer not to use it as it is. Despite its
very generic name, the msleep() function apply only when we are within
a real process/task context. If you attempt to use it in interrupt, BH
or timer context, you will get some very interesting results.
	On the other hand, both udelay() and mdelay() can be used in
any context, so deserve a generic name.
	Because the IrDA drivers use both interrupt/BH and process
context, we need to make sure that we don't use msleep() in the wrong
context. The current code make this explicit, you see the
set_task_state() and you know that you must be in the proper
context. Using msleep() in IrDA drivers only obfuscate this important
issue and make the source less maintainable.
	I would suggest renaming "msleep()" to "task_msleep()" or
"schedule_msleep()" before applying this patch, so that things are
clear. Or just make "task_msleep()" or "schedule_msleep()" a wrapper
around "msleep()".

	Have fun...

	Jean

> Signed-off-by: Nishanth Aravamudan <nacc@us.ibm.com>
> 
> 
> --- linux-vanilla/drivers/net/irda/irtty-sir.c	2004-06-16 05:18:37.000000000 +0000
> +++ linux-dev/drivers/net/irda/irtty-sir.c	2004-07-21 17:26:31.000000000 +0000
> @@ -32,6 +32,7 @@
>  #include <linux/init.h>
>  #include <asm/uaccess.h>
>  #include <linux/smp_lock.h>
> +#include <linux/delay.h>
>  
>  #include <net/irda/irda.h>
>  #include <net/irda/irda_device.h>
> @@ -96,10 +97,8 @@ static void irtty_wait_until_sent(struct
>  		tty->driver->wait_until_sent(tty, msecs_to_jiffies(100));
>  		unlock_kernel();
>  	}
> -	else {
> -		set_task_state(current, TASK_UNINTERRUPTIBLE);
> -		schedule_timeout(msecs_to_jiffies(USBSERIAL_TX_DONE_DELAY));
> -	}
> +	else 
> +		msleep(USBSERIAL_TX_DONE_DELAY);
>  }
>  
>  /* 

[-- Attachment #2: Type: text/plain, Size: 167 bytes --]

_______________________________________________
Kernel-janitors mailing list
Kernel-janitors@lists.osdl.org
http://lists.osdl.org/mailman/listinfo/kernel-janitors

             reply	other threads:[~2004-07-27 17:50 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-07-27 17:50 Jean Tourrilhes [this message]
2004-07-27 18:15 ` [Kernel-janitors] Re: [PATCH] irda/irtty-sir: replace Nishanth Aravamudan
2004-07-27 18:26 ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20040727175004.GA18782@bougret.hpl.hp.com \
    --to=jt@bougret.hpl.hp.com \
    --cc=kernel-janitors@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.