From: Alessandro Zummo <alessandro.zummo@towertech.it>
To: Pavel Machek <pavel@ucw.cz>
Cc: kernel list <linux-kernel@vger.kernel.org>
Subject: Re: [RFC][PATCH 1/6] RTC subsystem, class
Date: Tue, 27 Dec 2005 04:16:52 +0100 [thread overview]
Message-ID: <20051227041652.0c4e5685@inspiron> (raw)
In-Reply-To: <20051226201657.GA1974@elf.ucw.cz>
On Mon, 26 Dec 2005 21:16:57 +0100
Pavel Machek <pavel@ucw.cz> wrote:
> > > > +int rtc_set_alarm(struct class_device *class_dev, struct rtc_wkalrm*alrm)
> > >
> > > Struct rtc_wake_alarm *alarm, those wovels are there for readability.
> >
> > I'm not the one who created this structure. It's defined
> > in linux/rtc.h since a long time. I can only change alrm
> > to alarm.
>
> Sorry if you are not responsible... Yes, alarm would be better.
>
> How does this relate to /proc/acpi/alarm, btw? Do they use same RTC
> alarm?
Yes, they do. The ACPI subsystem does direct I/O on the cmos clock.
Given the complexity of the ACPI code, when/if the x86 rtc driver
will be ported to the RTC subsystem, it would be wise
to disable the alarm part if ACPI is compiled in.
--
Best regards,
Alessandro Zummo,
Tower Technologies - Turin, Italy
http://www.towertech.it
prev parent reply other threads:[~2005-12-27 3:15 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-12-20 20:45 [RFC][PATCH 1/6] RTC subsystem, class Alessandro Zummo
2005-12-20 21:13 ` Christoph Hellwig
2005-12-20 21:23 ` Alessandro Zummo
2005-12-21 1:50 ` Mitchell Blank Jr
2005-12-21 9:30 ` Alessandro Zummo
2005-12-20 21:30 ` Russell King
2005-12-21 2:01 ` Dmitry Torokhov
2005-12-21 9:50 ` Alessandro Zummo
2005-12-21 19:43 ` Dmitry Torokhov
2005-12-21 23:10 ` Alessandro Zummo
2005-12-22 13:35 ` Pavel Machek
2005-12-26 2:47 ` Alessandro Zummo
2005-12-26 20:16 ` Pavel Machek
2005-12-27 3:16 ` Alessandro Zummo [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20051227041652.0c4e5685@inspiron \
--to=alessandro.zummo@towertech.it \
--cc=linux-kernel@vger.kernel.org \
--cc=pavel@ucw.cz \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.