From mboxrd@z Thu Jan 1 00:00:00 1970 From: Arnd Bergmann Subject: Re: [PATCH] pasemi: electra IDE/pata_platform glue Date: Sun, 13 May 2007 01:11:02 +0200 Message-ID: <200705130111.03153.arnd@arndb.de> References: <20070512145041.GA13025@lixom.net> Mime-Version: 1.0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: 7bit Return-path: Received: from moutng.kundenserver.de ([212.227.126.171]:61864 "EHLO moutng.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751998AbXELXLP (ORCPT ); Sat, 12 May 2007 19:11:15 -0400 In-Reply-To: <20070512145041.GA13025@lixom.net> Content-Disposition: inline Sender: linux-ide-owner@vger.kernel.org List-Id: linux-ide@vger.kernel.org To: linuxppc-dev@ozlabs.org Cc: Olof Johansson , paulus@samba.org, linux-ide@vger.kernel.org On Saturday 12 May 2007, Olof Johansson wrote: > > We unfortunately need to modify the resources before calling the generic > platform driver, since the device tree only has one register window in > it and the driver expects two. Adding this as an of_platform driver > instead doesn't give us any benefit, it just adds one more layer of > register/probe functions. Why not provide a proper pata_of.c driver based on ata_generic? That will help the next person that has a builtin ata controller and wants to get it running as an of_device. If you simply export generic_sht (rename that to ata_generic_sht) and generic_port_ops (-> ata_generic_port_ops), then the resulting of_platform_driver should be no more complicated than the one you are proposing here. Arnd <>< From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from moutng.kundenserver.de (moutng.kundenserver.de [212.227.126.171]) by ozlabs.org (Postfix) with ESMTP id B1B5BDDE45 for ; Sun, 13 May 2007 09:11:18 +1000 (EST) From: Arnd Bergmann To: linuxppc-dev@ozlabs.org Subject: Re: [PATCH] pasemi: electra IDE/pata_platform glue Date: Sun, 13 May 2007 01:11:02 +0200 References: <20070512145041.GA13025@lixom.net> In-Reply-To: <20070512145041.GA13025@lixom.net> MIME-Version: 1.0 Content-Type: text/plain; charset="iso-8859-1" Message-Id: <200705130111.03153.arnd@arndb.de> Cc: Olof Johansson , linux-ide@vger.kernel.org, paulus@samba.org List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , On Saturday 12 May 2007, Olof Johansson wrote: > > We unfortunately need to modify the resources before calling the generic > platform driver, since the device tree only has one register window in > it and the driver expects two. Adding this as an of_platform driver > instead doesn't give us any benefit, it just adds one more layer of > register/probe functions. Why not provide a proper pata_of.c driver based on ata_generic? That will help the next person that has a builtin ata controller and wants to get it running as an of_device. If you simply export generic_sht (rename that to ata_generic_sht) and generic_port_ops (-> ata_generic_port_ops), then the resulting of_platform_driver should be no more complicated than the one you are proposing here. Arnd <><