From mboxrd@z Thu Jan 1 00:00:00 1970 From: Wolfgang Denk Date: Sun, 31 Aug 2008 16:58:28 +0200 Subject: [U-Boot] [PATCH 2/6] Separate flash read and write operations In-Reply-To: References: Message-ID: <20080831145828.ED89124899@gemini.denx.de> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de Dear Guennadi Liakhovetski, In message you wrote: Your > Subject: Re: [U-Boot] [PATCH 2/6] Separate flash read and write operations does not make a good commit comment - you should at least add "fw_env:" or similar so eveybody know which "flash read and write operations" you are talking about. > The flash_io function was used for both read and write operations, whereby > very little code was shared between the two modes. By breaking this function > we simplify the code and save one level of identation. If I see this correctly, you did not implement any functional changes or bug fixes, i. e. it was just a code restructuring because you didn't like the current style and preferred another one? Best regards, Wolfgang Denk -- DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de Perfection is reached, not when there is no longer anything to add, but when there is no longer anything to take away. - Antoine de Saint-Exupery