From: Jean Delvare <khali@linux-fr.org>
To: lm-sensors@vger.kernel.org
Subject: Re: [lm-sensors] [PATCH 2/2] hwmon: w83781d: use new style driver
Date: Mon, 13 Oct 2008 10:55:54 +0000 [thread overview]
Message-ID: <20081013125554.27a7f1bc@hyperion.delvare> (raw)
In-Reply-To: <48CB7FFA.10202@grandegger.com>
Hi Wolfgang,
On Mon, 13 Oct 2008 10:43:05 +0200, Wolfgang Grandegger wrote:
> Jean Delvare wrote:
> > I will send an updated patch set to the lm-sensors list now. This patch
> > set is also available at:
> > http://jdelvare.pck.nerim.net/sensors/w83781d/
> > Please test these patches as your time permits. If possible, it would
> > be great if you could review them and give me your ack on them, before
> > I push them upstream.
>
> I just verified the patch series on my embedded PowerPC MPC8344E board
> and it worked fine. Unfortunately I can not test the ISA interface due
> to lack of hardware. Just some nitpicking. In the final w83781d.c I
OK, thanks for reporting. I was able to test the ISA case here and it
worked fine.
> realized redundant labels:
>
> static int
> w83781d_detect_subclients(struct i2c_client *new_client)
> {
> ...
> /* Undo inits in case of errors */
> ERROR_SC_3:
> i2c_unregister_device(data->lm75[0]);
> ERROR_SC_2:
> ERROR_SC_1:
> return err;
That's on purpose, to make the patch smaller / more readable. These
labels suck anyway and we should replace them, so whoever does this in
the future (possibly me) can drop the redundant label at the same time.
If you think the current state is too ugly then I can do that right now
and add a 7th patch to the series.
Did you have time to review the patches? Can I add your Acked-by on
some of them?
Thanks,
--
Jean Delvare
_______________________________________________
lm-sensors mailing list
lm-sensors@lm-sensors.org
http://lists.lm-sensors.org/mailman/listinfo/lm-sensors
prev parent reply other threads:[~2008-10-13 10:55 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-09-13 8:55 [lm-sensors] [PATCH 2/2] hwmon: w83781d: use new style driver Wolfgang Grandegger
2008-10-06 16:26 ` Jean Delvare
2008-10-07 8:13 ` Wolfgang Grandegger
2008-10-07 17:39 ` Jean Delvare
2008-10-13 8:43 ` Wolfgang Grandegger
2008-10-13 10:55 ` Jean Delvare [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20081013125554.27a7f1bc@hyperion.delvare \
--to=khali@linux-fr.org \
--cc=lm-sensors@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.