All of lore.kernel.org
 help / color / mirror / Atom feed
From: Gleb Natapov <gleb@redhat.com>
To: Blue Swirl <blauwirbel@gmail.com>
Cc: qemu-devel@nongnu.org
Subject: Re: [Qemu-devel] [PATCH] remove unused field from pci device.
Date: Mon, 8 Jun 2009 20:36:25 +0300	[thread overview]
Message-ID: <20090608173625.GJ5558@redhat.com> (raw)
In-Reply-To: <f43fc5580906081031y5fefa35cr80672d8c8905da50@mail.gmail.com>

On Mon, Jun 08, 2009 at 08:31:09PM +0300, Blue Swirl wrote:
> On 6/8/09, Gleb Natapov <gleb@redhat.com> wrote:
> > Signed-off-by: Gleb Natapov <gleb@redhat.com>
> >  diff --git a/hw/pci.c b/hw/pci.c
> >  index 0ab5b94..02b335f 100644
> >  --- a/hw/pci.c
> >  +++ b/hw/pci.c
> >  @@ -268,7 +268,7 @@ static PCIDevice *do_pci_register_device(PCIDevice *pci_dev, PCIBus *bus,
> >          config_write = pci_default_write_config;
> >      pci_dev->config_read = config_read;
> >      pci_dev->config_write = config_write;
> >  -    pci_dev->irq_index = pci_irq_index++;
> >  +    pci_irq_index++;
> >      bus->devices[devfn] = pci_dev;
> >      pci_dev->irq = qemu_allocate_irqs(pci_set_irq, pci_dev, 4);
> >      return pci_dev;
> >  diff --git a/hw/pci.h b/hw/pci.h
> >  index 0405837..fb7b89a 100644
> >  --- a/hw/pci.h
> >  +++ b/hw/pci.h
> >  @@ -154,8 +154,6 @@ struct PCIDevice {
> >      PCIConfigReadFunc *config_read;
> >      PCIConfigWriteFunc *config_write;
> >      PCIUnregisterFunc *unregister;
> >  -    /* ??? This is a PC-specific hack, and should be removed.  */
> >  -    int irq_index;
> >
> >      /* IRQ objects for the INTA-INTD pins.  */
> >      qemu_irq *irq;
> 
> After the patch, pci_irq_index no longer tracks irqs but how many PCI
> devices there are in the system, so perhaps it should be renamed as
> well.
pci_irq_index tracked the number of PCI devices before this patch too
since irq_index is unused anyway. Do you want me to resend the patch
with renaming or do renaming in separate patch?

--
			Gleb.

  reply	other threads:[~2009-06-08 17:36 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-06-08 12:02 [Qemu-devel] [PATCH] remove unused field from pci device Gleb Natapov
2009-06-08 17:31 ` Blue Swirl
2009-06-08 17:36   ` Gleb Natapov [this message]
2009-06-08 17:40     ` Blue Swirl
2009-06-09  2:59 ` Isaku Yamahata

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090608173625.GJ5558@redhat.com \
    --to=gleb@redhat.com \
    --cc=blauwirbel@gmail.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.