From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mailman by lists.gnu.org with archive (Exim 4.43) id 1MfMBq-0001h3-Fa for mharc-grub-devel@gnu.org; Sun, 23 Aug 2009 19:09:34 -0400 Received: from mailman by lists.gnu.org with tmda-scanned (Exim 4.43) id 1MfMBo-0001dD-PT for grub-devel@gnu.org; Sun, 23 Aug 2009 19:09:32 -0400 Received: from exim by lists.gnu.org with spam-scanned (Exim 4.43) id 1MfMBl-0001SX-4u for grub-devel@gnu.org; Sun, 23 Aug 2009 19:09:32 -0400 Received: from [199.232.76.173] (port=37404 helo=monty-python.gnu.org) by lists.gnu.org with esmtp (Exim 4.43) id 1MfMBk-0001S9-PB for grub-devel@gnu.org; Sun, 23 Aug 2009 19:09:28 -0400 Received: from xvm-190-8.ghst.net ([217.70.190.8]:43948 helo=aybabtu.com) by monty-python.gnu.org with esmtps (TLS-1.0:RSA_AES_256_CBC_SHA1:32) (Exim 4.60) (envelope-from ) id 1MfMBk-0003Fd-HX for grub-devel@gnu.org; Sun, 23 Aug 2009 19:09:28 -0400 Received: from [192.168.10.10] (helo=thorin) by aybabtu.com with esmtp (Exim 4.69) (envelope-from ) id 1MfMBi-0001L6-Oa for grub-devel@gnu.org; Mon, 24 Aug 2009 01:09:26 +0200 Received: from rmh by thorin with local (Exim 4.69) (envelope-from ) id 1MfMBh-0006oL-Vq for grub-devel@gnu.org; Mon, 24 Aug 2009 01:09:25 +0200 Date: Mon, 24 Aug 2009 01:09:25 +0200 From: Robert Millan To: The development of GRUB 2 Message-ID: <20090823230925.GB26096@thorin> References: <1250287249.8137.65.camel@mj> <1250806584.2668.61.camel@mj> <20090823104031.GF4130@thorin> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: Organization: free as in freedom X-Message-Flag: Worried about Outlook viruses? Switch to Thunderbird! www.mozilla.com/thunderbird X-Debbugs-No-Ack: true User-Agent: Mutt/1.5.18 (2008-05-17) X-detected-operating-system: by monty-python.gnu.org: GNU/Linux 2.6 (newer, 3) Subject: Re: [PATCH] Split big and little endian BeFS and AtheFS X-BeenThere: grub-devel@gnu.org X-Mailman-Version: 2.1.5 Precedence: list Reply-To: The development of GRUB 2 List-Id: The development of GRUB 2 List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Sun, 23 Aug 2009 23:09:33 -0000 On Sun, Aug 23, 2009 at 01:04:30PM +0200, Vladimir 'phcoder' Serbinenko wrote: > On Sun, Aug 23, 2009 at 12:40 PM, Robert Millan wrote: > > On Thu, Aug 20, 2009 at 06:16:24PM -0400, Pavel Roskin wrote: > >> I don't think we should rename "byte_order" to "unused".  Just because > >> we doesn't use it now to determine the endianess, > > > > Shouldn't we be checking for it?  (and error out if mismatch). > This field is unstraightforward to use. We already have the same > information from the magic (which is stored in native-endian). I feel > like checking additional field will just lead to rejected FS > especially if I don't get this field right. In other words I prefer to > keep complexity to minimum especially in parts of code not used > extensively. As long as you're confident that we're discarding invalid FS reliably, no problem with it. -- Robert Millan The DRM opt-in fallacy: "Your data belongs to us. We will decide when (and how) you may access your data; but nobody's threatening your freedom: we still allow you to remove your data and not access it at all."