From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Date: Mon, 24 Aug 2009 15:53:44 +0200 From: Hendrik Brueckner Subject: Re: [GIT PULL] s390 patches for v2.6.31-rc7 Message-ID: <20090824135344.GC4639@cetus.boeblingen.de.ibm.com> References: <20090823213714.11757b14@skybase> <20090823201526.GA30461@wavehammer.waldi.eu.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20090823201526.GA30461@wavehammer.waldi.eu.org> Sender: linux-kernel-owner@vger.kernel.org List-Archive: List-Post: To: Bastian Blank Cc: Martin Schwidefsky , linux-kernel , linux-s390 , Heiko Carstens List-ID: Bastian, thanks for your feedback. On Sun, Aug 23, 2009 at 10:15:26PM +0200, Bastian Blank wrote: > On Sun, Aug 23, 2009 at 09:37:14PM +0200, Martin Schwidefsky wrote: > > +static void __init set_preferred_console(void) > > +{ > > + if (MACHINE_IS_KVM) { > > + add_preferred_console("hvc", 0, NULL); > > + s390_virtio_console_init(); > > + return; > > + } > > Why this early return instead of else if as all options are mutually > exclusive? Also why do you init the virtio console here instead of an > console_initcall? This is a bug fix to set the respective preferred console device for conmode=3270. To make as few changes as possible for -rc7, the console initialization for kvm has been moved to the new function. You are right that s390_virtio_console_init() should be called from a console_initcall(). I started working on another patch to solve this issue for the next kernel release. Best regards, Hendrik