From: Andrew Morton <akpm@linux-foundation.org>
To: Akinobu Mita <akinobu.mita@gmail.com>
Cc: Alexey Dobriyan <adobriyan@gmail.com>,
linux-kernel@vger.kernel.org, Ingo Molnar <mingo@elte.hu>,
Peter Zijlstra <peterz@infradead.org>
Subject: Re: [PATCH 1/7] sched: Use for_each_bit
Date: Sun, 31 Jan 2010 19:00:09 -0800 [thread overview]
Message-ID: <20100131190009.b266a27e.akpm@linux-foundation.org> (raw)
In-Reply-To: <961aa3351001311854s40d33804m715d7643fe430b5b@mail.gmail.com>
On Mon, 1 Feb 2010 11:54:14 +0900 Akinobu Mita <akinobu.mita@gmail.com> wrote:
> 2010/2/1 Andrew Morton <akpm@linux-foundation.org>:
> > On Sun, 31 Jan 2010 14:06:10 +0200 Alexey Dobriyan <adobriyan@gmail.com> wrote:
> >
> >> On Sun, Jan 31, 2010 at 1:53 PM, Akinobu Mita <akinobu.mita@gmail.com> wrote:
> >> > __#define for_each_cpupri_active(array, idx) __ __ __ __ __ __ __ __ __ __\
> >> > - __for (idx = find_first_bit(array, CPUPRI_NR_PRIORITIES); __ __ \
> >> > - __ __ __ idx < CPUPRI_NR_PRIORITIES; __ __ __ __ __ __ __ __ __ __ __ __ __ __\
> >> > - __ __ __ idx = find_next_bit(array, CPUPRI_NR_PRIORITIES, idx+1))
> >> > + __ __ __ for_each_bit(idx, array, CPUPRI_NR_PRIORITIES)
> >>
> >> It should be called for_each_set_bit().
> >
> > Agree.
>
> (I'm resending because I failed to reply all)
>
> You mean for_each_bit() should be renamed to for_each_set_bit() ?
Yes.
> I'm not sure. But if so, find_first_bit() also should be renamed to
> find_first_set_bit() and so on?
Yes, it should have been. It's a bit late to correct that mistake, but
it's not too late to fix for_each_bit().
next prev parent reply other threads:[~2010-02-01 3:00 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-01-31 11:53 [PATCH 1/7] sched: Use for_each_bit Akinobu Mita
2010-01-31 11:53 ` [PATCH 2/7] bitmap: " Akinobu Mita
2010-01-31 11:53 ` [PATCH 3/7] phonet: " Akinobu Mita
2010-01-31 11:53 ` [PATCH 4/7] intel-iommu: " Akinobu Mita
2010-01-31 11:53 ` [PATCH 5/7] infiniband: " Akinobu Mita
2010-01-31 11:53 ` [PATCH 6/7] atm: " Akinobu Mita
2010-01-31 11:53 ` [PATCH 7/7] hpet: " Akinobu Mita
2010-01-31 12:06 ` [PATCH 1/7] sched: " Alexey Dobriyan
2010-02-01 2:38 ` Andrew Morton
2010-02-01 2:54 ` Akinobu Mita
2010-02-01 3:00 ` Andrew Morton [this message]
2010-02-02 8:24 ` [tip:sched/core] " tip-bot for Akinobu Mita
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20100131190009.b266a27e.akpm@linux-foundation.org \
--to=akpm@linux-foundation.org \
--cc=adobriyan@gmail.com \
--cc=akinobu.mita@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=peterz@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.