From mboxrd@z Thu Jan 1 00:00:00 1970 From: Grant Likely Subject: Re: [PATCH 11/28] Blackfin SPI: convert struct names to something more logical Date: Mon, 18 Oct 2010 00:31:44 -0600 Message-ID: <20101018063144.GI19399@angua.secretlab.ca> References: <1287356381-31495-1-git-send-email-vapier@gentoo.org> <1287356381-31495-12-git-send-email-vapier@gentoo.org> <20101018060253.GA19399@angua.secretlab.ca> <20101018062025.GD19399@angua.secretlab.ca> Mime-Version: 1.0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable Cc: spi-devel-general-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org, David Brownell , uclinux-dist-devel-ZG0+EudsQA8dtHy/vicBwGD2FQJk+8+b@public.gmane.org To: Mike Frysinger Return-path: Content-Disposition: inline In-Reply-To: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: uclinux-dist-devel-bounces-ZG0+EudsQA8dtHy/vicBwGD2FQJk+8+b@public.gmane.org Errors-To: uclinux-dist-devel-bounces-ZG0+EudsQA8dtHy/vicBwGD2FQJk+8+b@public.gmane.org List-Id: linux-spi.vger.kernel.org On Mon, Oct 18, 2010 at 02:28:23AM -0400, Mike Frysinger wrote: > On Mon, Oct 18, 2010 at 02:20, Grant Likely wrote: > > On Mon, Oct 18, 2010 at 02:10:17AM -0400, Mike Frysinger wrote: > >> On Mon, Oct 18, 2010 at 02:02, Grant Likely wrote: > >> > On Sun, Oct 17, 2010 at 06:59:24PM -0400, Mike Frysinger wrote: > >> >> -struct driver_data { > >> >> +struct master_data { > >> > > >> > Or better yet, to protect against global collisions, bfin5xx_master = perhaps? > >> > >> i'd rather not. =A0there is too much "bfin5xx" stuff already which > >> shouldnt exist. =A0what collision could there possibly be ? > > > > For driver code, anything at the file scope has a potential conflict > > with the global scope. =A0If any header in include/linux were to define > > a "master_data" or a "slave_data" structure, (those are pretty generic > > names, it is well within the realm of possibilities) then it would > > conflict. > = > i dont think generic names like that would be allowed in global space > for this exact reason. ive already made sure all the data/function > symbols that are visible from a linkage stand point are properly > namespaced because unlike structures, those are externally visible by > tools such as kallsyms. > = > i'd really prefer to not have to redo all these patches considering > this one change will cascade into like 20 others. i'd be a lot more > amendable to a patch on top of all of these that namespaces the > structs. > -mike I'm okay with a patch on top. g.