From: Marcelo Tosatti <mtosatti@redhat.com>
To: Takuya Yoshikawa <takuya.yoshikawa@gmail.com>
Cc: avi@redhat.com, kvm@vger.kernel.org,
yoshikawa.takuya@oss.ntt.co.jp, gleb@redhat.com
Subject: Re: [PATCH 1/3] KVM: x86 emulator: Place insn_fetch helpers together
Date: Wed, 18 May 2011 09:51:12 -0300 [thread overview]
Message-ID: <20110518125112.GA9894@amt.cnet> (raw)
In-Reply-To: <20110515005458.9964c7b8.takuya.yoshikawa@gmail.com>
On Sun, May 15, 2011 at 12:54:58AM +0900, Takuya Yoshikawa wrote:
> From: Takuya Yoshikawa <yoshikawa.takuya@oss.ntt.co.jp>
>
> The two macros need special care to use:
> Assume rc, ctxt, ops and done exist outside of them.
> Can goto outside.
>
> Considering the fact that these are used only in decode functions,
> moving these right after do_insn_fetch() seems to be a right thing
> to improve the readability.
>
> We also rename do_fetch_insn_byte() to do_insn_fetch_byte() to be
> consistent.
>
> Signed-off-by: Takuya Yoshikawa <yoshikawa.takuya@oss.ntt.co.jp>
Applied all, thanks.
prev parent reply other threads:[~2011-05-18 13:18 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-05-14 15:54 [PATCH 1/3] KVM: x86 emulator: Place insn_fetch helpers together Takuya Yoshikawa
2011-05-14 15:57 ` [PATCH 2/3] KVM: x86 emulator: Stop passing ctxt->ops as arg of decode helpers Takuya Yoshikawa
2011-05-14 16:00 ` [PATCH 3/3] KVM: x86 emulator: Stop passing ctxt->ops as arg of emul functions Takuya Yoshikawa
2011-05-18 12:51 ` Marcelo Tosatti [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20110518125112.GA9894@amt.cnet \
--to=mtosatti@redhat.com \
--cc=avi@redhat.com \
--cc=gleb@redhat.com \
--cc=kvm@vger.kernel.org \
--cc=takuya.yoshikawa@gmail.com \
--cc=yoshikawa.takuya@oss.ntt.co.jp \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.