From: Jonathan Nieder <jrnieder@gmail.com>
To: Ramkumar Ramachandra <artagnon@gmail.com>
Cc: Git List <git@vger.kernel.org>,
Junio C Hamano <gitster@pobox.com>,
Christian Couder <chriscool@tuxfamily.org>,
Daniel Barkalow <barkalow@iabervon.org>
Subject: Re: [GSoC update] Sequencer: The insn sheet format
Date: Wed, 6 Jul 2011 05:41:51 -0500 [thread overview]
Message-ID: <20110706104151.GM15682@elie> (raw)
In-Reply-To: <1309938868-2028-1-git-send-email-artagnon@gmail.com>
Ramkumar Ramachandra wrote:
> Thanks for reading.
Thanks for the many improvements!
I think the hardest piece in the series so far is what to do about
the
git cherry-pick something-i-shouldnt-cherry-pick
git reset --hard; # or git reset --merge HEAD
git cherry-pick what-i-should-have-cherry-picked-instead
habit. Aside from that, it would be nice to have more tests and some
simple documentation, and most other things I found were nitpicks.
prev parent reply other threads:[~2011-07-06 10:42 UTC|newest]
Thread overview: 55+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-07-06 7:54 [GSoC update] Sequencer: The insn sheet format Ramkumar Ramachandra
2011-07-06 7:54 ` [PATCH 01/14] advice: Introduce error_resolve_conflict Ramkumar Ramachandra
2011-07-06 8:35 ` Jonathan Nieder
2011-07-06 9:28 ` Ramkumar Ramachandra
2011-07-06 10:03 ` Jonathan Nieder
2011-07-06 7:54 ` [PATCH 02/14] revert: Inline add_message_to_msg function Ramkumar Ramachandra
2011-07-06 7:54 ` [PATCH 03/14] revert: Don't check lone argument in get_encoding Ramkumar Ramachandra
2011-07-06 7:54 ` [PATCH 04/14] revert: Rename no_replay to record_origin Ramkumar Ramachandra
2011-07-06 7:54 ` [PATCH 05/14] revert: Propogate errors upwards from do_pick_commit Ramkumar Ramachandra
2011-07-06 8:50 ` Jonathan Nieder
2011-07-06 9:30 ` Ramkumar Ramachandra
2011-07-06 7:54 ` [PATCH 06/14] revert: Eliminate global "commit" variable Ramkumar Ramachandra
2011-07-06 8:55 ` Jonathan Nieder
2011-07-06 9:37 ` Ramkumar Ramachandra
2011-07-06 7:54 ` [PATCH 07/14] revert: Introduce struct to keep command-line options Ramkumar Ramachandra
2011-07-06 9:09 ` Jonathan Nieder
2011-07-06 11:20 ` Ramkumar Ramachandra
2011-07-06 12:06 ` Jonathan Nieder
2011-07-12 6:14 ` Ramkumar Ramachandra
2011-07-06 21:20 ` Junio C Hamano
2011-07-12 6:21 ` Ramkumar Ramachandra
2011-07-12 6:33 ` Jonathan Nieder
2011-07-06 7:54 ` [PATCH 08/14] revert: Separate cmdline parsing from functional code Ramkumar Ramachandra
2011-07-06 9:13 ` Jonathan Nieder
2011-07-06 9:34 ` Ramkumar Ramachandra
2011-07-06 7:54 ` [PATCH 09/14] revert: Don't create invalid replay_opts in parse_args Ramkumar Ramachandra
2011-07-06 9:20 ` Jonathan Nieder
2011-07-06 7:54 ` [PATCH 10/14] revert: Persist data for continuation Ramkumar Ramachandra
2011-07-06 10:01 ` Jonathan Nieder
2011-07-06 11:55 ` Ramkumar Ramachandra
2011-07-06 21:20 ` Junio C Hamano
2011-07-06 7:54 ` [PATCH 11/14] revert: Introduce a layer of indirection over pick_commits Ramkumar Ramachandra
2011-07-06 10:37 ` Jonathan Nieder
2011-07-06 11:24 ` Ramkumar Ramachandra
2011-07-06 11:39 ` Jonathan Nieder
2011-07-06 11:44 ` Ramkumar Ramachandra
2011-07-06 11:53 ` Jonathan Nieder
2011-07-06 21:00 ` Junio C Hamano
2011-07-07 6:31 ` Ramkumar Ramachandra
2011-07-06 7:54 ` [PATCH 12/14] revert: Introduce --reset to cleanup sequencer data Ramkumar Ramachandra
2011-07-06 10:14 ` Jonathan Nieder
2011-07-06 10:55 ` Ramkumar Ramachandra
2011-07-06 14:32 ` Ramkumar Ramachandra
2011-07-06 19:21 ` Jonathan Nieder
2011-07-06 19:56 ` Jonathan Nieder
2011-07-07 3:03 ` Ramkumar Ramachandra
2011-07-06 7:54 ` [PATCH 13/14] revert: Introduce --continue to continue the operation Ramkumar Ramachandra
2011-07-06 10:25 ` Jonathan Nieder
2011-07-06 21:21 ` Junio C Hamano
2011-07-06 21:52 ` Drew Northup
2011-07-07 6:35 ` Ramkumar Ramachandra
2011-07-06 7:54 ` [RFC PATCH 14/14] revert: Change insn sheet format Ramkumar Ramachandra
2011-07-06 10:33 ` Jonathan Nieder
2011-07-06 10:49 ` Ramkumar Ramachandra
2011-07-06 10:41 ` Jonathan Nieder [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20110706104151.GM15682@elie \
--to=jrnieder@gmail.com \
--cc=artagnon@gmail.com \
--cc=barkalow@iabervon.org \
--cc=chriscool@tuxfamily.org \
--cc=git@vger.kernel.org \
--cc=gitster@pobox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.