From: Jonathan Nieder <jrnieder@gmail.com>
To: Ramkumar Ramachandra <artagnon@gmail.com>
Cc: Git List <git@vger.kernel.org>,
Junio C Hamano <gitster@pobox.com>,
Christian Couder <chriscool@tuxfamily.org>,
Daniel Barkalow <barkalow@iabervon.org>
Subject: Re: [PATCH 06/17] revert: Eliminate global "commit" variable
Date: Wed, 13 Jul 2011 02:10:29 -0500 [thread overview]
Message-ID: <20110713071029.GA31285@elie> (raw)
In-Reply-To: <CALkWK0k3muAi_h7GRqgJ9vY8SwHK40-AwMdjA=uCDO8Ng4utCA@mail.gmail.com>
Ramkumar Ramachandra wrote:
> Right. How about this?
>
> revert: Eliminate global "commit" variable
>
> Functions which act on commits currently rely on a file-scope static
> variable to be set before they're called. Consequently, the API and
> corresponding callsites are ugly and unclear. Remove this variable
> and change their API to accept the commit to act on as additional
> argument so that the callsites change from looking like
>
> commit = prepare_a_commit();
> act_on_commit();
>
> to looking like
>
> commit = prepare_a_commit();
> act_on_commit(commit);
>
> This change is also in line with our long-term goal of exposing some
> of these functions through a public API.
Sounds fine to me. I could nitpick by saying that "Functions which
act on commits" is a little vague (I think the actual story is
something like "The global 'commit' variable used to represent one of
the arguments passed to 'git cherry-pick' or 'git revert' and thus was
static along with the options. When cherry-pick learned to replay
multiple commits in sequence, that wasn't changed, resulting in a
somewhat unnatural calling sequence that uses a global to pass in a
parameters:
for each commit c {
commit = c;
res = do_pick_commit();
if (res)
return res;
}
Teach do_pick_commit and the functions it calls to accept the commit
to act on as an argument, like we always should have. Part of a
campaign to clean up cherry-pick/revert's internal APIs before
exposing them.")
next prev parent reply other threads:[~2011-07-13 7:10 UTC|newest]
Thread overview: 99+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-07-11 14:53 [GSoC update] Sequencer for inclusion Ramkumar Ramachandra
2011-07-11 14:53 ` [PATCH 01/17] advice: Introduce error_resolve_conflict Ramkumar Ramachandra
2011-07-11 14:53 ` [PATCH 02/17] revert: Inline add_message_to_msg function Ramkumar Ramachandra
2011-07-12 16:53 ` Jonathan Nieder
2011-07-13 6:00 ` Ramkumar Ramachandra
2011-07-13 6:42 ` Jonathan Nieder
2011-07-19 16:36 ` Ramkumar Ramachandra
2011-07-19 16:52 ` Junio C Hamano
2011-07-19 17:08 ` Ramkumar Ramachandra
2011-07-19 19:36 ` Jonathan Nieder
2011-07-20 5:32 ` Ramkumar Ramachandra
2011-07-11 14:53 ` [PATCH 03/17] revert: Don't check lone argument in get_encoding Ramkumar Ramachandra
2011-07-12 16:59 ` Jonathan Nieder
2011-07-13 6:14 ` Ramkumar Ramachandra
2011-07-13 6:30 ` Jonathan Nieder
2011-07-11 14:53 ` [PATCH 04/17] revert: Rename no_replay to record_origin Ramkumar Ramachandra
2011-07-12 17:02 ` Jonathan Nieder
2011-07-13 7:35 ` Ramkumar Ramachandra
2011-07-17 19:36 ` Jonathan Nieder
2011-07-11 14:53 ` [PATCH 05/17] revert: Propogate errors upwards from do_pick_commit Ramkumar Ramachandra
2011-07-12 17:32 ` Jonathan Nieder
2011-07-17 10:46 ` Ramkumar Ramachandra
2011-07-17 16:59 ` Jonathan Nieder
2011-07-19 10:09 ` Ramkumar Ramachandra
2011-07-11 14:53 ` [PATCH 06/17] revert: Eliminate global "commit" variable Ramkumar Ramachandra
2011-07-12 17:45 ` Jonathan Nieder
2011-07-13 6:57 ` Ramkumar Ramachandra
2011-07-13 7:10 ` Jonathan Nieder [this message]
2011-07-13 8:33 ` Ramkumar Ramachandra
2011-07-13 16:40 ` Jonathan Nieder
2011-07-11 14:53 ` [PATCH 07/17] revert: Introduce struct to keep command-line options Ramkumar Ramachandra
2011-07-12 18:05 ` Jonathan Nieder
2011-07-13 7:56 ` Ramkumar Ramachandra
2011-07-11 14:53 ` [PATCH 08/17] revert: Separate cmdline parsing from functional code Ramkumar Ramachandra
2011-07-12 18:20 ` Jonathan Nieder
2011-07-18 20:53 ` Ramkumar Ramachandra
2011-07-18 21:03 ` Jonathan Nieder
2011-07-11 14:54 ` [PATCH 09/17] revert: Don't create invalid replay_opts in parse_args Ramkumar Ramachandra
2011-07-11 20:44 ` Junio C Hamano
2011-07-12 5:57 ` Ramkumar Ramachandra
2011-07-12 18:29 ` Jonathan Nieder
2011-07-17 11:56 ` Ramkumar Ramachandra
2011-07-17 18:43 ` Jonathan Nieder
2011-07-11 14:54 ` [PATCH 10/17] sequencer: Announce sequencer state location Ramkumar Ramachandra
2011-07-12 18:56 ` Jonathan Nieder
2011-07-13 12:10 ` Sverre Rabbelier
2011-07-17 16:23 ` Ramkumar Ramachandra
2011-07-17 19:19 ` Jonathan Nieder
2011-07-18 19:44 ` Ramkumar Ramachandra
2011-07-11 14:54 ` [PATCH 11/17] revert: Save data for continuing after conflict resolution Ramkumar Ramachandra
2011-07-11 21:01 ` Junio C Hamano
2011-07-11 21:31 ` Junio C Hamano
2011-07-12 5:43 ` Ramkumar Ramachandra
2011-07-12 19:37 ` Jonathan Nieder
2011-07-17 11:48 ` Ramkumar Ramachandra
2011-07-17 18:40 ` Jonathan Nieder
2011-07-18 19:31 ` Ramkumar Ramachandra
2011-07-19 12:21 ` Jonathan Nieder
2011-07-19 12:34 ` Ramkumar Ramachandra
2011-07-11 14:54 ` [PATCH 12/17] revert: Save command-line options for continuing operation Ramkumar Ramachandra
2011-07-11 21:15 ` Junio C Hamano
2011-07-12 5:56 ` Ramkumar Ramachandra
2011-07-12 19:52 ` Jonathan Nieder
2011-07-18 20:18 ` Ramkumar Ramachandra
2011-07-11 14:54 ` [PATCH 13/17] revert: Introduce a layer of indirection over pick_commits Ramkumar Ramachandra
2011-07-12 20:03 ` Jonathan Nieder
2011-07-18 21:24 ` Ramkumar Ramachandra
2011-07-11 14:54 ` [PATCH 14/17] reset: Make hard reset remove the sequencer state Ramkumar Ramachandra
2011-07-12 20:15 ` Jonathan Nieder
2011-07-17 16:40 ` Ramkumar Ramachandra
2011-07-11 14:54 ` [PATCH 15/17] revert: Remove sequencer state when no commits are pending Ramkumar Ramachandra
2011-07-11 19:58 ` Junio C Hamano
2011-07-12 6:26 ` Ramkumar Ramachandra
2011-07-11 14:54 ` [PATCH 16/17] revert: Introduce --reset to remove sequencer state Ramkumar Ramachandra
2011-07-12 20:30 ` Jonathan Nieder
2011-07-17 17:10 ` Ramkumar Ramachandra
2011-07-17 19:25 ` Jonathan Nieder
2011-07-11 14:54 ` [PATCH 17/17] revert: Introduce --continue to continue the operation Ramkumar Ramachandra
2011-07-12 20:46 ` Jonathan Nieder
2011-07-17 16:11 ` Ramkumar Ramachandra
2011-07-17 18:32 ` Jonathan Nieder
2011-07-18 20:00 ` Ramkumar Ramachandra
2011-07-18 20:09 ` Jonathan Nieder
2011-07-11 17:17 ` [GSoC update] Sequencer for inclusion Jonathan Nieder
2011-07-11 17:57 ` Ramkumar Ramachandra
2011-07-11 20:05 ` Ramkumar Ramachandra
2011-07-11 20:11 ` Jonathan Nieder
2011-07-12 7:05 ` Ramkumar Ramachandra
2011-07-11 20:07 ` Junio C Hamano
2011-07-11 22:14 ` Jeff King
2011-07-12 6:41 ` Ramkumar Ramachandra
2011-07-12 6:47 ` Jeff King
2011-07-13 9:41 ` Ramkumar Ramachandra
2011-07-13 19:07 ` Jeff King
2011-07-18 21:37 ` [RFC PATCH] config: Introduce functions to write non-standard file Ramkumar Ramachandra
2011-07-18 23:54 ` Junio C Hamano
2011-07-19 8:52 ` Ramkumar Ramachandra
2011-07-12 5:58 ` [GSoC update] Sequencer for inclusion Jonathan Nieder
2011-07-12 6:28 ` Miles Bader
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20110713071029.GA31285@elie \
--to=jrnieder@gmail.com \
--cc=artagnon@gmail.com \
--cc=barkalow@iabervon.org \
--cc=chriscool@tuxfamily.org \
--cc=git@vger.kernel.org \
--cc=gitster@pobox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.