From: Dave Chinner <david@fromorbit.com>
To: Christoph Hellwig <hch@infradead.org>
Cc: xfs@oss.sgi.com
Subject: Re: [PATCH 4/6] xfs: call xfs_buf_delwri_queue directly
Date: Mon, 22 Aug 2011 16:22:11 +1000 [thread overview]
Message-ID: <20110822062211.GH3162@dastard> (raw)
In-Reply-To: <20110814171652.350395176@bombadil.infradead.org>
On Sun, Aug 14, 2011 at 01:15:21PM -0400, Christoph Hellwig wrote:
> Unify the ways we add buffers to the delwri queue by always calling
> xfs_buf_delwri_queue directly. The xfs_bdwrite functions is removed and
> opencoded in its callers, and the two places setting XBF_DELWRI while a
> buffer is locked and expecting xfs_buf_unlock to pick it up are converted
> to call xfs_buf_delwri_queue directly, too. Also replace the
> XFS_BUF_UNDELAYWRITE macro with direct calls to xfs_buf_delwri_dequeue
> to make the explicit queuing/dequeuing more obvious.
>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Dave Chinner <dchinner@redhat.com>
--
Dave Chinner
david@fromorbit.com
_______________________________________________
xfs mailing list
xfs@oss.sgi.com
http://oss.sgi.com/mailman/listinfo/xfs
next prev parent reply other threads:[~2011-08-22 6:23 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-08-14 17:15 [PATCH 0/6] delwri cleanups Christoph Hellwig
2011-08-14 17:15 ` [PATCH 1/6] xfs: remove delwri buffer handling from xfs_buf_iorequest Christoph Hellwig
2011-08-22 6:09 ` Dave Chinner
2011-08-14 17:15 ` [PATCH 2/6] xfs: remove the unlock argument to xfs_buf_delwri_queue Christoph Hellwig
2011-08-22 6:16 ` Dave Chinner
2011-08-14 17:15 ` [PATCH 3/6] xfs: move more delwri setup into xfs_buf_delwri_queue Christoph Hellwig
2011-08-22 6:19 ` Dave Chinner
2011-08-14 17:15 ` [PATCH 4/6] xfs: call xfs_buf_delwri_queue directly Christoph Hellwig
2011-08-22 6:22 ` Dave Chinner [this message]
2011-08-14 17:15 ` [PATCH 5/6] xfs: let xfs_bwrite callers handle the xfs_buf_relse Christoph Hellwig
2011-08-22 6:24 ` Dave Chinner
2011-08-14 17:15 ` [PATCH 6/6] xfs: use the "delwri" terminology consistently Christoph Hellwig
2011-08-22 6:26 ` Dave Chinner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20110822062211.GH3162@dastard \
--to=david@fromorbit.com \
--cc=hch@infradead.org \
--cc=xfs@oss.sgi.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.