All of lore.kernel.org
 help / color / mirror / Atom feed
From: Antonio Quartulli <ordex@autistici.org>
To: The list for a Better Approach To Mobile Ad-hoc Networking
	<b.a.t.m.a.n@lists.open-mesh.org>
Subject: Re: [B.A.T.M.A.N.] [PATCH] batman-adv: generalise tt_local_reset_flags()
Date: Tue, 1 Nov 2011 14:43:49 +0100	[thread overview]
Message-ID: <20111101134348.GH20215@ritirata.org> (raw)
In-Reply-To: <20111031004201.GH10726@pandem0nium>

On Mon, Oct 31, 2011 at 01:42:01AM +0100, Simon Wunderlich wrote:
> Hey Antonio,
> 
> I don't quite understand what this patch is good for - it generalises the function,
> but does not use the function at another point. So what it is good for (next to
> add more complexity to batman ;] ).
> 
> Furthermore it counts the changes and adds it to num_local_tt, is there a bug fix
> hidden in this patch somewhere? :)

No hidden bug-fix here :)
This patch aims to generalise the tt_local_reset_flags() function only. As I
discussed with Sven on IRC, this function could be quite confusing, because its
name suggests that it can be used either for other purposes, but this is not
true: it can only be used as it is now in the code.

Therefore this patch wants to generalise it enough in order to be eventually
used elsewhere.

The increment of tt_local_num is actually done inside the function and it is
useful only for the use case proposed in the current code. To generalise the
function I had to move the increment outside (somebody else could want to flip a
certain flag without affecting the local counter :-) ).

IMHO this patch is not strictly needed, but it would clean the code up (Until
it doesn't add any complexity :P)

Cheers,

-- 
Antonio Quartulli

..each of us alone is worth nothing..
Ernesto "Che" Guevara

  reply	other threads:[~2011-11-01 13:43 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-10-30 19:09 [B.A.T.M.A.N.] [PATCH] batman-adv: generalise tt_local_reset_flags() Antonio Quartulli
2011-10-31  0:42 ` Simon Wunderlich
2011-11-01 13:43   ` Antonio Quartulli [this message]
2011-11-04 15:00     ` Simon Wunderlich
2011-11-07 15:47 ` [B.A.T.M.A.N.] [PATCHv2] " Antonio Quartulli
2011-11-08 17:02   ` Marek Lindner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20111101134348.GH20215@ritirata.org \
    --to=ordex@autistici.org \
    --cc=b.a.t.m.a.n@lists.open-mesh.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.