From mboxrd@z Thu Jan 1 00:00:00 1970 From: Mike Frysinger Date: Tue, 14 Feb 2012 01:46:19 -0500 Subject: [U-Boot] [PATCH 26/28] net: Add link-local addressing support In-Reply-To: References: <1327020811-1538-1-git-send-email-joe.hershberger@ni.com> <201202030742.43438.vapier@gentoo.org> Message-ID: <201202140146.22432.vapier@gentoo.org> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de On Monday 13 February 2012 15:21:12 Joe Hershberger wrote: > On Fri, Feb 3, 2012 at 6:42 AM, Mike Frysinger wrote: > > On Thursday 19 January 2012 19:53:29 Joe Hershberger wrote: > >> + NetOurGatewayIP = 0; > >> + ip_to_string(NetOurGatewayIP, tmp); > >> + setenv("gatewayip", tmp); > >> + > >> + ip_to_string(NetOurSubnetMask, tmp); > >> + setenv("netmask", tmp); > >> + > >> + ip_to_string(NetOurIP, tmp); > >> + setenv("ipaddr", tmp); > > > > i feel like we should add a helper to do this > > setenv_ip("ipaddr", NetOurIP); > > I think that's a good idea, but I don't think it should be part of > this patch series. It would probably be clearer to do that > independently later. that's fine > >> --- a/net/Makefile > >> +++ b/net/Makefile > >> > >> -COBJS := $(COBJS-y) > >> +COBJS := $(sort $(COBJS-y)) > > > > why ? > > Sort is needed because there are 2 different config options that could > add the net_rand source file and sort will eliminate duplicates. i'd say "needs a comment", but it seems we already crossed that threshold in other Makefiles. should probably make this the standard moving forward so people can copy & paste & not ask again. -mike -------------- next part -------------- A non-text attachment was scrubbed... Name: not available Type: application/pgp-signature Size: 836 bytes Desc: This is a digitally signed message part. URL: