From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [Linaro-mm-sig] [PATCH] dma-buf: add get_dma_buf() Date: Sun, 18 Mar 2012 20:04:53 +0100 Message-ID: <20120318190453.GJ4286@phenom.ffwll.local> References: <1331913881-13105-1-git-send-email-rob.clark@linaro.org> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Return-path: Content-Disposition: inline In-Reply-To: Sender: linux-media-owner@vger.kernel.org To: Sumit Semwal Cc: Dave Airlie , Rob Clark , patches@linaro.org, dri-devel@lists.freedesktop.org, linaro-mm-sig@lists.linaro.org, daniel@ffwll.ch, airlied@redhat.com, linux-media@vger.kernel.org List-Id: dri-devel@lists.freedesktop.org On Sun, Mar 18, 2012 at 01:12:22PM +0530, Sumit Semwal wrote: > On 16 March 2012 23:23, Dave Airlie wrote: > > On Fri, Mar 16, 2012 at 4:04 PM, Rob Clark wrote: > >> From: Rob Clark > >> > >> Works in a similar way to get_file(), and is needed in cases such as > >> when the exporter needs to also keep a reference to the dmabuf (that > >> is later released with a dma_buf_put()), and possibly other similar > >> cases. > >> > >> Signed-off-by: Rob Clark > > > > Reviewed-by: Dave Airlie > > > Thanks; pulled into for-next. I'm back from vacation and already grumpily complaining about dma-buf patches ;-) For consistency with dma_buf_put we should call this dma_buf_get instead of get_dma_buf ... I'll write a bikeshed patch on top of your tree. -Daniel -- Daniel Vetter Mail: daniel@ffwll.ch Mobile: +41 (0)79 365 57 48