From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [Linaro-mm-sig] [PATCH] dma-buf: add get_dma_buf() Date: Sun, 18 Mar 2012 20:15:33 +0100 Message-ID: <20120318191533.GK4286@phenom.ffwll.local> References: <1331913881-13105-1-git-send-email-rob.clark@linaro.org> <20120318190453.GJ4286@phenom.ffwll.local> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-wi0-f171.google.com (mail-wi0-f171.google.com [209.85.212.171]) by gabe.freedesktop.org (Postfix) with ESMTP id 5FE239E8A0 for ; Sun, 18 Mar 2012 12:14:51 -0700 (PDT) Received: by wibhj13 with SMTP id hj13so2225995wib.12 for ; Sun, 18 Mar 2012 12:14:50 -0700 (PDT) Content-Disposition: inline In-Reply-To: <20120318190453.GJ4286@phenom.ffwll.local> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: dri-devel-bounces+sf-dri-devel=m.gmane.org@lists.freedesktop.org Errors-To: dri-devel-bounces+sf-dri-devel=m.gmane.org@lists.freedesktop.org To: Sumit Semwal Cc: patches@linaro.org, dri-devel@lists.freedesktop.org, Rob Clark , linaro-mm-sig@lists.linaro.org, airlied@redhat.com, linux-media@vger.kernel.org List-Id: dri-devel@lists.freedesktop.org On Sun, Mar 18, 2012 at 08:04:53PM +0100, Daniel Vetter wrote: > On Sun, Mar 18, 2012 at 01:12:22PM +0530, Sumit Semwal wrote: > > On 16 March 2012 23:23, Dave Airlie wrote: > > > On Fri, Mar 16, 2012 at 4:04 PM, Rob Clark wrote: > > >> From: Rob Clark > > >> > > >> Works in a similar way to get_file(), and is needed in cases such as > > >> when the exporter needs to also keep a reference to the dmabuf (that > > >> is later released with a dma_buf_put()), and possibly other similar > > >> cases. > > >> > > >> Signed-off-by: Rob Clark > > > > > > Reviewed-by: Dave Airlie > > > > > Thanks; pulled into for-next. > > I'm back from vacation and already grumpily complaining about dma-buf > patches ;-) For consistency with dma_buf_put we should call this > dma_buf_get instead of get_dma_buf ... I'll write a bikeshed patch on top > of your tree. Oops, there's already a dma_buf_get around - Rob and Dave pointed that out on irc to dense me. And I can't come up with a saner naming scheme. I'll retract my bikeshed. -Daniel -- Daniel Vetter Mail: daniel@ffwll.ch Mobile: +41 (0)79 365 57 48 From mboxrd@z Thu Jan 1 00:00:00 1970 Return-path: Received: from mail-wi0-f172.google.com ([209.85.212.172]:42675 "EHLO mail-wi0-f172.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754998Ab2CRTOv (ORCPT ); Sun, 18 Mar 2012 15:14:51 -0400 Received: by wibhj6 with SMTP id hj6so2968251wib.1 for ; Sun, 18 Mar 2012 12:14:50 -0700 (PDT) Date: Sun, 18 Mar 2012 20:15:33 +0100 From: Daniel Vetter To: Sumit Semwal Cc: Dave Airlie , Rob Clark , patches@linaro.org, dri-devel@lists.freedesktop.org, linaro-mm-sig@lists.linaro.org, daniel@ffwll.ch, airlied@redhat.com, linux-media@vger.kernel.org Subject: Re: [Linaro-mm-sig] [PATCH] dma-buf: add get_dma_buf() Message-ID: <20120318191533.GK4286@phenom.ffwll.local> References: <1331913881-13105-1-git-send-email-rob.clark@linaro.org> <20120318190453.GJ4286@phenom.ffwll.local> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20120318190453.GJ4286@phenom.ffwll.local> Sender: linux-media-owner@vger.kernel.org List-ID: On Sun, Mar 18, 2012 at 08:04:53PM +0100, Daniel Vetter wrote: > On Sun, Mar 18, 2012 at 01:12:22PM +0530, Sumit Semwal wrote: > > On 16 March 2012 23:23, Dave Airlie wrote: > > > On Fri, Mar 16, 2012 at 4:04 PM, Rob Clark wrote: > > >> From: Rob Clark > > >> > > >> Works in a similar way to get_file(), and is needed in cases such as > > >> when the exporter needs to also keep a reference to the dmabuf (that > > >> is later released with a dma_buf_put()), and possibly other similar > > >> cases. > > >> > > >> Signed-off-by: Rob Clark > > > > > > Reviewed-by: Dave Airlie > > > > > Thanks; pulled into for-next. > > I'm back from vacation and already grumpily complaining about dma-buf > patches ;-) For consistency with dma_buf_put we should call this > dma_buf_get instead of get_dma_buf ... I'll write a bikeshed patch on top > of your tree. Oops, there's already a dma_buf_get around - Rob and Dave pointed that out on irc to dense me. And I can't come up with a saner naming scheme. I'll retract my bikeshed. -Daniel -- Daniel Vetter Mail: daniel@ffwll.ch Mobile: +41 (0)79 365 57 48