From mboxrd@z Thu Jan 1 00:00:00 1970 From: Tom Rini Date: Thu, 13 Sep 2012 10:39:34 -0700 Subject: [U-Boot] [PATCH v2 0/7] gpt: GUID Partition Table (GPT) restoration In-Reply-To: <20120913082016.529dbd84@amdc308.digital.local> References: <1345795995-24656-1-git-send-email-l.majewski@samsung.com> <1347461446-32097-1-git-send-email-l.majewski@samsung.com> <5050C51F.6050508@ti.com> <20120913082016.529dbd84@amdc308.digital.local> Message-ID: <20120913173934.GC19851@bill-the-cat> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de On Thu, Sep 13, 2012 at 08:20:16AM +0200, Lukasz Majewski wrote: > Hi Tom, > > Thanks for review. > > > On 09/12/2012 07:50 AM, Lukasz Majewski wrote: > > > This patch series provides a new command - "gpt" for eMMC partition > > > table (in the GPT format) restoration. > > > > > > As a pre-work, some cleanup at the part_efi.c file was performed to > > > remove custom macros and make GPT related structures more readable. > > > > > > Moreover the part_efi.h file has been moved to ./include directory > > > to be easily available from other subsystems. > > > > > > The GPT detailed description has been written to README.gpt file. > > > > > > Tested at: > > > - Exynos4210 rev.1 - TRATS Samsung development board > > > > I had two very minor comments. Aside from that, please make sure the > > series is checkpatch clean (I haven't checked). Thanks! > > There is one little problem with the checkpatch: > > The patch: > [PATCH v2 2/7] part:efi: Move part_efi.h file to ./include > > "touches" some legacy code, and checkpatch complaints about e.g.: > > WARNING: do not add new typedefs > #281: FILE: include/part_efi.h:97: > +typedef struct _gpt_header { > > which I don't want to change in this patch series. > > Moreover it complaints about: > WARNING: __packed is preferred over __attribute__((packed)) > #303: FILE: include/part_efi.h:119: > +} __attribute__ ((packed)) gpt_entry_attributes; > which was changed at further patch (which I believe is a better place > to do so): > [PATCH v2 4/7] gpt: The leXX_to_int() calls replaced with ones defined > at > > To sum up - some checkpatch warnings appears since I've moved a legacy > code to a new place. > Rest of those patches is checkpatch "clean". Sounds good to me, thanks for the explanation. -- Tom -------------- next part -------------- A non-text attachment was scrubbed... Name: not available Type: application/pgp-signature Size: 836 bytes Desc: Digital signature URL: