From: Jesse Barnes <jbarnes@virtuousgeek.org>
To: Mario Kleiner <mario.kleiner@tuebingen.mpg.de>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 1/2] drm: add flags argument to crtc page_flip callback
Date: Fri, 2 Nov 2012 09:00:52 -0700 [thread overview]
Message-ID: <20121102090052.62db0473@jbarnes-desktop> (raw)
In-Reply-To: <50934C16.6080800@tuebingen.mpg.de>
On Fri, 02 Nov 2012 05:29:10 +0100
Mario Kleiner <mario.kleiner@tuebingen.mpg.de> wrote:
> On 30.10.12 19:33, Jesse Barnes wrote:
> > This lets us pass down flags the drivers might be interested in, e.g. async.
> >
> > Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
>
> Hi Jesse
>
> I like it :) -- Anything that helps to get rid of the troublesome
> 'SwapBuffersWait' madness in the ddx at some point makes me happy.
>
> > diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
> > index ef1b221..b4964ac 100644
> > --- a/drivers/gpu/drm/drm_crtc.c
> > +++ b/drivers/gpu/drm/drm_crtc.c
> > @@ -3627,7 +3627,7 @@ int drm_mode_page_flip_ioctl(struct drm_device *dev,
> > (void (*) (struct drm_pending_event *)) kfree;
> > }
> >
> > - ret = crtc->funcs->page_flip(crtc, fb, e);
> > + ret = crtc->funcs->page_flip(crtc, fb, e, flags);
>
> I think this should be page_flip->flags, ie.
>
> + ret = crtc->funcs->page_flip(crtc, fb, e, page_flip->flags);
>
> because flags is used here:
>
> > if (ret) {
> > if (page_flip->flags & DRM_MODE_PAGE_FLIP_EVENT) {
> > spin_lock_irqsave(&dev->event_lock, flags);
>
> to spin_lock_irqsave.
>
> As a tiny nit-pick, you sometimes name the variable 'flags', sometimes
> 'flip_flags' in the different kms implementations below, which could be
> made consistent.
>
> Reviewed-by: mario.kleiner@tuebingen.mpg.de
>
Yeah thanks. After I used 'flags' everywhere I saw the locking ones
and changed some, but obviously didn't catch them all. :)
I'll fix things up to be more consistent.
Thanks,
--
Jesse Barnes, Intel Open Source Technology Center
next prev parent reply other threads:[~2012-11-02 16:00 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-10-30 18:33 [RFC] Async flips Jesse Barnes
2012-10-30 18:33 ` [PATCH 1/2] drm: add flags argument to crtc page_flip callback Jesse Barnes
2012-11-02 4:29 ` Mario Kleiner
2012-11-02 16:00 ` Jesse Barnes [this message]
2012-10-30 18:33 ` [PATCH 2/2] drm/i915: add async flip support on gen7 Jesse Barnes
2012-10-31 17:47 ` Eric Anholt
2012-10-31 19:24 ` Jesse Barnes
2012-10-31 12:53 ` [RFC] Async flips Ville Syrjälä
2012-10-31 15:23 ` Jesse Barnes
2012-10-31 15:26 ` Daniel Vetter
2012-10-31 15:39 ` Jesse Barnes
2012-10-31 15:49 ` Chris Wilson
2012-10-31 16:03 ` Daniel Vetter
2012-10-31 16:27 ` Jesse Barnes
2012-10-31 16:05 ` Ville Syrjälä
2012-10-31 17:44 ` Eric Anholt
2012-10-31 18:51 ` Ville Syrjälä
2012-11-02 4:45 ` Mario Kleiner
2012-11-02 9:29 ` Ville Syrjälä
2012-11-12 3:53 ` Mario Kleiner
2012-11-12 12:04 ` Ville Syrjälä
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20121102090052.62db0473@jbarnes-desktop \
--to=jbarnes@virtuousgeek.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=mario.kleiner@tuebingen.mpg.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.