From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from eggs.gnu.org ([208.118.235.92]:42938) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1Tpzgj-0006sq-G7 for qemu-devel@nongnu.org; Tue, 01 Jan 2013 06:07:19 -0500 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71) (envelope-from ) id 1Tpzgi-0002OV-2X for qemu-devel@nongnu.org; Tue, 01 Jan 2013 06:07:17 -0500 Received: from hall.aurel32.net ([2001:470:1f15:c4f::1]:52758) by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1Tpzgh-0002OI-Ru for qemu-devel@nongnu.org; Tue, 01 Jan 2013 06:07:15 -0500 Date: Tue, 1 Jan 2013 12:07:08 +0100 From: Aurelien Jarno Message-ID: <20130101110708.GF16659@ohm.aurel32.net> References: <20121210161555.GA44699@cs.nctu.edu.tw> <20121220012318.GA10284@cs.nctu.edu.tw> <1355968783.19189.7.camel@liguang.fnst.cn.fujitsu.com> <20121220021420.GA11565@cs.nctu.edu.tw> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: <20121220021420.GA11565@cs.nctu.edu.tw> Subject: Re: [Qemu-devel] [PATCH] target-mips: Use EXCP_SC rather than a magic number List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , To: =?utf-8?B?6Zmz6Z+L5Lu7IChXZWktUmVuIENoZW4p?= Cc: qemu-devel@nongnu.org, li guang , "Johnson, Eric" On Thu, Dec 20, 2012 at 10:14:20AM +0800, 陳韋任 (Wei-Ren Chen) wrote: > Hi Li, > > > > > Signed-off-by: Chen Wei-Ren > > > > --- > > > > target-mips/op_helper.c | 6 +++--- > > > > 1 files changed, 3 insertions(+), 3 deletions(-) > > > > > > > > diff --git a/target-mips/op_helper.c b/target-mips/op_helper.c > > > > index f45d494..98a445c 100644 > > > > --- a/target-mips/op_helper.c > > > > +++ b/target-mips/op_helper.c > > > > @@ -39,10 +39,10 @@ static inline void QEMU_NORETURN do_raise_exception_err(CPUMIPSState *env, > > > > uintptr_t pc) > > > > { > > > > TranslationBlock *tb; > > > > -#if 1 > > > > - if (exception < 0x100) > > > > + if (exception < EXCP_SC) { > > > > qemu_log("%s: %d %d\n", __func__, exception, error_code); > > > > -#endif > > > > + } > > > > + > > > > seems original '#if 1, #endif' statement > > is for temporary debug only, > > so maybe can be concealed out entirely. > > for log purpose, every exception code > > will log when 'do_interrupt' for MIPS > > if log is enabled. > > Thanks for your feedback. You mean the code snippet below? > > --- target-mips/helper.c > void do_interrupt (CPUMIPSState *env) > { > ... > > if (qemu_log_enabled() && env->exception_index != EXCP_EXT_INTERRUPT) { > if (env->exception_index < 0 || env->exception_index > EXCP_LAST) > name = "unknown"; > else > name = excp_names[env->exception_index]; > > qemu_log("%s enter: PC " TARGET_FMT_lx " EPC " TARGET_FMT_lx " %s exception\n", > __func__, env->active_tc.PC, env->CP0_EPC, name); > } > > ... > } > I don't think this is necessary to add a qemu_log_enabled(), this is already something included in qemu_log(). -- Aurelien Jarno GPG: 1024D/F1BCDB73 aurelien@aurel32.net http://www.aurel32.net