From mboxrd@z Thu Jan 1 00:00:00 1970 From: Alasdair G Kergon Subject: Re: [PATCH 6/8] [persistent-data] Add a transactional array. Date: Mon, 28 Jan 2013 20:22:24 +0000 Message-ID: <20130128202224.GB30665@agk-dp.fab.redhat.com> References: <1355429956-22785-1-git-send-email-ejt@redhat.com> <1355429956-22785-7-git-send-email-ejt@redhat.com> <20130125201106.GJ3122@agk-dp.fab.redhat.com> <20130128145735.GE2442@raspberrypi> Reply-To: device-mapper development Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Content-Disposition: inline In-Reply-To: <20130128145735.GE2442@raspberrypi> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: dm-devel-bounces@redhat.com Errors-To: dm-devel-bounces@redhat.com To: Joe Thornber Cc: dm-devel@redhat.com List-Id: dm-devel.ids On Mon, Jan 28, 2013 at 02:57:36PM +0000, Joe Thornber wrote: > I've refactored the grow() function, breaking it up to reduce > indentation. However, I've left in 'else' clauses. I find the > following says 'there are three options' ... Indeed, breaking it up like that has improved the readability and the final else makes little difference now. Alasdair