From mboxrd@z Thu Jan 1 00:00:00 1970 From: Daniel Vetter Subject: Re: [PATCH] drm: cleanup: use drm_framebuffer_reference instead of a kref_get Date: Wed, 10 Apr 2013 11:18:26 +0200 Message-ID: <20130410091826.GG27612@phenom.ffwll.local> References: <1365584380-11772-1-git-send-email-archit@ti.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: Received: from mail-ee0-f41.google.com (mail-ee0-f41.google.com [74.125.83.41]) by gabe.freedesktop.org (Postfix) with ESMTP id 6CFD4E6008 for ; Wed, 10 Apr 2013 02:15:28 -0700 (PDT) Received: by mail-ee0-f41.google.com with SMTP id c1so121053eek.0 for ; Wed, 10 Apr 2013 02:15:27 -0700 (PDT) Content-Disposition: inline In-Reply-To: <1365584380-11772-1-git-send-email-archit@ti.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: dri-devel-bounces+sf-dri-devel=m.gmane.org@lists.freedesktop.org Errors-To: dri-devel-bounces+sf-dri-devel=m.gmane.org@lists.freedesktop.org To: Archit Taneja Cc: dri-devel@lists.freedesktop.org List-Id: dri-devel@lists.freedesktop.org On Wed, Apr 10, 2013 at 02:29:39PM +0530, Archit Taneja wrote: > drm_framebuffer_lookup() does a kref_get() for the framebuffer if it finds one > corresponding to the fb id passed to it. Use drm_framebuffer_reference() instead > for clarity since it's the function used in other places to take a reference. > > Signed-off-by: Archit Taneja Reviewed-by: Daniel Vetter > --- > drivers/gpu/drm/drm_crtc.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c > index dd64a06..a3b63cf 100644 > --- a/drivers/gpu/drm/drm_crtc.c > +++ b/drivers/gpu/drm/drm_crtc.c > @@ -412,7 +412,7 @@ struct drm_framebuffer *drm_framebuffer_lookup(struct drm_device *dev, > mutex_lock(&dev->mode_config.fb_lock); > fb = __drm_framebuffer_lookup(dev, id); > if (fb) > - kref_get(&fb->refcount); > + drm_framebuffer_reference(fb); > mutex_unlock(&dev->mode_config.fb_lock); > > return fb; > -- > 1.7.10.4 > -- Daniel Vetter Software Engineer, Intel Corporation +41 (0) 79 365 57 48 - http://blog.ffwll.ch