All of lore.kernel.org
 help / color / mirror / Atom feed
From: Lukas Fleischer <git@cryptocrack.de>
To: Jeff King <peff@peff.net>
Cc: git@vger.kernel.org
Subject: Re: [PATCH 1/3] Make read_index_data() public
Date: Sat, 13 Apr 2013 10:23:17 +0200	[thread overview]
Message-ID: <20130413082317.GA31894@blizzard> (raw)
In-Reply-To: <20130412194012.GA5154@sigill.intra.peff.net>

On Fri, Apr 12, 2013 at 03:40:12PM -0400, Jeff King wrote:
> On Fri, Apr 12, 2013 at 07:26:11PM +0200, Lukas Fleischer wrote:
> 
> > This allows for reusing the function in convert.c later.
> > 
> > Also, move it from attr.c to read-cache.c and add a use_index parameter
> > to specify a custom index_state since we are no longer enable to access
> > the static use_index variable from attr.c.
> 
> I'm all for removing duplicated code, but, but I think the name
> "read_index_data" is a bit misleading for a global function. I would
> expect it to read data from the index (and the argument "path" does not
> help clarify that at all).
> 
> Can we rename it read_blob_data_from_index_path() or something?

Pretty long function name... I agree that it is better to have a verbose
function name instead of something short that gives a wrong impression
of what the function does and I can't think of a shorter, yet
descriptive way to name the function.

If nobody comes up with an alternative suggestion, I will change it to
read_blob_data_from_index_path() and resubmit.

> 
> -Peff

  reply	other threads:[~2013-04-13  8:23 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-04-12 17:26 [PATCH 0/3] Remove ~25 lines of duplicate code Lukas Fleischer
2013-04-12 17:26 ` [PATCH 1/3] Make read_index_data() public Lukas Fleischer
2013-04-12 19:40   ` Jeff King
2013-04-13  8:23     ` Lukas Fleischer [this message]
2013-04-12 17:26 ` [PATCH 2/3] Add size parameter to read_index_data() Lukas Fleischer
2013-04-12 17:26 ` [PATCH 3/3] convert.c: Remove duplicate code Lukas Fleischer
2013-04-13 13:28 ` [PATCH v2 1/3] Add public function read_blob_data_from_index_path() Lukas Fleischer
2013-04-13 13:28   ` [PATCH v2 2/3] Add size parameter to read_blob_data_from_index_path() Lukas Fleischer
2013-04-13 13:28   ` [PATCH v2 3/3] convert.c: Remove duplicate code Lukas Fleischer
2013-04-14  5:49   ` [PATCH v2 1/3] Add public function read_blob_data_from_index_path() Junio C Hamano
2013-04-14  6:55     ` Junio C Hamano
2013-04-14 20:14     ` Lukas Fleischer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130413082317.GA31894@blizzard \
    --to=git@cryptocrack.de \
    --cc=git@vger.kernel.org \
    --cc=peff@peff.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.