From mboxrd@z Thu Jan 1 00:00:00 1970 From: mark.rutland@arm.com (Mark Rutland) Date: Fri, 17 Jan 2014 14:44:57 +0000 Subject: [PATCH] of: add function to count number of u32 elements in a property In-Reply-To: <3781679.27UF2dWtKL@phil> References: <27256277.YJ687suYy5@phil> <1669323.jqjZBfkRx4@phil> <20140116124527.GD19578@e106331-lin.cambridge.arm.com> <3781679.27UF2dWtKL@phil> Message-ID: <20140117144456.GG19578@e106331-lin.cambridge.arm.com> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org On Thu, Jan 16, 2014 at 06:04:42PM +0000, Heiko St?bner wrote: > The need to know the number of array elements in a property is > a common pattern. To prevent duplication of open-coded implementations > add a helper function that also centralises strict sanity checking > and DTB format details. > > Suggested-by: Mark Rutland > Signed-off-by: Heiko Stuebner > --- > Hi Mark, > did you mean it like this? I've tested it with the sram-reserve change and > it made the part of the determining the number elements a lot nicer :-) Yes! This looks pretty nice! :) > > drivers/of/base.c | 32 ++++++++++++++++++++++++++++++++ > include/linux/of.h | 8 ++++++++ > 2 files changed, 40 insertions(+) > > diff --git a/drivers/of/base.c b/drivers/of/base.c > index f807d0e..0f40ea5 100644 > --- a/drivers/of/base.c > +++ b/drivers/of/base.c > @@ -920,6 +920,38 @@ int of_property_read_u32_index(const struct device_node *np, > EXPORT_SYMBOL_GPL(of_property_read_u32_index); > > /** > + * of_property_count_u32_elems - Count the number of u32 values in a property > + * > + * @np: device node from which the property value is to be read. > + * @propname: name of the property to be searched. > + * > + * Search for a property in a device node and count the number of u32 elements > + * in it. Returns number of elements on sucess, -EINVAL if the property does > + * not exist or its length does not match a multiple of u32 and -ENODATA if the > + * property does not have a value. > + */ > +int of_property_count_u32_elems(const struct device_node *np, > + const char *propname) > +{ > + int elem_size = sizeof(u32); > + int len; > + struct property *prop = of_find_property(np, propname, &len); > + > + if (!prop) > + return -EINVAL; > + if (!prop->value) > + return -ENODATA; > + > + if (prop->length % elem_size != 0) { > + pr_err("size of %s is not a multiple of u32\n", propname); > + return -EINVAL; > + } > + > + return len / elem_size; > +} > +EXPORT_SYMBOL_GPL(of_property_count_u32_elems); As Rob said in his reply, it would be nice to split this into a static helper that took elem size as a parameter, so we can have the full suite of of_property_count_{u8,u16,u32,u64}_elems. Also, I think you can get rid of len and always use prop->length, as other helpers seem to do. Cheers for putting this together! Mark. From mboxrd@z Thu Jan 1 00:00:00 1970 From: Mark Rutland Subject: Re: [PATCH] of: add function to count number of u32 elements in a property Date: Fri, 17 Jan 2014 14:44:57 +0000 Message-ID: <20140117144456.GG19578@e106331-lin.cambridge.arm.com> References: <27256277.YJ687suYy5@phil> <1669323.jqjZBfkRx4@phil> <20140116124527.GD19578@e106331-lin.cambridge.arm.com> <3781679.27UF2dWtKL@phil> Mime-Version: 1.0 Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: base64 Return-path: Content-Disposition: inline In-Reply-To: <3781679.27UF2dWtKL@phil> Content-Language: en-US List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: "linux-arm-kernel" Errors-To: linux-arm-kernel-bounces+linux-arm-kernel=m.gmane.org@lists.infradead.org To: Heiko =?utf-8?Q?St=C3=BCbner?= Cc: "devicetree@vger.kernel.org" , Pawel Moll , Stephen Warren , Greg Kroah-Hartman , Ian Campbell , "linux-kernel@vger.kernel.org" , "arm@kernel.org" , Philipp Zabel , "grant.likely@linaro.org" , "linux-arm-kernel@lists.infradead.org" List-Id: devicetree@vger.kernel.org T24gVGh1LCBKYW4gMTYsIDIwMTQgYXQgMDY6MDQ6NDJQTSArMDAwMCwgSGVpa28gU3TDvGJuZXIg d3JvdGU6Cj4gVGhlIG5lZWQgdG8ga25vdyB0aGUgbnVtYmVyIG9mIGFycmF5IGVsZW1lbnRzIGlu IGEgcHJvcGVydHkgaXMKPiBhIGNvbW1vbiBwYXR0ZXJuLiBUbyBwcmV2ZW50IGR1cGxpY2F0aW9u IG9mIG9wZW4tY29kZWQgaW1wbGVtZW50YXRpb25zCj4gYWRkIGEgaGVscGVyIGZ1bmN0aW9uIHRo YXQgYWxzbyBjZW50cmFsaXNlcyBzdHJpY3Qgc2FuaXR5IGNoZWNraW5nCj4gYW5kIERUQiBmb3Jt YXQgZGV0YWlscy4KPiAKPiBTdWdnZXN0ZWQtYnk6IE1hcmsgUnV0bGFuZCA8bWFyay5ydXRsYW5k QGFybS5jb20+Cj4gU2lnbmVkLW9mZi1ieTogSGVpa28gU3R1ZWJuZXIgPGhlaWtvQHNudGVjaC5k ZT4KPiAtLS0KPiBIaSBNYXJrLAo+IGRpZCB5b3UgbWVhbiBpdCBsaWtlIHRoaXM/IEkndmUgdGVz dGVkIGl0IHdpdGggdGhlIHNyYW0tcmVzZXJ2ZSBjaGFuZ2UgYW5kCj4gaXQgbWFkZSB0aGUgcGFy dCBvZiB0aGUgZGV0ZXJtaW5pbmcgdGhlIG51bWJlciBlbGVtZW50cyBhIGxvdCBuaWNlciA6LSkK ClllcyEgVGhpcyBsb29rcyBwcmV0dHkgbmljZSEgOikKCj4gCj4gIGRyaXZlcnMvb2YvYmFzZS5j ICB8ICAgMzIgKysrKysrKysrKysrKysrKysrKysrKysrKysrKysrKysKPiAgaW5jbHVkZS9saW51 eC9vZi5oIHwgICAgOCArKysrKysrKwo+ICAyIGZpbGVzIGNoYW5nZWQsIDQwIGluc2VydGlvbnMo KykKPiAKPiBkaWZmIC0tZ2l0IGEvZHJpdmVycy9vZi9iYXNlLmMgYi9kcml2ZXJzL29mL2Jhc2Uu Ywo+IGluZGV4IGY4MDdkMGUuLjBmNDBlYTUgMTAwNjQ0Cj4gLS0tIGEvZHJpdmVycy9vZi9iYXNl LmMKPiArKysgYi9kcml2ZXJzL29mL2Jhc2UuYwo+IEBAIC05MjAsNiArOTIwLDM4IEBAIGludCBv Zl9wcm9wZXJ0eV9yZWFkX3UzMl9pbmRleChjb25zdCBzdHJ1Y3QgZGV2aWNlX25vZGUgKm5wLAo+ ICBFWFBPUlRfU1lNQk9MX0dQTChvZl9wcm9wZXJ0eV9yZWFkX3UzMl9pbmRleCk7Cj4gIAo+ICAv KioKPiArICogb2ZfcHJvcGVydHlfY291bnRfdTMyX2VsZW1zIC0gQ291bnQgdGhlIG51bWJlciBv ZiB1MzIgdmFsdWVzIGluIGEgcHJvcGVydHkKPiArICoKPiArICogQG5wOgkJZGV2aWNlIG5vZGUg ZnJvbSB3aGljaCB0aGUgcHJvcGVydHkgdmFsdWUgaXMgdG8gYmUgcmVhZC4KPiArICogQHByb3Bu YW1lOgluYW1lIG9mIHRoZSBwcm9wZXJ0eSB0byBiZSBzZWFyY2hlZC4KPiArICoKPiArICogU2Vh cmNoIGZvciBhIHByb3BlcnR5IGluIGEgZGV2aWNlIG5vZGUgYW5kIGNvdW50IHRoZSBudW1iZXIg b2YgdTMyIGVsZW1lbnRzCj4gKyAqIGluIGl0LiBSZXR1cm5zIG51bWJlciBvZiBlbGVtZW50cyBv biBzdWNlc3MsIC1FSU5WQUwgaWYgdGhlIHByb3BlcnR5IGRvZXMKPiArICogbm90IGV4aXN0IG9y IGl0cyBsZW5ndGggZG9lcyBub3QgbWF0Y2ggYSBtdWx0aXBsZSBvZiB1MzIgYW5kIC1FTk9EQVRB IGlmIHRoZQo+ICsgKiBwcm9wZXJ0eSBkb2VzIG5vdCBoYXZlIGEgdmFsdWUuCj4gKyAqLwo+ICtp bnQgb2ZfcHJvcGVydHlfY291bnRfdTMyX2VsZW1zKGNvbnN0IHN0cnVjdCBkZXZpY2Vfbm9kZSAq bnAsCj4gKwkJCQljb25zdCBjaGFyICpwcm9wbmFtZSkKPiArewo+ICsJaW50IGVsZW1fc2l6ZSA9 IHNpemVvZih1MzIpOwo+ICsJaW50IGxlbjsKPiArCXN0cnVjdCBwcm9wZXJ0eSAqcHJvcCA9IG9m X2ZpbmRfcHJvcGVydHkobnAsIHByb3BuYW1lLCAmbGVuKTsKPiArCj4gKwlpZiAoIXByb3ApCj4g KwkJcmV0dXJuIC1FSU5WQUw7Cj4gKwlpZiAoIXByb3AtPnZhbHVlKQo+ICsJCXJldHVybiAtRU5P REFUQTsKPiArCj4gKwlpZiAocHJvcC0+bGVuZ3RoICUgZWxlbV9zaXplICE9IDApIHsKPiArCQlw cl9lcnIoInNpemUgb2YgJXMgaXMgbm90IGEgbXVsdGlwbGUgb2YgdTMyXG4iLCBwcm9wbmFtZSk7 Cj4gKwkJcmV0dXJuIC1FSU5WQUw7Cj4gKwl9Cj4gKwo+ICsJcmV0dXJuIGxlbiAvIGVsZW1fc2l6 ZTsKPiArfQo+ICtFWFBPUlRfU1lNQk9MX0dQTChvZl9wcm9wZXJ0eV9jb3VudF91MzJfZWxlbXMp OwoKQXMgUm9iIHNhaWQgaW4gaGlzIHJlcGx5LCBpdCB3b3VsZCBiZSBuaWNlIHRvIHNwbGl0IHRo aXMgaW50byBhIHN0YXRpYwpoZWxwZXIgdGhhdCB0b29rIGVsZW0gc2l6ZSBhcyBhIHBhcmFtZXRl ciwgc28gd2UgY2FuIGhhdmUgdGhlIGZ1bGwgc3VpdGUKb2Ygb2ZfcHJvcGVydHlfY291bnRfe3U4 LHUxNix1MzIsdTY0fV9lbGVtcy4KCkFsc28sIEkgdGhpbmsgeW91IGNhbiBnZXQgcmlkIG9mIGxl biBhbmQgYWx3YXlzIHVzZSBwcm9wLT5sZW5ndGgsIGFzCm90aGVyIGhlbHBlcnMgc2VlbSB0byBk by4KCkNoZWVycyBmb3IgcHV0dGluZyB0aGlzIHRvZ2V0aGVyIQoKTWFyay4KCl9fX19fX19fX19f X19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fCmxpbnV4LWFybS1rZXJuZWwgbWFp bGluZyBsaXN0CmxpbnV4LWFybS1rZXJuZWxAbGlzdHMuaW5mcmFkZWFkLm9yZwpodHRwOi8vbGlz dHMuaW5mcmFkZWFkLm9yZy9tYWlsbWFuL2xpc3RpbmZvL2xpbnV4LWFybS1rZXJuZWwK From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752351AbaAQOph (ORCPT ); Fri, 17 Jan 2014 09:45:37 -0500 Received: from cam-admin0.cambridge.arm.com ([217.140.96.50]:33879 "EHLO cam-admin0.cambridge.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751094AbaAQOpf (ORCPT ); Fri, 17 Jan 2014 09:45:35 -0500 Date: Fri, 17 Jan 2014 14:44:57 +0000 From: Mark Rutland To: Heiko =?utf-8?Q?St=C3=BCbner?= Cc: "linux-arm-kernel@lists.infradead.org" , "arm@kernel.org" , "grant.likely@linaro.org" , Rob Herring , "devicetree@vger.kernel.org" , Philipp Zabel , "linux-kernel@vger.kernel.org" , Greg Kroah-Hartman , Pawel Moll , Stephen Warren , Ian Campbell Subject: Re: [PATCH] of: add function to count number of u32 elements in a property Message-ID: <20140117144456.GG19578@e106331-lin.cambridge.arm.com> References: <27256277.YJ687suYy5@phil> <1669323.jqjZBfkRx4@phil> <20140116124527.GD19578@e106331-lin.cambridge.arm.com> <3781679.27UF2dWtKL@phil> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: <3781679.27UF2dWtKL@phil> Thread-Topic: [PATCH] of: add function to count number of u32 elements in a property Accept-Language: en-GB, en-US Content-Language: en-US User-Agent: Mutt/1.5.20 (2009-06-14) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Jan 16, 2014 at 06:04:42PM +0000, Heiko Stübner wrote: > The need to know the number of array elements in a property is > a common pattern. To prevent duplication of open-coded implementations > add a helper function that also centralises strict sanity checking > and DTB format details. > > Suggested-by: Mark Rutland > Signed-off-by: Heiko Stuebner > --- > Hi Mark, > did you mean it like this? I've tested it with the sram-reserve change and > it made the part of the determining the number elements a lot nicer :-) Yes! This looks pretty nice! :) > > drivers/of/base.c | 32 ++++++++++++++++++++++++++++++++ > include/linux/of.h | 8 ++++++++ > 2 files changed, 40 insertions(+) > > diff --git a/drivers/of/base.c b/drivers/of/base.c > index f807d0e..0f40ea5 100644 > --- a/drivers/of/base.c > +++ b/drivers/of/base.c > @@ -920,6 +920,38 @@ int of_property_read_u32_index(const struct device_node *np, > EXPORT_SYMBOL_GPL(of_property_read_u32_index); > > /** > + * of_property_count_u32_elems - Count the number of u32 values in a property > + * > + * @np: device node from which the property value is to be read. > + * @propname: name of the property to be searched. > + * > + * Search for a property in a device node and count the number of u32 elements > + * in it. Returns number of elements on sucess, -EINVAL if the property does > + * not exist or its length does not match a multiple of u32 and -ENODATA if the > + * property does not have a value. > + */ > +int of_property_count_u32_elems(const struct device_node *np, > + const char *propname) > +{ > + int elem_size = sizeof(u32); > + int len; > + struct property *prop = of_find_property(np, propname, &len); > + > + if (!prop) > + return -EINVAL; > + if (!prop->value) > + return -ENODATA; > + > + if (prop->length % elem_size != 0) { > + pr_err("size of %s is not a multiple of u32\n", propname); > + return -EINVAL; > + } > + > + return len / elem_size; > +} > +EXPORT_SYMBOL_GPL(of_property_count_u32_elems); As Rob said in his reply, it would be nice to split this into a static helper that took elem size as a parameter, so we can have the full suite of of_property_count_{u8,u16,u32,u64}_elems. Also, I think you can get rid of len and always use prop->length, as other helpers seem to do. Cheers for putting this together! Mark.