From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jean-Francois Moine Subject: Re: [PATCH v3 2/5] ASoC: tda998x: add a codec driver for the TDA998x Date: Tue, 4 Feb 2014 19:59:21 +0100 Message-ID: <20140204195921.5ace6163@armhf> References: <20140204133014.GA22609@sirena.org.uk> <20140204181605.5b837a70@armhf> <20140204175410.GL22609@sirena.org.uk> Mime-Version: 1.0 Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: base64 Return-path: In-Reply-To: <20140204175410.GL22609@sirena.org.uk> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: dri-devel-bounces@lists.freedesktop.org Errors-To: dri-devel-bounces@lists.freedesktop.org To: Mark Brown Cc: alsa-devel@alsa-project.org, Russell King - ARM Linux , linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org, linux-arm-kernel@lists.infradead.org List-Id: alsa-devel@alsa-project.org T24gVHVlLCA0IEZlYiAyMDE0IDE3OjU0OjEwICswMDAwCk1hcmsgQnJvd24gPGJyb29uaWVAa2Vy bmVsLm9yZz4gd3JvdGU6Cgo+IE9uIFR1ZSwgRmViIDA0LCAyMDE0IGF0IDA2OjE2OjA1UE0gKzAx MDAsIEplYW4tRnJhbmNvaXMgTW9pbmUgd3JvdGU6Cj4gPiBNYXJrIEJyb3duIDxicm9vbmllQGtl cm5lbC5vcmc+IHdyb3RlOgo+IAo+ID4gPiA+ICsJLyogbG9hZCB0aGUgb3B0aW9uYWwgQ09ERUMg Ki8KPiA+ID4gPiArCW9mX3BsYXRmb3JtX3BvcHVsYXRlKG5wLCBOVUxMLCBOVUxMLCAmY2xpZW50 LT5kZXYpOwo+IAo+ID4gPiBXaHkgaXMgdGhpcyB1c2luZyBvZl9wbGF0Zm9ybV9wb3B1bGF0ZSgp PyAgVGhhdCdzIGEgdmVyeSBvZGQgd2F5IG9mCj4gPiA+IGRvaW5nIHRoaW5ncy4KPiAKPiA+IFRo ZSBpMmMgZG9lcyBub3QgcG9wdWxhdGUgdGhlIHN1Ym5vZGVzIGluIHRoZSBEVC4gSSBkaWQgbm90 IGZpbmQgd2h5LAo+ID4gYnV0LCB3aGF0IGlzIHN1cmUgaXMgdGhhdCBpZiBvZl9wbGF0Zm9ybV9w b3B1bGF0ZSgpIGlzIG5vdCBjYWxsZWQsIHRoZQo+ID4gdGRhIENPREVDIG1vZHVsZSBpcyBub3Qg bG9hZGVkLgo+IAo+IFlvdSBzaG91bGRuJ3QgYmUgcmVwcmVzZW50aW5nIHRoaXMgYXMgYSBzZXBh cmF0ZSBub2RlIGluIHRoZSBEVCB1bmxlc3MKPiB0aGVyZSByZWFsbHkgaXMgYSBkaXN0aW5jdCBh bmQgcmV1c2FibGUgSVAsIG90aGVyd2lzZSB5b3UncmUgcHV0dGluZwo+IExpbnV4IGltcGxlbWVu dGF0aW9uIGRldGFpbHMgaW4gdGhlcmUuICBEZXNjcmliZSB0aGUgaGFyZHdhcmUsIG5vdCB0aGUK PiBpbXBsZW1lbWVudGF0aW9uLgoKSWYgdGhlcmUgaXMgbm8gJ2NvbXBhdGlibGUnIG5vZGUgZm9y IHRoZSB0ZGE5OTh4IENPREVDIGluIHRoZSBEVCwgdGhlCnNpbXBsZS1jYXJkIGlzIG5vdCB1c2Fi bGUsIHNpbXBseSBiZWNhdXNlIHlvdSB3YW50IHRoZSBDT0RFQyBEQUlzIHRvIGJlCmRlZmluZWQg YnkgJ3BoYW5kbGUgKyBpbmRleCcgaW5zdGVhZCBvZiBieSBEQUkgbmFtZS4KCj4gPiBZb3UgbWF5 IGZpbmQgYW4gb3RoZXIgZXhhbXBsZSBpbiBkcml2ZXJzL21mZC90d2wtY29yZS5jLgo+IAo+IFRo ZSBUV0wgZHJpdmVycyBhcmVuJ3QgYWx3YXlzIGEgc2hpbmluZyBleGFtcGxlIG9mIGhvdyB0byBk byB0aGluZ3MgLQo+IHRoZXkgd2VyZSBvbmUgb2YgdGhlIGVhcmxpZXN0IE1GRHMgc28gdGhlcmUn cyB3YXJ0cyBpbiB0aGVyZS4KPiAKPiA+ID4gPiArY29uZmlnIFNORF9TT0NfVERBOTk4WAo+ID4g PiA+ICsJdHJpc3RhdGUKPiA+ID4gPiArCWRlcGVuZHMgb24gT0YKPiA+ID4gPiArCWRlZmF1bHQg eSBpZiBEUk1fSTJDX05YUF9UREE5OThYPXkKPiA+ID4gPiArCWRlZmF1bHQgbSBpZiBEUk1fSTJD X05YUF9UREE5OThYPW0KPiAKPiA+ID4gTWFrZSB0aGlzIHZpc2libGUgaWYgaXQgY2FuIGJlIHNl bGVjdGVkIGZyb20gRFQgc28gaXQgY2FuIGJlIHVzZWQgd2l0aAo+ID4gPiBnZW5lcmljIGNhcmRz Lgo+IAo+ID4gSSBkb24ndCB1bmRlcnN0YW5kLiBUaGUgdGRhIENPREVDIGNhbiBvbmx5IGJlIHVz ZWQgd2l0aCB0aGUgVERBOTk4eCBJMkMKPiA+IGRyaXZlci4gSXQgbWlnaHQgaGF2ZSBiZWVuIGlu Y2x1ZGVkIGluIHRoZSB0ZGE5OTh4IHNvdXJjZSBhcyB3ZWxsLgo+IAo+IFlvdSBzaG91bGRuJ3Qg aGF2ZSB0aGUgZGVmYXVsdCBzZXR0aW5ncyB0aGVyZSBhdCBhbGwsIHRoYXQncyBub3QgdGhlCj4g bm9ybWFsIGlkaW9tIGZvciBNRkRzLiAgSSdkIGFsc28gbm90IGV4cGVjdCB0byBoYXZlIHRvIGJ1 aWxkIHRoZSBDT0RFQwo+IGRyaXZlciBqdXN0IGJlY2F1c2UgSSBidWlsdCB0aGUgRFJNIGNvbXBv bmVudC4KCkFzIHRoZSB0ZGE5OTh4IGhhbmRsZXMgYXVkaW8gaW4gSERNSSwgaXQgd291bGQgYmUg YSBwaXR5IGlmIHlvdSBzaG91bGQKY29ubmVjdCBhbiBvdGhlciBjYWJsZSB0byB5b3VyIHNjcmVl bi4KCj4gPiBOb3csIHRoZSBDT0RFQyBpcyBkZWNsYXJlZCBpbnNpZGUgdGhlIHRkYTk5OHggYXMg YSBub2RlIGNoaWxkLiBCdXQsIGluCj4gPiBhIGJhZCBEVCwgdGhlIHRkYSBDT0RFQyBjb3VsZCBi ZSBkZWNsYXJlZCBhbnl3aGVyZSwgZXZlbiBpbnNpZGUgYSBvdGhlcgo+ID4gRFJNIEkyQyBzbGF2 ZSBlbmNvZGVyLCBpbiB3aGljaCBjYXNlLCBiYWQgdGhpbmdzIHdvdWxkIGhhcHBlbi4uLgo+IAo+ IFNvLCBwYXJ0IG9mIHRoZSBwcm9ibGVtIGhlcmUgaXMgdGhhdCB0aGlzIGlzIGJlaW5nIGV4cGxp Y2l0bHkgZGVjbGFyZWQKPiBpbiB0aGUgRFQgbGVhZGluZyB0byBtb3JlIHNvdXJjZXMgZm9yIGVy cm9yLgoKU2ltcGxlLWNhcmQgY29uc3RyYWludC4KCj4gPiA+IFdoYXQgZG9lcyB0aGlzIGFjdHVh bGx5IGRvPyAgTm8gaW5mb3JtYXRpb24gaXMgYmVpbmcgcGFzc2VkIGluIHRvIHRoZQo+ID4gPiBj b3JlIGZ1bmN0aW9uIGhlcmUsIG5vdCBldmVuIGFueSBpbmZvcm1hdGlvbiBvbiBpZiBpdCdzIHN0 YXJ0aW5nIG9yCj4gPiA+IHN0b3BwaW5nLiAgTG9va2luZyBhdCB0aGUgcmVzdCBvZiB0aGUgY29k ZSBJIGNhbid0IGhlbHAgdGhpbmtpbmcgaXQKPiA+ID4gbWlnaHQgYmUgY2xlYXJlciB0byBpbmxp bmUgdGhpcyBwb3NzaWJseSB3aXRoIGEgbG9va3VwIGhlbHBlciwgdGhlIGNvZGUKPiA+ID4gaXMg dmVyeSBzbWFsbCBhbmQgdGhlIGxhY2sgb2YgcGFyYW1ldGVycyBtYWtlcyBpdCBoYXJkIHRvIGZv bGxvdy4KPiAKPiA+IEkgdGhvdWdodCBpdCB3YXMgc2ltcGxlIGVub3VnaC4gVGhlIGZ1bmN0aW9u IHRkYV9zdGFydF9zdG9wKCkgaXMgY2FsbGVkCj4gPiBmcm9tIDIgcGxhY2VzOgo+IAo+IEl0J3Mg bm90IGF0IGFsbCBvYnZpb3VzIC0gX2F1ZGlvX3VwZGF0ZSgpIGlzbid0IGEgdGVycmlibHkgZGVz Y3JpcHRpdmUKPiBuYW1lLCBqdXN0IGxvb2tpbmcgYXQgdGhhdCBmdW5jdGlvbiBieSBpdHNlbGYg SSBoYWQgbm8gaWRlYSB3aGF0IGl0IHdhcwo+IHN1cHBvc2VkIHRvIGJlIGRvaW5nLgoKVGhlIGZp cnN0IHB1cnBvc2Ugb2YgdGhlIGZ1bmN0aW9uIGlzIHRvIHNldCB0aGUgYXVkaW8gaW5wdXQgcG9y dCBpbiB0aGUKdGRhOTk4eC4gU3RyZWFtaW5nIHN0b3AgY291bGQgaGF2ZSBiZWVuIG9taXR0ZWQs IGJ1dCBJIHRob3VnaHQgaXQgY291bGQKYmUgaW50ZXJlc3RpbmcgdG8gc3RvcCBIRE1JIGF1ZGlv IHdoZW4gdGhlcmUgaXMgYSBzdXBlciBIaUZpIGRldmljZQpjb25uZWN0ZWQgdG8gdGhlIFMvUERJ RiBjb25uZWN0b3IuCgo+ID4gLSBvbiBhdWRpbyBzdGFydCBpbiB0ZGFfc3RhcnR1cCB3aXRoIHRo ZSBhdWRpbyB0eXBlIChEQUkgaWQpCj4gPiAJcHJpdi0+ZGFpX2lkID0gZGFpLT5pZDsKPiAKPiA+ IC0gb24gYXVkaW8gc3RvcCB3aXRoIGEgbnVsbCBhdWRpbyB0eXBlCj4gPiAJcHJpdi0+ZGFpX2lk ID0gMDsJCS8qIHN0cmVhbWluZyBzdG9wICovCj4gCj4gPiBPbiBzdHJlYW0gc3RhcnQsIHRoZSBE QUkgaWQgaXMgbmV2ZXIgbnVsbCwgYXMgZXhwbGFpbmVkIGluIHRoZSBwYXRjaCAxOgo+IAo+ID4g CVRoZSBhdWRpbyBmb3JtYXQgdmFsdWVzIGluIHRoZSBlbmNvZGVyIGNvbmZpZ3VyYXRpb24gaW50 ZXJmYWNlICBhcmUKPiA+IAljaGFuZ2VkIHRvIG5vbiBudWxsIHZhbHVlcyBzbyB0aGF0IHRoZSB2 YWx1ZSAwIGlzIHVzZWQgaW4gdGhlIGF1ZGlvCj4gPiAJZnVuY3Rpb24gdG8gaW5kaWNhdGUgdGhh dCBhdWRpbyBzdHJlYW1pbmcgaXMgc3RvcHBlZC4KPiAKPiA+IGFuZCBvbiBzdHJlYW1pbmcgc3Rv cCB0aGUgcG9ydCBpcyBub3QgbWVhbmluZ2Z1bC4KPiAKPiA+IEkgd2lsbCBhZGQgYSBudWxsIGl0 ZW0gaW4gdGhlIGVudW0gKEFGTVRfTk9fQVVESU8pLgo+IAo+IFNvIHdlIGNhbid0IHVzZSBib3Ro IHN0cmVhbXMgc2ltdWx0YW5lb3VzbHkgdGhlbj8gIFRoYXQncyBhIGJpdCBzYWQuCgpUaGF0J3Mg aG93IHRoZSBOWFAgdGRhOTk4eCBmYW1pbHkgd29ya3MgKGFuZCBzdXJlbHkgbWFueSBvdGhlciBI RE1JCnRyYW5zbWl0dGVycykuCgpTbywgYXMgSSB1bmRlcnN0YW5kIGZyb20geW91ciByZW1hcmtz LCB0aGUgQ09ERUMgc2hvdWxkIGJlIGluY2x1ZGVkIGluCnRoZSB0ZGE5OTh4IGRyaXZlciwgYW5k LCB0aGVuLCBhcyB0aGUgc2ltcGxlLWNhcmQgY2Fubm90IGJlIHVzZWQsIHRoZXJlCnNob3VsZCBi ZSBhIEN1Ym94IHNwZWNpZmljIGF1ZGlvIGNhcmQgZHJpdmVyIGZvciB0aGUgKGtpcmt3b29kIGF1 ZGlvICsKdGRhOTk4eCBIRE1JICsgUy9QRElGKSBzZXQuIEFtIEkgcmlnaHQ/CgotLSAKS2VuIGFy IGMnaGVudGHDsQl8CSAgICAgICoqIEJyZWl6aCBoYSBMaW51eCBhdGF2ISAqKgpKZWYJCXwJCWh0 dHA6Ly9tb2luZWpmLmZyZWUuZnIvCl9fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19fX19f X19fX19fX19fX19fCmRyaS1kZXZlbCBtYWlsaW5nIGxpc3QKZHJpLWRldmVsQGxpc3RzLmZyZWVk ZXNrdG9wLm9yZwpodHRwOi8vbGlzdHMuZnJlZWRlc2t0b3Aub3JnL21haWxtYW4vbGlzdGluZm8v ZHJpLWRldmVsCg== From mboxrd@z Thu Jan 1 00:00:00 1970 From: moinejf@free.fr (Jean-Francois Moine) Date: Tue, 4 Feb 2014 19:59:21 +0100 Subject: [PATCH v3 2/5] ASoC: tda998x: add a codec driver for the TDA998x In-Reply-To: <20140204175410.GL22609@sirena.org.uk> References: <20140204133014.GA22609@sirena.org.uk> <20140204181605.5b837a70@armhf> <20140204175410.GL22609@sirena.org.uk> Message-ID: <20140204195921.5ace6163@armhf> To: linux-arm-kernel@lists.infradead.org List-Id: linux-arm-kernel.lists.infradead.org On Tue, 4 Feb 2014 17:54:10 +0000 Mark Brown wrote: > On Tue, Feb 04, 2014 at 06:16:05PM +0100, Jean-Francois Moine wrote: > > Mark Brown wrote: > > > > > + /* load the optional CODEC */ > > > > + of_platform_populate(np, NULL, NULL, &client->dev); > > > > Why is this using of_platform_populate()? That's a very odd way of > > > doing things. > > > The i2c does not populate the subnodes in the DT. I did not find why, > > but, what is sure is that if of_platform_populate() is not called, the > > tda CODEC module is not loaded. > > You shouldn't be representing this as a separate node in the DT unless > there really is a distinct and reusable IP, otherwise you're putting > Linux implementation details in there. Describe the hardware, not the > implemementation. If there is no 'compatible' node for the tda998x CODEC in the DT, the simple-card is not usable, simply because you want the CODEC DAIs to be defined by 'phandle + index' instead of by DAI name. > > You may find an other example in drivers/mfd/twl-core.c. > > The TWL drivers aren't always a shining example of how to do things - > they were one of the earliest MFDs so there's warts in there. > > > > > +config SND_SOC_TDA998X > > > > + tristate > > > > + depends on OF > > > > + default y if DRM_I2C_NXP_TDA998X=y > > > > + default m if DRM_I2C_NXP_TDA998X=m > > > > Make this visible if it can be selected from DT so it can be used with > > > generic cards. > > > I don't understand. The tda CODEC can only be used with the TDA998x I2C > > driver. It might have been included in the tda998x source as well. > > You shouldn't have the default settings there at all, that's not the > normal idiom for MFDs. I'd also not expect to have to build the CODEC > driver just because I built the DRM component. As the tda998x handles audio in HDMI, it would be a pity if you should connect an other cable to your screen. > > Now, the CODEC is declared inside the tda998x as a node child. But, in > > a bad DT, the tda CODEC could be declared anywhere, even inside a other > > DRM I2C slave encoder, in which case, bad things would happen... > > So, part of the problem here is that this is being explicitly declared > in the DT leading to more sources for error. Simple-card constraint. > > > What does this actually do? No information is being passed in to the > > > core function here, not even any information on if it's starting or > > > stopping. Looking at the rest of the code I can't help thinking it > > > might be clearer to inline this possibly with a lookup helper, the code > > > is very small and the lack of parameters makes it hard to follow. > > > I thought it was simple enough. The function tda_start_stop() is called > > from 2 places: > > It's not at all obvious - _audio_update() isn't a terribly descriptive > name, just looking at that function by itself I had no idea what it was > supposed to be doing. The first purpose of the function is to set the audio input port in the tda998x. Streaming stop could have been omitted, but I thought it could be interesting to stop HDMI audio when there is a super HiFi device connected to the S/PDIF connector. > > - on audio start in tda_startup with the audio type (DAI id) > > priv->dai_id = dai->id; > > > - on audio stop with a null audio type > > priv->dai_id = 0; /* streaming stop */ > > > On stream start, the DAI id is never null, as explained in the patch 1: > > > The audio format values in the encoder configuration interface are > > changed to non null values so that the value 0 is used in the audio > > function to indicate that audio streaming is stopped. > > > and on streaming stop the port is not meaningful. > > > I will add a null item in the enum (AFMT_NO_AUDIO). > > So we can't use both streams simultaneously then? That's a bit sad. That's how the NXP tda998x family works (and surely many other HDMI transmitters). So, as I understand from your remarks, the CODEC should be included in the tda998x driver, and, then, as the simple-card cannot be used, there should be a Cubox specific audio card driver for the (kirkwood audio + tda998x HDMI + S/PDIF) set. Am I right? -- Ken ar c'henta? | ** Breizh ha Linux atav! ** Jef | http://moinejf.free.fr/ From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755023AbaBDS7U (ORCPT ); Tue, 4 Feb 2014 13:59:20 -0500 Received: from smtpfb1-g21.free.fr ([212.27.42.9]:40548 "EHLO smtpfb1-g21.free.fr" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751357AbaBDS7R convert rfc822-to-8bit (ORCPT ); Tue, 4 Feb 2014 13:59:17 -0500 Date: Tue, 4 Feb 2014 19:59:21 +0100 From: Jean-Francois Moine To: Mark Brown Cc: alsa-devel@alsa-project.org, Dave Airlie , dri-devel@lists.freedesktop.org, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, Rob Clark , Russell King - ARM Linux Subject: Re: [PATCH v3 2/5] ASoC: tda998x: add a codec driver for the TDA998x Message-ID: <20140204195921.5ace6163@armhf> In-Reply-To: <20140204175410.GL22609@sirena.org.uk> References: <20140204133014.GA22609@sirena.org.uk> <20140204181605.5b837a70@armhf> <20140204175410.GL22609@sirena.org.uk> X-Mailer: Claws Mail 3.9.3 (GTK+ 2.24.22; arm-unknown-linux-gnueabihf) MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8BIT Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 4 Feb 2014 17:54:10 +0000 Mark Brown wrote: > On Tue, Feb 04, 2014 at 06:16:05PM +0100, Jean-Francois Moine wrote: > > Mark Brown wrote: > > > > > + /* load the optional CODEC */ > > > > + of_platform_populate(np, NULL, NULL, &client->dev); > > > > Why is this using of_platform_populate()? That's a very odd way of > > > doing things. > > > The i2c does not populate the subnodes in the DT. I did not find why, > > but, what is sure is that if of_platform_populate() is not called, the > > tda CODEC module is not loaded. > > You shouldn't be representing this as a separate node in the DT unless > there really is a distinct and reusable IP, otherwise you're putting > Linux implementation details in there. Describe the hardware, not the > implemementation. If there is no 'compatible' node for the tda998x CODEC in the DT, the simple-card is not usable, simply because you want the CODEC DAIs to be defined by 'phandle + index' instead of by DAI name. > > You may find an other example in drivers/mfd/twl-core.c. > > The TWL drivers aren't always a shining example of how to do things - > they were one of the earliest MFDs so there's warts in there. > > > > > +config SND_SOC_TDA998X > > > > + tristate > > > > + depends on OF > > > > + default y if DRM_I2C_NXP_TDA998X=y > > > > + default m if DRM_I2C_NXP_TDA998X=m > > > > Make this visible if it can be selected from DT so it can be used with > > > generic cards. > > > I don't understand. The tda CODEC can only be used with the TDA998x I2C > > driver. It might have been included in the tda998x source as well. > > You shouldn't have the default settings there at all, that's not the > normal idiom for MFDs. I'd also not expect to have to build the CODEC > driver just because I built the DRM component. As the tda998x handles audio in HDMI, it would be a pity if you should connect an other cable to your screen. > > Now, the CODEC is declared inside the tda998x as a node child. But, in > > a bad DT, the tda CODEC could be declared anywhere, even inside a other > > DRM I2C slave encoder, in which case, bad things would happen... > > So, part of the problem here is that this is being explicitly declared > in the DT leading to more sources for error. Simple-card constraint. > > > What does this actually do? No information is being passed in to the > > > core function here, not even any information on if it's starting or > > > stopping. Looking at the rest of the code I can't help thinking it > > > might be clearer to inline this possibly with a lookup helper, the code > > > is very small and the lack of parameters makes it hard to follow. > > > I thought it was simple enough. The function tda_start_stop() is called > > from 2 places: > > It's not at all obvious - _audio_update() isn't a terribly descriptive > name, just looking at that function by itself I had no idea what it was > supposed to be doing. The first purpose of the function is to set the audio input port in the tda998x. Streaming stop could have been omitted, but I thought it could be interesting to stop HDMI audio when there is a super HiFi device connected to the S/PDIF connector. > > - on audio start in tda_startup with the audio type (DAI id) > > priv->dai_id = dai->id; > > > - on audio stop with a null audio type > > priv->dai_id = 0; /* streaming stop */ > > > On stream start, the DAI id is never null, as explained in the patch 1: > > > The audio format values in the encoder configuration interface are > > changed to non null values so that the value 0 is used in the audio > > function to indicate that audio streaming is stopped. > > > and on streaming stop the port is not meaningful. > > > I will add a null item in the enum (AFMT_NO_AUDIO). > > So we can't use both streams simultaneously then? That's a bit sad. That's how the NXP tda998x family works (and surely many other HDMI transmitters). So, as I understand from your remarks, the CODEC should be included in the tda998x driver, and, then, as the simple-card cannot be used, there should be a Cubox specific audio card driver for the (kirkwood audio + tda998x HDMI + S/PDIF) set. Am I right? -- Ken ar c'hentaƱ | ** Breizh ha Linux atav! ** Jef | http://moinejf.free.fr/