From mboxrd@z Thu Jan 1 00:00:00 1970 From: Tom Rini Date: Wed, 5 Feb 2014 08:03:47 -0500 Subject: [U-Boot] [PATCH v2 6/8] cmd_mmc.c: Add 'partconf' command to mmc In-Reply-To: <52F03B1E.9060601@samsung.com> References: <1391117520-21868-1-git-send-email-trini@ti.com> <1391117520-21868-6-git-send-email-trini@ti.com> <52F03B1E.9060601@samsung.com> Message-ID: <20140205130347.GC7049@bill-the-cat> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de On Tue, Feb 04, 2014 at 09:58:06AM +0900, Jaehoon Chung wrote: > On 01/31/2014 06:31 AM, Tom Rini wrote: > > Add a partconf sub-command to the mmc command to allow for setting > > the boot_ack, boot_partition and partition_access fields of > > PARTITION_CONFIG (formerly BOOT_CONFIG, EXT_CSD[179]). Part of this > > requires changing the check for 'part' from an strncmp to a strcmp, like > > the rest of the sub-commands. [snip] > > @@ -451,6 +477,8 @@ U_BOOT_CMD( > > " - Enable boot_part for booting and disable access to boot_part\n" > > "mmc bootpart-resize \n" > > " - Change sizes of boot and RPMB partitions of specified device\n" > > + "mmc partconf dev boot_ack boot_partition partition_access\n" > > How about using bracket("< >") for more readable? > mmc partconf Except for bootpart-resize the rest of the mmc commands (and most in general) don't use "< >" around required parameters unless it's part of some sub-choices (such as spl export ...). > Anyway, looks good to me. Thanks! -- Tom -------------- next part -------------- A non-text attachment was scrubbed... Name: not available Type: application/pgp-signature Size: 836 bytes Desc: Digital signature URL: