From: Ezequiel Garcia <ezequiel.garcia@free-electrons.com>
To: Artem Bityutskiy <dedekind1@gmail.com>
Cc: Richard Weinberger <richard@nod.at>, linux-mtd@lists.infradead.org
Subject: Re: [PATCH] ubiblock: Support UBI volume name or volume ID parameter passing
Date: Mon, 14 Apr 2014 15:45:51 -0300 [thread overview]
Message-ID: <20140414184551.GC23722@arch.cereza> (raw)
In-Reply-To: <1397472124.3287.6.camel@karhu>
On Apr 14, Artem Bityutskiy wrote:
> On Thu, 2014-04-10 at 11:43 -0300, Ezequiel Garcia wrote:
> > +static int ubi_open_volume_by_id(libubi_t desc, const char *node, int vol_id, int mode)
> > {
> > + char file[256];
> > + struct ubi_dev_info dev_info;
> > int err, fd;
> > - libubi_t libubi;
> >
> > - err = parse_opt(argc, argv);
> > + err = ubi_get_dev_info(desc, node, &dev_info);
> > if (err)
> > + return errmsg("cannot get information about UBI device \"%s\"", node);
> > +
> > + sprintf(file, "/dev/ubi%d_%d", dev_info.dev_num, vol_id);
>
> Device node names may ve anything. Please, do not rely on the "/dev/ubi%
> d_%d" naming scheme in the tool.
>
Yeah, I know this sucks.
> I think device node can be found out by scanning "/dev" and looking at
> the device node major/minor numbers. This is more work of course.
>
Ah, that's a good idea. Let me give it a try.
> However, libubi does exactly the same assumption about UBI volume names
> as you do, so if you move this function to libubi, I think it will be
> good enough. At least if someone wants to change this in the future,
> then it will only require changing the library, but not its users.
>
OK, I will.
--
Ezequiel García, Free Electrons
Embedded Linux, Kernel and Android Engineering
http://free-electrons.com
next prev parent reply other threads:[~2014-04-14 18:46 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-04-10 14:43 [PATCH] ubiblock: Support UBI volume name or volume ID parameter passing Ezequiel Garcia
2014-04-14 10:42 ` Artem Bityutskiy
2014-04-14 18:45 ` Ezequiel Garcia [this message]
2014-07-21 20:53 ` Ezequiel Garcia
2014-07-28 16:31 ` Artem Bityutskiy
2014-07-30 14:22 ` Ezequiel Garcia
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140414184551.GC23722@arch.cereza \
--to=ezequiel.garcia@free-electrons.com \
--cc=dedekind1@gmail.com \
--cc=linux-mtd@lists.infradead.org \
--cc=richard@nod.at \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.