All of lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel@ffwll.ch>
To: Chris Wilson <chris@chris-wilson.co.uk>,
	Daniel Vetter <daniel@ffwll.ch>,
	Damien Lespiau <damien.lespiau@intel.com>,
	intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH v2] igt/gem_workarounds: rework igt to test workaround registers
Date: Tue, 2 Sep 2014 15:22:28 +0200	[thread overview]
Message-ID: <20140902132228.GA15520@phenom.ffwll.local> (raw)
In-Reply-To: <20140902111228.GD25238@nuc-i3427.alporthouse.com>

On Tue, Sep 02, 2014 at 12:12:28PM +0100, Chris Wilson wrote:
> On Tue, Sep 02, 2014 at 01:04:34PM +0200, Daniel Vetter wrote:
> > On Tue, Sep 02, 2014 at 10:59:06AM +0100, Damien Lespiau wrote:
> > > On Tue, Sep 02, 2014 at 10:18:20AM +0100, Arun Siluvery wrote:
> > > > -		igt_assert(fd >= 0);
> > > > +		if (fd < 0)
> > > > +			igt_skip_on("No Workaround table available !!\n");
> > > 
> > > That's not quite a correct use of the API. The _on is there to signal
> > > the first argument is an expression. This will work only because the
> > > string is evaluated to true. You probably want to use igt_skip_on_f()
> > > 
> > > http://people.freedesktop.org/~danvet/igt/intel-gpu-tools-i-g-t-core.html#igt-skip-on-f
> > 
> > Or just igt_skip_on - we dump the expression that was tested, which should
> > be fairly informational. At least when fd would have a better name ;-)
> 
> Use igt_require(), it produces more natural phrasing in usage and
> output.

Yeah, for new code I second this - we have too many macros ;-) But my
practice has been to use igt_skip_on when changing existing code since I
seem to be too incompetent to reliably invert boolean conditions ...

Cheers, Daniel
-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch

      reply	other threads:[~2014-09-02 13:22 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-09-01 13:29 [PATCH 0/2] Rework workaround igt Arun Siluvery
2014-09-01 13:29 ` [PATCH 1/2] gem_workarounds: intel_wa_registers is now prefixed with i915 Arun Siluvery
2014-09-01 13:29 ` [PATCH 2/2] igt/gem_workarounds: rework igt to test workaround registers Arun Siluvery
2014-09-01 14:12   ` Damien Lespiau
2014-09-02  9:18   ` [PATCH v2] " Arun Siluvery
2014-09-02  9:59     ` Damien Lespiau
2014-09-02 11:04       ` Daniel Vetter
2014-09-02 11:12         ` Chris Wilson
2014-09-02 13:22           ` Daniel Vetter [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140902132228.GA15520@phenom.ffwll.local \
    --to=daniel@ffwll.ch \
    --cc=chris@chris-wilson.co.uk \
    --cc=damien.lespiau@intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.