From: Thomas Huth <thuth@redhat.com>
To: Markus Armbruster <armbru@redhat.com>
Cc: Jason Wang <jasowang@redhat.com>,
qemu-devel@nongnu.org, Stefan Hajnoczi <stefanha@redhat.com>
Subject: Re: [Qemu-devel] [PATCH 1/5] net/dump: Add support for receive_iov function
Date: Fri, 10 Jul 2015 20:09:54 +0200 [thread overview]
Message-ID: <20150710200954.7349f5a3@thh440s> (raw)
In-Reply-To: <87y4ixbiuo.fsf@blackfin.pond.sub.org>
On Fri, 03 Jul 2015 13:06:55 +0200
Markus Armbruster <armbru@redhat.com> wrote:
> Thomas Huth <thuth@redhat.com> writes:
>
> > Adding a proper receive_iov function to the net dump module. This
> > will make it easier to support the dump feature for the -netdev
> > option in later patches.
> > Also make the receive functions available to the other parts of the
> > source code so we can later use them for dumping from net.c, too.
> >
> > Signed-off-by: Thomas Huth <thuth@redhat.com>
> > ---
> > net/clients.h | 3 +++
> > net/dump.c | 48 ++++++++++++++++++++++++++++++++++++++++--------
> > 2 files changed, 43 insertions(+), 8 deletions(-)
> >
> > diff --git a/net/clients.h b/net/clients.h
> > index d47530e..5092f3d 100644
> > --- a/net/clients.h
> > +++ b/net/clients.h
> > @@ -29,6 +29,9 @@
> >
> > int net_init_dump(const NetClientOptions *opts, const char *name,
> > NetClientState *peer, Error **errp);
> > +ssize_t net_dump_receive(NetClientState *nc, const uint8_t *buf, size_t size);
> > +ssize_t net_dump_receive_iov(NetClientState *nc, const struct iovec *iov,
> > + int cnt);
> >
> > #ifdef CONFIG_SLIRP
> > int net_init_slirp(const NetClientOptions *opts, const char *name,
> > diff --git a/net/dump.c b/net/dump.c
> > index 02c8064..383718a 100644
> > --- a/net/dump.c
> > +++ b/net/dump.c
> > @@ -57,27 +57,49 @@ struct pcap_sf_pkthdr {
> > uint32_t len;
> > };
> >
> > -static ssize_t dump_receive(NetClientState *nc, const uint8_t *buf, size_t size)
> > +ssize_t net_dump_receive_iov(NetClientState *nc, const struct iovec *iov,
> > + int cnt)
> > {
> > DumpState *s = DO_UPCAST(DumpState, nc, nc);
> > struct pcap_sf_pkthdr hdr;
> > int64_t ts;
> > - int caplen;
> > + int caplen, i;
> > + size_t size = 0;
> > + struct iovec dumpiov[cnt + 1];
>
> Variable length array. Ignorant question: okay to use VLAs in QEMU?
I guess so - at least there are already some other spots that use VLAs,
e.g. in tap_receive_iov()
> >
> > /* Early return in case of previous error. */
> > if (s->fd < 0) {
> > return size;
>
> Before your patch: return the size argument.
>
> Afterwards: return zero. Sure that's what you want?
That was of course a stupid bug. Thanks for pointing it out, it will be
fixed in v2!
> > }
> >
> > + dumpiov[0].iov_base = &hdr;
> > + dumpiov[0].iov_len = sizeof(hdr);
> > + caplen = s->pcap_caplen;
> > +
> > + /* Copy iov, limit maximum size to caplen, and count total input size */
> > + for (i = 0; i < cnt; i++) {
> > + dumpiov[i + 1].iov_base = iov[i].iov_base;
> > + if (size + iov[i].iov_len <= caplen) {
> > + dumpiov[i + 1].iov_len = iov[i].iov_len;
> > + } else if (size < caplen) {
> > + dumpiov[i + 1].iov_len = caplen - size;
> > + } else {
> > + dumpiov[i + 1].iov_len = 0;
>
> When you hit caplen before the last iovec, this produces trailing
> iovec[] with zero iov_len instead of shortening the array. Okay.
I'll use iov_copy in the next version, as suggested by Jason - and that
returns the shortened count if necessary.
> > + }
> > + size += iov[i].iov_len;
> > + }
> > +
> > ts = muldiv64(qemu_clock_get_ns(QEMU_CLOCK_VIRTUAL), 1000000, get_ticks_per_sec());
> > - caplen = size > s->pcap_caplen ? s->pcap_caplen : size;
> > + if (size < caplen) {
> > + caplen = size;
> > + }
> >
> > hdr.ts.tv_sec = ts / 1000000 + s->start_ts;
> > hdr.ts.tv_usec = ts % 1000000;
> > hdr.caplen = caplen;
> > hdr.len = size;
> > - if (write(s->fd, &hdr, sizeof(hdr)) != sizeof(hdr) ||
> > - write(s->fd, buf, caplen) != caplen) {
> > +
> > + if (writev(s->fd, dumpiov, cnt + 1) != sizeof(hdr) + caplen) {
>
> Bonus: saves a system call :)
>
> > qemu_log("-net dump write error - stop dump\n");
> > close(s->fd);
> > s->fd = -1;
> > @@ -86,7 +108,16 @@ static ssize_t dump_receive(NetClientState *nc, const uint8_t *buf, size_t size)
> > return size;
> > }
> >
> > -static void dump_cleanup(NetClientState *nc)
> > +ssize_t net_dump_receive(NetClientState *nc, const uint8_t *buf, size_t size)
> > +{
> > + struct iovec iov = {
> > + .iov_base = (void *)buf,
> > + .iov_len = size
> > + };
> > + return net_dump_receive_iov(nc, &iov, 1);
> > +}
> > +
> > +static void net_dump_cleanup(NetClientState *nc)
> > {
> > DumpState *s = DO_UPCAST(DumpState, nc, nc);
> >
> > @@ -96,8 +127,9 @@ static void dump_cleanup(NetClientState *nc)
> > static NetClientInfo net_dump_info = {
> > .type = NET_CLIENT_OPTIONS_KIND_DUMP,
> > .size = sizeof(DumpState),
> > - .receive = dump_receive,
> > - .cleanup = dump_cleanup,
> > + .receive = net_dump_receive,
> > + .receive_iov = net_dump_receive_iov,
> > + .cleanup = net_dump_cleanup,
> > };
> >
> > static int net_dump_init(NetClientState *peer, const char *device,
>
> Any particular reason to rename dump_cleanup()? Not that I mind...
It's more consistent ... and in v2 I'll also need this function
exported (to make sure that the fd gets closed for -netdev, too), so I
then should rename it anyway.
Thomas
next prev parent reply other threads:[~2015-07-10 18:10 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-06-24 15:56 [Qemu-devel] [PATCH 0/5] Network traffic dumping for -netdev, second try Thomas Huth
2015-06-24 15:56 ` [Qemu-devel] [PATCH 1/5] net/dump: Add support for receive_iov function Thomas Huth
2015-06-26 6:38 ` Jason Wang
2015-06-26 7:06 ` Thomas Huth
2015-07-03 11:06 ` Markus Armbruster
2015-07-10 18:09 ` Thomas Huth [this message]
2015-06-24 15:56 ` [Qemu-devel] [PATCH 2/5] net/dump: Move DumpState into NetClientState Thomas Huth
2015-06-24 15:56 ` [Qemu-devel] [PATCH 3/5] net/dump: Rework net-dump init functions Thomas Huth
2015-07-03 11:19 ` Markus Armbruster
2015-06-24 15:56 ` [Qemu-devel] [PATCH 4/5] net/dump: Add dump option for netdev devices Thomas Huth
2015-06-26 6:50 ` Jason Wang
2015-06-26 9:44 ` Stefan Hajnoczi
2015-06-29 9:57 ` Thomas Huth
2015-06-30 15:12 ` Stefan Hajnoczi
2015-06-30 10:37 ` Thomas Huth
2015-07-01 8:36 ` Stefan Hajnoczi
2015-07-03 11:28 ` Markus Armbruster
2015-07-10 18:27 ` Thomas Huth
2015-06-24 15:56 ` [Qemu-devel] [PATCH 5/5] qemu options: Add information about dumpfile to help text Thomas Huth
2015-07-03 11:30 ` Markus Armbruster
2015-06-26 9:41 ` [Qemu-devel] [PATCH 0/5] Network traffic dumping for -netdev, second try Stefan Hajnoczi
2015-07-03 11:30 ` Markus Armbruster
-- strict thread matches above, loose matches on Subject: below --
2015-09-24 7:22 [Qemu-devel] [PATCH 0/5] Network traffic dumping via netfilter Thomas Huth
2015-09-24 7:22 ` [Qemu-devel] [PATCH 1/5] net/dump: Add support for receive_iov function Thomas Huth
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150710200954.7349f5a3@thh440s \
--to=thuth@redhat.com \
--cc=armbru@redhat.com \
--cc=jasowang@redhat.com \
--cc=qemu-devel@nongnu.org \
--cc=stefanha@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.