All of lore.kernel.org
 help / color / mirror / Atom feed
From: Tom Rini <trini@konsulko.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [U-Boot, v2, 2/8] spl: Add a name to the SPL load-image methods
Date: Mon, 12 Dec 2016 08:36:35 -0500	[thread overview]
Message-ID: <20161212133635.GR4248@bill-the-cat> (raw)
In-Reply-To: <1480545056-17704-3-git-send-email-sjg@chromium.org>

On Wed, Nov 30, 2016 at 03:30:50PM -0700, Simon Glass wrote:

> It is useful to name each method so that we can print out this name when
> using the method. Currently this happens using a separate function. In
> preparation for unifying this, add a name to each method.
> 
> The name is only available if we have libcommon support (i.e can use
> printf()).
> 
> Signed-off-by: Simon Glass <sjg@chromium.org>

Applied to u-boot/master, thanks!

-- 
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: Digital signature
URL: <http://lists.denx.de/pipermail/u-boot/attachments/20161212/dc407e8d/attachment.sig>

  reply	other threads:[~2016-12-12 13:36 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-11-30 22:30 [U-Boot] [PATCH v2 1/8] spl: Use a single underscore in the SPL_LOAD_IMAGE_METHOD() macro Simon Glass
2016-11-30 22:30 ` [U-Boot] [PATCH v2 2/8] spl: Add a name to the SPL load-image methods Simon Glass
2016-12-12 13:36   ` Tom Rini [this message]
2016-11-30 22:30 ` [U-Boot] [PATCH v2 3/8] spl: Move the loading code into its own function Simon Glass
2016-12-12 13:37   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 4/8] spl: Pass the loader into spl_load_image() Simon Glass
2016-12-12 13:39   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 5/8] spl: Drop announce_boot_device() Simon Glass
2016-12-12 13:40   ` [U-Boot] [U-Boot,v2,5/8] " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 6/8] spl: sunxi: Drop spl_board_announce_boot_device() Simon Glass
2016-12-12 13:40   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 7/8] spl: uniphier: " Simon Glass
2016-12-12 13:41   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 8/8] spl: sandbox: " Simon Glass
2016-12-12 13:41   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-12-12 13:36 ` [U-Boot] [U-Boot, v2, 1/8] spl: Use a single underscore in the SPL_LOAD_IMAGE_METHOD() macro Tom Rini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20161212133635.GR4248@bill-the-cat \
    --to=trini@konsulko.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.