All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sami Kerola <kerolasa@iki.fi>
To: util-linux@vger.kernel.org
Cc: Sami Kerola <kerolasa@iki.fi>
Subject: pull: hwclock 27 changes
Date: Sat, 31 Dec 2016 21:41:07 +0000	[thread overview]
Message-ID: <20161231214107.8658-1-kerolasa@iki.fi> (raw)

Good New Year,

Most of the changes in this pull request has been lying in my git repo for
few months, and now when 2016 is coming to an end I had a look what
unsubmitted work there is.  After reviewing my changes, and improving some
of them modestly, these are now ready for review.

----------------------------------------------------------------

The following changes since commit 963f7dfb82d44661d76c6fb61fda309b846726ce:

  Merge branch 'getrandom' of git://github.com/kerolasa/lelux-utiliteetit (2016-12-22 15:27:25 +0100)

are available in the git repository at:

  git://github.com/kerolasa/lelux-utiliteetit.git hwclock

for you to fetch changes up to c7a8f56920c738a90038cd6baaaec676c642b926:

  hwclock: remove trailing dot from messages that include system error message (2016-12-31 21:29:27 +0000)

----------------------------------------------------------------
Sami Kerola (27):
      hwclock: remove UTC-0 localization hack
      lib: add timegm() portability function to lib/timeutils.c
      hwclock: remove FLOOR macro
      hwclock: remove hwclock_exit() indirection
      hwclock: do not hardcode date command magic string twice
      hwclock: remove unnecessary type casts
      hwclock: move command-line options to control structure
      hwclock: clarify set_cmos_epoch() code
      hwclock: move error messages to determine_clock_access_method()
      docs: add instructions how to avoid alpha epoc Y2020 bug
      hwclock: remove dead code and other minor fixes
      hwclock: simplify save_adjtime() execution flow
      hwclock: alloate date_resp parsing buffer in interpret_date_string()
      hwclock: initialize struct adjtime members
      hwclock: use symbolic magic values passed in between functions
      hwclock: remove magic constants from interpret_date_string()
      hwclock: add debugging to open_rtc()
      hwclock: remove division by zero [asan]
      hwclock: use integer arithmetics in compare_clock()
      docs: deprecate hwclock --compare option
      hwclock: improve coding style
      hwclock: stream line synchronize_to_clock_tick_rtc()
      hwclock: try RTCGET and RTCSET only when normal rtc fails
      hwclock: clarify cmos inb and outb preprocessor directives
      hwclock: fix rtc atexit registration
      hwclock: make --date=argument less prone to injection
      hwclock: remove trailing dot from messages that include system error message

 configure.ac             |   1 +
 include/pathnames.h      |   4 +
 include/timeutils.h      |   4 +
 lib/timeutils.c          |  19 ++
 login-utils/utmpdump.c   |   1 +
 sys-utils/hwclock-cmos.c | 228 +++++++------
 sys-utils/hwclock-rtc.c  | 221 ++++++------
 sys-utils/hwclock.8.in   |  11 +
 sys-utils/hwclock.c      | 874 +++++++++++++++++++++--------------------------
 sys-utils/hwclock.h      |  71 +++-
 10 files changed, 702 insertions(+), 732 deletions(-)

             reply	other threads:[~2016-12-31 21:41 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-12-31 21:41 Sami Kerola [this message]
2017-01-03 14:34 ` pull: hwclock 27 changes J William Piggott
     [not found] ` <05e4405f-8096-9261-f9f2-d2c6b84675bc@gmx.com>
2017-01-07 19:37   ` J William Piggott
2017-01-07 20:32     ` J William Piggott
2017-01-07 23:06     ` Sami Kerola
2017-01-08  9:39       ` Sami Kerola
2017-01-08 21:21         ` J William Piggott
2017-01-08 10:09       ` Sami Kerola
2017-01-08 21:21         ` J William Piggott
2017-01-08 21:21       ` J William Piggott
2017-01-11 21:44         ` Sami Kerola
2017-01-13  1:30           ` J William Piggott
2017-01-14  9:34             ` Sami Kerola
2017-01-14 22:51               ` J William Piggott
2017-01-22 19:03                 ` J William Piggott
2017-01-25 21:54                   ` Sami Kerola
2017-01-27  2:07                     ` J William Piggott
2017-02-02 15:04                       ` [ping] Karel: " J William Piggott
2017-02-03 22:41                         ` Sami Kerola
2017-02-11 17:10                           ` J William Piggott
2017-02-04 18:47                         ` Karel Zak
2017-02-05 22:37                           ` Sami Kerola
2017-02-09 10:43                         ` Karel Zak
2017-02-09 11:09                         ` Karel Zak
2017-02-11 17:10                           ` J William Piggott
2017-01-09 11:32       ` Karel Zak
2017-01-09 13:53         ` J William Piggott
2017-01-09 20:48           ` Bjarni Ingi Gislason

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20161231214107.8658-1-kerolasa@iki.fi \
    --to=kerolasa@iki.fi \
    --cc=util-linux@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.