From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752081AbdBJH41 (ORCPT ); Fri, 10 Feb 2017 02:56:27 -0500 Received: from merlin.infradead.org ([205.233.59.134]:39268 "EHLO merlin.infradead.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751106AbdBJH4X (ORCPT ); Fri, 10 Feb 2017 02:56:23 -0500 Date: Fri, 10 Feb 2017 08:55:23 +0100 From: Peter Zijlstra To: Byungchul Park Cc: mingo@kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] sched: Enhance readability of iterating wake_list Message-ID: <20170210075523.GF6515@twins.programming.kicks-ass.net> References: <1486699771-8007-1-git-send-email-byungchul.park@lge.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1486699771-8007-1-git-send-email-byungchul.park@lge.com> User-Agent: Mutt/1.5.23.1 (2014-03-12) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Feb 10, 2017 at 01:09:31PM +0900, Byungchul Park wrote: > +#define for_each_wake_list(task, node) \ > + for ((task) = llist_entry((node), struct task_struct, wake_entry); \ > + node; (node) = llist_next(node), \ > + (task) = llist_entry((node), struct task_struct, wake_entry)) > + How about you make that llist_for_each(pos, member) or similar and replace all while (foo) { foo = llist_next(foo); } instances? Because most llist_next() users have the same pattern.