From: Jeff Cody <jcody@redhat.com>
To: John Snow <jsnow@redhat.com>
Cc: Paolo Bonzini <pbonzini@redhat.com>,
qemu-block@nongnu.org, kwolf@redhat.com, pkrempa@redhat.com,
qemu-devel@nongnu.org
Subject: Re: [Qemu-devel] [PATCH 3/3] blockjob: expose manual-cull property
Date: Tue, 3 Oct 2017 13:43:05 -0400 [thread overview]
Message-ID: <20171003174305.GG4501@localhost.localdomain> (raw)
In-Reply-To: <84555a15-9ec6-2b28-a118-c209c97efd45@redhat.com>
On Tue, Oct 03, 2017 at 11:59:28AM -0400, John Snow wrote:
>
>
> On 10/03/2017 11:57 AM, Paolo Bonzini wrote:
> > On 03/10/2017 05:15, John Snow wrote:
> >> For drive-backup and blockdev-backup, expose the manual-cull
> >> property, having it default to false. There are no universal
> >> creation parameters, so it must be added to each job type that
> >> it makes sense for individually.
> >>
> >> Signed-off-by: John Snow <jsnow@redhat.com>
>
> [...]
>
> >
> > The verb "cull" is a bit weird. The only alternative that comes to mind
> > though are "reap" (like processes). There's also "join" (like threads),
> > but would imply waiting if the jobs hasn't completed yet, and we
> > probably don't want it.
> >
> > Paolo
> >
>
> Sure, open to suggestions. I think Kevin suggested "delete" which I have
> reservations about because of people potentially confusing it with
> "cancel" or "complete" -- it does not have the capacity to
> end/terminate/finish/complete/cancel a job.
>
> "reap" might be fine. I don't really have any strong preference.
>
As far as verbs go, I like both 'reap' and 'delete'. As far as the
property, naming it 'manual_verb' is a bit odd, too. Maybe a clearer term
for the property would just be 'persistent', with the QMP command being
'block_job_reap' or 'block_job_delete'?
-Jeff
next prev parent reply other threads:[~2017-10-03 17:43 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-10-03 3:15 [Qemu-devel] [PATCH 0/3] blockjobs: add explicit job culling John Snow
2017-10-03 3:15 ` [Qemu-devel] [PATCH 1/3] blockjob: add manual-cull property John Snow
2017-10-03 3:15 ` [Qemu-devel] [PATCH 2/3] qmp: add block-job-cull command John Snow
2017-10-03 3:15 ` [Qemu-devel] [PATCH 3/3] blockjob: expose manual-cull property John Snow
2017-10-03 15:57 ` Paolo Bonzini
2017-10-03 15:59 ` John Snow
2017-10-03 17:43 ` Jeff Cody [this message]
2017-10-04 1:32 ` John Snow
2017-10-03 9:20 ` [Qemu-devel] [PATCH 0/3] blockjobs: add explicit job culling Vladimir Sementsov-Ogievskiy
2017-10-03 14:42 ` John Snow
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171003174305.GG4501@localhost.localdomain \
--to=jcody@redhat.com \
--cc=jsnow@redhat.com \
--cc=kwolf@redhat.com \
--cc=pbonzini@redhat.com \
--cc=pkrempa@redhat.com \
--cc=qemu-block@nongnu.org \
--cc=qemu-devel@nongnu.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.