From: Peter Xu <peterx@redhat.com>
To: David Gibson <david@gibson.dropbear.id.au>
Cc: "Michael S . Tsirkin" <mst@redhat.com>,
Eduardo Habkost <ehabkost@redhat.com>,
Marcel Apfelbaum <marcel@redhat.com>,
Igor Mammedov <imammedo@redhat.com>,
qemu-devel@nongnu.org
Subject: Re: [Qemu-devel] [for-2.12 1/7] pci: Rename root bus initialization functions for clarity
Date: Fri, 1 Dec 2017 12:27:34 +0800 [thread overview]
Message-ID: <20171201042734.GA2712@xz-mi> (raw)
In-Reply-To: <20171201000250.GB30161@umbus.fritz.box>
On Fri, Dec 01, 2017 at 11:02:50AM +1100, David Gibson wrote:
> On Thu, Nov 30, 2017 at 02:17:21PM +0800, Peter Xu wrote:
> > On Wed, Nov 29, 2017 at 07:46:22PM +1100, David Gibson wrote:
> > > pci_bus_init(), pci_bus_new_inplace(), pci_bus_new() and pci_register_bus()
> > > are misleadingly named. They're not used for initializing *any* PCI bus,
> > > but only for a root PCI bus.
> > >
> > > Non-root buses - i.e. ones under a logical PCI to PCI bridge - are instead
> > > created with a direct qbus_create_inplace() (see pci_bridge_initfn()).
> > >
> > > This patch renames the functions to make it clear they're only used for
> > > a root bus.
> > >
> > > Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
> >
> > An optional nit: would it be nice to name the new functions as:
> > pci_bus_root_*()? Say, I would prefer pci_bus_root_new() than
> > pci_root_bus_new() since root bus is still a specific type of bus.
>
> Hrm,. *_bus_root_* reads very strangely to me, I find it less clear
> than ..._root_bus_...
Sure. I'm also fine to keep it the old way. Thanks,
--
Peter Xu
next prev parent reply other threads:[~2017-12-01 16:37 UTC|newest]
Thread overview: 47+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-11-29 8:46 [Qemu-devel] [for-2.12 0/7] PCI cleanups David Gibson
2017-11-29 8:46 ` [Qemu-devel] [for-2.12 1/7] pci: Rename root bus initialization functions for clarity David Gibson
2017-11-29 9:43 ` Marcel Apfelbaum
2017-11-30 6:17 ` Peter Xu
2017-12-01 0:02 ` David Gibson
2017-12-01 4:27 ` Peter Xu [this message]
2017-11-29 8:46 ` [Qemu-devel] [for-2.12 2/7] pci: Move bridge data structures from pci_bus.h to pci_bridge.h David Gibson
2017-11-29 10:33 ` Marcel Apfelbaum
2017-11-30 6:41 ` Peter Xu
2017-11-29 8:46 ` [Qemu-devel] [for-2.12 3/7] pci: Fold pci_bus.h into pci.h David Gibson
2017-11-29 10:38 ` Marcel Apfelbaum
2017-11-30 4:02 ` David Gibson
2017-11-30 5:56 ` Peter Xu
2017-11-30 10:25 ` Marcel Apfelbaum
2017-12-01 16:29 ` Michael S. Tsirkin
2017-12-02 0:59 ` David Gibson
2017-12-03 5:07 ` Michael S. Tsirkin
2017-12-04 4:01 ` David Gibson
2017-12-04 4:40 ` David Gibson
2017-11-29 8:46 ` [Qemu-devel] [for-2.12 4/7] pci: Simplify pci_bus_is_root() David Gibson
2017-11-29 10:45 ` Marcel Apfelbaum
2017-11-29 13:12 ` David Gibson
2017-11-29 14:42 ` Marcel Apfelbaum
2017-11-30 6:23 ` Peter Xu
2017-12-01 4:25 ` David Gibson
2017-11-29 8:46 ` [Qemu-devel] [for-2.12 5/7] pci: Add pci_dev_bus_num() helper David Gibson
2017-11-29 10:48 ` Marcel Apfelbaum
2017-11-30 6:42 ` Peter Xu
2017-11-29 8:46 ` [Qemu-devel] [for-2.12 6/7] pci: Eliminate redundant PCIDevice::bus pointer David Gibson
2017-11-29 10:54 ` Marcel Apfelbaum
2017-11-29 11:41 ` Eduardo Habkost
2017-11-29 13:15 ` David Gibson
2017-11-29 14:43 ` Marcel Apfelbaum
2017-11-30 6:31 ` Peter Xu
2017-11-29 8:46 ` [Qemu-devel] [for-2.12 7/7] pci: Eliminate pci_find_primary_bus() David Gibson
2017-11-29 10:56 ` Marcel Apfelbaum
2017-11-30 6:39 ` Peter Xu
2017-11-29 9:02 ` [Qemu-devel] [for-2.12 0/7] PCI cleanups no-reply
2017-11-29 9:18 ` Fam Zheng
2017-11-29 10:11 ` David Gibson
2017-12-05 4:49 ` Michael S. Tsirkin
2017-12-05 5:05 ` Fam Zheng
2017-12-05 5:11 ` David Gibson
2017-12-05 6:46 ` Fam Zheng
2017-12-05 13:06 ` David Gibson
2017-12-05 13:42 ` Fam Zheng
2017-12-05 23:14 ` David Gibson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20171201042734.GA2712@xz-mi \
--to=peterx@redhat.com \
--cc=david@gibson.dropbear.id.au \
--cc=ehabkost@redhat.com \
--cc=imammedo@redhat.com \
--cc=marcel@redhat.com \
--cc=mst@redhat.com \
--cc=qemu-devel@nongnu.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.